# Problem create Engine - Enterprise Search encountered an error. Check Kibana Server logs for details

**URL:** <https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835>\
**Category:** Elastic Search\
**Tags:** docker, elastic-app-search\
**Created:** [August 28, 2023, 5:50pm UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835 "2023-08-28T17:50:03Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![PustyB](https://avatars.discourse-cdn.com/v4/letter/p/c67d28/32.png) [@PustyB](https://discuss.elastic.co/u/PustyB)\
**Post date:** [August 28, 2023, 5:50pm UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/1 "2023-08-28T17:50:03Z")

</div>

Hi. I have a problem with creating an engine. When creating a new index-based engine, this problem pops up:

_Enterprise Search encountered an error. Check Kibana Server logs for details._

In the kibana logs I find something like this:

```auto
[2023-08-28T17:45:08.300+00:00][ERROR][plugins.enterpriseSearch] An error occurred while resolving request to https://example.com/internal/enterprise_search/search_indices: Enterprise Search encountered an error.
[2023-08-28T17:45:08.302+00:00][ERROR][plugins.enterpriseSearch] ResponseError: index_closed_exception
	Root causes:
		index_closed_exception: closed
    at KibanaTransport.request (/usr/share/kibana/node_modules/@elastic/transport/lib/Transport.js:479:27)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at KibanaTransport.request (/usr/share/kibana/node_modules/@kbn/core-elasticsearch-client-server-internal/src/create_transport.js:51:16)
    at Indices.stats (/usr/share/kibana/node_modules/@elastic/elasticsearch/lib/api/api/indices.js:1401:16)
    at fetchIndexStats (/usr/share/kibana/node_modules/@kbn/enterprise-search-plugin/server/lib/indices/fetch_index_stats.js:17:7)
    at fetchSearchIndices (/usr/share/kibana/node_modules/@kbn/enterprise-search-plugin/server/lib/indices/fetch_indices.js:31:24)
    at /usr/share/kibana/node_modules/@kbn/enterprise-search-plugin/server/routes/enterprise_search/indices.js:64:21
    at /usr/share/kibana/node_modules/@kbn/enterprise-search-plugin/server/utils/elasticsearch_error_handler.js:21:14
    at Router.handle (/usr/share/kibana/node_modules/@kbn/core-http-router-server-internal/src/router.js:146:30)
    at handler (/usr/share/kibana/node_modules/@kbn/core-http-router-server-internal/src/router.js:112:50)
    at exports.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:60:28)
    at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:371:32)
    at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:281:9)

```

When creating managed docs engine I don't have such problem.

Kubernetes cluster on bare metal  
Version 8.9.0.

---

<div class="post-metadata">

**Author:** ![Sean\_Story](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sean_story/32/69987_2.png) [@Sean\_Story](https://discuss.elastic.co/u/Sean_Story)\
**Post date:** [August 28, 2023, 5:59pm UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/2 "2023-08-28T17:59:24Z")

</div>

Is the relevant index closed? And have you tried to [open](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-open-close.html) it first?

---

<div class="post-metadata">

**Author:** ![PustyB](https://avatars.discourse-cdn.com/v4/letter/p/c67d28/32.png) [@PustyB](https://discuss.elastic.co/u/PustyB)\
**Post date:** [August 28, 2023, 8:07pm UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/3 "2023-08-28T20:07:11Z")

</div>

Okay it's true.  
I checked all the indexes using `GET /_cat/indices?pretty` and one was closed. I opened it by `POST /<target>/_open` and it worked.  
In that case, for App Search to work then all indexes must always be open? I can't have any closed indexes?

The closed index was created by me and has no relation to Enterprise Search

---

<div class="post-metadata">

**Author:** ![Sean\_Story](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sean_story/32/69987_2.png) [@Sean\_Story](https://discuss.elastic.co/u/Sean_Story)\
**Post date:** [August 28, 2023, 9:04pm UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/4 "2023-08-28T21:04:57Z")

</div>

The closed index was not the index you were trying to build the App Search Engine off of?

Can we talk in specifics? What was the name of your index with the data you wanted to search through App Search, and what index was closed?

Also, what version are you on? I will try to reproduce.

> for App Search to work then all indexes must always be open?

I don't believe that should be the case, no. App Search needs access to the `.ent-search-*` indices that Enterprise Search manages, as well as the index that you're trying to build an Engine off of, in the case of Elasticsearch Index App Search Engines. Outside of that, I'd expect things to work fine if unrelated indices are closed.

---

<div class="post-metadata">

**Author:** ![PustyB](https://avatars.discourse-cdn.com/v4/letter/p/c67d28/32.png) [@PustyB](https://discuss.elastic.co/u/PustyB)\
**Post date:** [August 29, 2023, 6:27am UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/5 "2023-08-29T06:27:40Z")

</div>

Sure.  
The index was called test-logstash-rabbitmq-01, because that's what I called it to myself.  
It was the only one that was closed, the rest were as open. I opened it and it worked.

It was not the index from which I wanted to make a search engine. I couldn't even do any indexing because when I clicked Continue there, it immediately threw an error on the next page. It didn't load any indexes.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/6/568ad8d2f6cc987d1e974eb62e944a671591c5bb.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 26, 2023, 6:28am UTC](https://discuss.elastic.co/t/problem-create-engine-enterprise-search-encountered-an-error-check-kibana-server-logs-for-details/341835/6 "2023-09-26T06:28:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
