# Problem ignoring fields

**URL:** https://discuss.elastic.co/t/problem-ignoring-fields/7032
**Category:** Elasticsearch
**Created:** [March 16, 2012, 4:58pm UTC](https://discuss.elastic.co/t/problem-ignoring-fields/7032 "2012-03-16T16:58:30Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Shashi](https://avatars.discourse-cdn.com/v4/letter/s/ecb155/32.png) [@Shashi](https://discuss.elastic.co/u/Shashi)
#### Post date: [March 16, 2012, 4:58pm UTC](https://discuss.elastic.co/t/problem-ignoring-fields/7032/1 "2012-03-16T16:58:30Z")

</div>

Hello Everyone,

How can I ignore all new fields in Elastic Search?

I have created mapping and loaded data in to ES, and things are fine.  
Some of the data of mine comes from client, and different clients send  
data in different formats.

I am seeing a new field these days, and some clients sent that in  
number format, and some in date. I think ES first looked at number and  
updated the mapping as "long". Now all the documents that have date  
are failing to get updated with number format exception.

My Issue is, the data I am interested in is already mapped by me. I  
don't worry if new fields get indexed or not, but I don't want an  
operation to fail with exceptions.

For example, if my initial mapping is for  
{user : "shashi"}

and if two other documents are  
{user : "shashi", created : 133333}, and {user : "ramu", created:  
"2012-03-15T00:04:29.054Z"}

I at least want the "user" field to be indexed, as I am mainly  
interested in that. I don't mine if rest is indexed or not, and I  
don't know about those additional fields in advance.

What do I need to do?

Thanks in advance,  
Shashi

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [March 17, 2012, 10:38am UTC](https://discuss.elastic.co/t/problem-ignoring-fields/7032/2 "2012-03-17T10:38:57Z")

</div>

Check the dynamic option here:  
[Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/reference/mapping/object-type.html) (you  
can place it at the root object). You can set it to false, and it will  
ignore anything that is not mapped by you.

On Fri, Mar 16, 2012 at 6:58 PM, Shashi [shaship2@gmail.com](mailto:shaship2@gmail.com) wrote:

> Hello Everyone,
> 
> How can I ignore all new fields in Elastic Search?
> 
> I have created mapping and loaded data in to ES, and things are fine.  
> Some of the data of mine comes from client, and different clients send  
> data in different formats.
> 
> I am seeing a new field these days, and some clients sent that in  
> number format, and some in date. I think ES first looked at number and  
> updated the mapping as "long". Now all the documents that have date  
> are failing to get updated with number format exception.
> 
> My Issue is, the data I am interested in is already mapped by me. I  
> don't worry if new fields get indexed or not, but I don't want an  
> operation to fail with exceptions.
> 
> For example, if my initial mapping is for  
> {user : "shashi"}
> 
> and if two other documents are  
> {user : "shashi", created : 133333}, and {user : "ramu", created:  
> "2012-03-15T00:04:29.054Z"}
> 
> I at least want the "user" field to be indexed, as I am mainly  
> interested in that. I don't mine if rest is indexed or not, and I  
> don't know about those additional fields in advance.
> 
> What do I need to do?
> 
> Thanks in advance,  
> Shashi

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:35am UTC](https://discuss.elastic.co/t/problem-ignoring-fields/7032/3 "2017-07-06T03:35:46Z")

</div>


