# Problem importing wikipedia dump after ES upgrade

**URL:** <https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751>\
**Category:** Elasticsearch\
**Created:** [November 21, 2016, 3:51pm UTC](https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751 "2016-11-21T15:51:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![geppo](https://avatars.discourse-cdn.com/v4/letter/g/3be4f8/32.png) [@geppo](https://discuss.elastic.co/u/geppo)\
**Post date:** [November 21, 2016, 3:51pm UTC](https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751/1 "2016-11-21T15:51:53Z")

</div>

HI to everybody,  
This morning i have upgraded to the new elasticsearch 5, and I have found some troubles to import wikipedia dump in ES. I have followed the procedure described in this thread [http://stackoverflow.com/questions/33630222/indexing-wikipedia-dump-to-elasticsearch-gets-xml-document-structures-must-start](http://stackoverflow.com/questions/33630222/indexing-wikipedia-dump-to-elasticsearch-gets-xml-document-structures-must-start) , that i have used succesfully with ES 2.x . But now the process ends before to finish the indexing. Then I can't make any kind of search in sense, all queries return me this output:

`Request failed to get to the server (status code: 0):`

If I try to restart the ES daemon, I can't make any query to my index but the output changes:  
`{ "error": { "root_cause": [], "type": "search_phase_execution_exception", "reason": "all shards failed", "phase": "query", "grouped": true, "failed_shards": [], "caused_by": { "type": "illegal_index_shard_state_exception", "reason": "CurrentState[RECOVERING] operations only allowed when shard state is one of [POST_RECOVERY, STARTED, RELOCATED]", "index_uuid": "8z18WSAtQkW1ONMjHCWEmg", "shard": "4", "index": "wikiparse" } }, "status": 503 }`

All of this happens after a clean installation. What can I do to fix that?  
Thanks in advance

---

<div class="post-metadata">

**Author:** ![cbuescher](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cbuescher/32/60402_2.png) [@cbuescher](https://discuss.elastic.co/u/cbuescher)\
**Post date:** [November 21, 2016, 3:58pm UTC](https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751/2 "2016-11-21T15:58:57Z")

</div>

I did this myself a while back and ran into issues as well. The mappings that you get when you follow this procedure are most likely still 2.x mappings (thats what wikipedia uses so far I think). There have been a few changes to the mapping api in 5.0, so unless wikipedia is moving to 5.x soon the only option I see is fixing the mappings (and other breaking stuff) by hand. What's wrong with the mappings might be apparent from your logs.

---

<div class="post-metadata">

**Author:** ![geppo](https://avatars.discourse-cdn.com/v4/letter/g/3be4f8/32.png) [@geppo](https://discuss.elastic.co/u/geppo)\
**Post date:** [November 22, 2016, 1:11pm UTC](https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751/3 "2016-11-22T13:11:18Z")

</div>

You give to me a good suggestion. Reading my logs I have understood that my problem was only a java heap space. For indexing wikipedia you need only to change "type":"string" in "type":"text" in mapping. So I have solved in this way

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 20, 2016, 1:12pm UTC](https://discuss.elastic.co/t/problem-importing-wikipedia-dump-after-es-upgrade/66751/4 "2016-12-20T13:12:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
