# Problem In Wrapper

**URL:** <https://discuss.elastic.co/t/problem-in-wrapper/6856>\
**Category:** Elasticsearch\
**Created:** [March 1, 2012, 5:30pm UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856 "2012-03-01T17:30:52Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kenneth\_Loafman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kenneth_loafman/32/2224_2.png) [@Kenneth\_Loafman](https://discuss.elastic.co/u/Kenneth_Loafman)\
**Post date:** [March 1, 2012, 5:30pm UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/1 "2012-03-01T17:30:52Z")

</div>

Hi,

I am getting the following errors in wrapper.log. They don't seem to be  
affecting anything, but I'd like to know what it means, and report that the  
formatting is wrong, there's no filename presented.

...Thanks,  
...Ken

ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
invalid string token for queued logging: Unable to write to the configured  
log directory: %s (%s)  
ERROR | wrapper | 2012/03/01 10:05:15 | The directory does not exist.  
ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
invalid string token for queued logging: Unable to write to the configured  
log file: %s (%s)  
ERROR | wrapper | 2012/03/01 10:05:15 | Falling back to the default  
file in the current working directory: %s  
STATUS | wrapper | 2012/03/01 10:05:15 | --\> Wrapper Started as Daemon  
STATUS | wrapper | 2012/03/01 10:05:15 | Java Service Wrapper Community  
Edition 64-bit 3.5.6  
STATUS | wrapper | 2012/03/01 10:05:15 | Copyright (C) 1999-2010 Tanuki  
Software, Ltd. All Rights Reserved.  
STATUS | wrapper | 2012/03/01 10:05:15 |  
[http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
STATUS | wrapper | 2012/03/01 10:05:15 |  
STATUS | wrapper | 2012/03/01 10:05:16 | Launching a JVM...  
INFO | jvm 1 | 2012/03/01 10:05:16 | WrapperManager: Initializing...

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [March 3, 2012, 9:39pm UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/2 "2012-03-03T21:39:03Z")

</div>

Mmmm, not sure what it means, will try and chase it up...

On Thursday, March 1, 2012 at 7:30 PM, Kenneth Loafman wrote:

> Hi,
> 
> I am getting the following errors in wrapper.log. They don't seem to be affecting anything, but I'd like to know what it means, and report that the formatting is wrong, there's no filename presented.
> 
> ...Thanks,  
> ...Ken
> 
> ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains invalid string token for queued logging: Unable to write to the configured log directory: %s (%s)  
> ERROR | wrapper | 2012/03/01 10:05:15 | The directory does not exist.  
> ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains invalid string token for queued logging: Unable to write to the configured log file: %s (%s)  
> ERROR | wrapper | 2012/03/01 10:05:15 | Falling back to the default file in the current working directory: %s  
> STATUS | wrapper | 2012/03/01 10:05:15 | --\> Wrapper Started as Daemon  
> STATUS | wrapper | 2012/03/01 10:05:15 | Java Service Wrapper Community Edition 64-bit 3.5.6  
> STATUS | wrapper | 2012/03/01 10:05:15 | Copyright (C) 1999-2010 Tanuki Software, Ltd. All Rights Reserved.  
> STATUS | wrapper | 2012/03/01 10:05:15 | [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> STATUS | wrapper | 2012/03/01 10:05:15 |  
> STATUS | wrapper | 2012/03/01 10:05:16 | Launching a JVM...  
> INFO | jvm 1 | 2012/03/01 10:05:16 | WrapperManager: Initializing...

---

<div class="post-metadata">

**Author:** ![Leif\_Mortenson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leif_mortenson/32/3192_2.png) [@Leif\_Mortenson](https://discuss.elastic.co/u/Leif_Mortenson)\
**Post date:** [March 4, 2012, 11:19am UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/3 "2012-03-04T11:19:46Z")

</div>

Kennith,  
Sorry for the trouble. This is a known Wrapper bug that was fixed in  
version 3.5.14. From the Wrapper's Release notes:

* * *

## Fix a problem on UNIX platforms where some asynchronous messages were causing a warning message "Coding Error..." to be logged in place of the intended message. This could be seen if the configured log file[http://wrapper.tanukisoftware.com/doc/english/prop-logfile.html](http://wrapper.tanukisoftware.com/doc/english/prop-logfile.html)did not have 'write' permissions. Other than the incorrect log message, the Wrapper worked correctly. Introduced in 3.5.2.

> **[Release Notes - Java Service Wrapper](https://wrapper.tanukisoftware.com/doc/english/release-notes.html)**

Cheers,  
Leif

On Friday, March 2, 2012 2:30:52 AM UTC+9, Kenneth Loafman wrote:

> Hi,
> 
> I am getting the following errors in wrapper.log. They don't seem to be  
> affecting anything, but I'd like to know what it means, and report that the  
> formatting is wrong, there's no filename presented.
> 
> ...Thanks,  
> ...Ken
> 
> ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
> invalid string token for queued logging: Unable to write to the configured  
> log directory: %s (%s)  
> ERROR | wrapper | 2012/03/01 10:05:15 | The directory does not exist.  
> ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
> invalid string token for queued logging: Unable to write to the configured  
> log file: %s (%s)  
> ERROR | wrapper | 2012/03/01 10:05:15 | Falling back to the default  
> file in the current working directory: %s  
> STATUS | wrapper | 2012/03/01 10:05:15 | --\> Wrapper Started as Daemon  
> STATUS | wrapper | 2012/03/01 10:05:15 | Java Service Wrapper Community  
> Edition 64-bit 3.5.6  
> STATUS | wrapper | 2012/03/01 10:05:15 | Copyright (C) 1999-2010 Tanuki  
> Software, Ltd. All Rights Reserved.  
> STATUS | wrapper | 2012/03/01 10:05:15 |  
> [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> STATUS | wrapper | 2012/03/01 10:05:15 |  
> STATUS | wrapper | 2012/03/01 10:05:16 | Launching a JVM...  
> INFO | jvm 1 | 2012/03/01 10:05:16 | WrapperManager: Initializing...

---

<div class="post-metadata">

**Author:** ![Kenneth\_Loafman\_2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kenneth_loafman_2/32/2224_2.png) [@Kenneth\_Loafman\_2](https://discuss.elastic.co/u/Kenneth_Loafman_2)\
**Post date:** [March 5, 2012, 7:51pm UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/4 "2012-03-05T19:51:52Z")

</div>

Leif,

Thanks for the response. I got the version I'm using, 3.5.6, from the  
following command:  
curl -L  
[http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master](http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master)  
and that's what I was reporting against. I did not realize there was  
another repository.

...Ken

On Sun, Mar 4, 2012 at 5:19 AM, Leif Mortenson [leif@tanukisoftware.com](mailto:leif@tanukisoftware.com)wrote:

> Kennith,  
> Sorry for the trouble. This is a known Wrapper bug that was fixed in  
> version 3.5.14. From the Wrapper's Release notes:
> 
> * * *
> 
> ## Fix a problem on UNIX platforms where some asynchronous messages were causing a warning message "Coding Error..." to be logged in place of the intended message. This could be seen if the configured log file[http://wrapper.tanukisoftware.com/doc/english/prop-logfile.html](http://wrapper.tanukisoftware.com/doc/english/prop-logfile.html)did not have 'write' permissions. Other than the incorrect log message, the Wrapper worked correctly. Introduced in 3.5.2.
> 
> [Release Notes - Java Service Wrapper](http://wrapper.tanukisoftware.com/doc/english/release-notes.html#3.5.14)
> 
> Cheers,  
> Leif
> 
> On Friday, March 2, 2012 2:30:52 AM UTC+9, Kenneth Loafman wrote:
> 
> > Hi,
> > 
> > I am getting the following errors in wrapper.log. They don't seem to be  
> > affecting anything, but I'd like to know what it means, and report that the  
> > formatting is wrong, there's no filename presented.
> > 
> > ...Thanks,  
> > ...Ken
> > 
> > ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
> > invalid string token for queued logging: Unable to write to the configured  
> > log directory: %s (%s)  
> > ERROR | wrapper | 2012/03/01 10:05:15 | The directory does not exist.  
> > ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains  
> > invalid string token for queued logging: Unable to write to the configured  
> > log file: %s (%s)  
> > ERROR | wrapper | 2012/03/01 10:05:15 | Falling back to the default  
> > file in the current working directory: %s  
> > STATUS | wrapper | 2012/03/01 10:05:15 | --\> Wrapper Started as Daemon  
> > STATUS | wrapper | 2012/03/01 10:05:15 | Java Service Wrapper Community  
> > Edition 64-bit 3.5.6  
> > STATUS | wrapper | 2012/03/01 10:05:15 | Copyright (C) 1999-2010  
> > Tanuki Software, Ltd. All Rights Reserved.  
> > STATUS | wrapper | 2012/03/01 10:05:15 |  
> > [http://wrapper.tanukisoftware](http://wrapper.tanukisoftware).\*\*com [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> > STATUS | wrapper | 2012/03/01 10:05:15 |  
> > STATUS | wrapper | 2012/03/01 10:05:16 | Launching a JVM...  
> > INFO | jvm 1 | 2012/03/01 10:05:16 | WrapperManager: Initializing...

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [March 5, 2012, 8:33pm UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/5 "2012-03-05T20:33:31Z")

</div>

There is a new version of the Java Service Wrapper, that repo simply needs to be updated to the latest version of it.

On Monday, March 5, 2012 at 9:51 PM, Kenneth Loafman wrote:

> Leif,
> 
> Thanks for the response. I got the version I'm using, 3.5.6, from the following command:  
> curl -L [http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master](http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master)  
> and that's what I was reporting against. I did not realize there was another repository.
> 
> ...Ken
> 
> On Sun, Mar 4, 2012 at 5:19 AM, Leif Mortenson \<[leif@tanukisoftware.com](mailto:leif@tanukisoftware.com) ([mailto:leif@tanukisoftware.com](mailto:leif@tanukisoftware.com))\> wrote:
> 
> > Kennith,  
> > Sorry for the trouble. This is a known Wrapper bug that was fixed in version 3.5.14. From the Wrapper's Release notes:
> > 
> > * * *
> > 
> > ## Fix a problem on UNIX platforms where some asynchronous messages were causing a warning message "Coding Error..." to be logged in place of the intended message. This could be seen if the configured log file ([wrapper.logfile Property - Java Service Wrapper](http://wrapper.tanukisoftware.com/doc/english/prop-logfile.html)) did not have 'write' permissions. Other than the incorrect log message, the Wrapper worked correctly. Introduced in 3.5.2.
> > 
> > [Release Notes - Java Service Wrapper](http://wrapper.tanukisoftware.com/doc/english/release-notes.html#3.5.14)
> > 
> > Cheers,  
> > Leif
> > 
> > On Friday, March 2, 2012 2:30:52 AM UTC+9, Kenneth Loafman wrote:
> > 
> > > Hi,
> > > 
> > > I am getting the following errors in wrapper.log. They don't seem to be affecting anything, but I'd like to know what it means, and report that the formatting is wrong, there's no filename presented.
> > > 
> > > ...Thanks,  
> > > ...Ken
> > > 
> > > ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains invalid string token for queued logging: Unable to write to the configured log directory: %s (%s)  
> > > ERROR | wrapper | 2012/03/01 10:05:15 | The directory does not exist.  
> > > ERROR | wrapper | 2012/03/01 10:05:15 | Coding Error. String contains invalid string token for queued logging: Unable to write to the configured log file: %s (%s)  
> > > ERROR | wrapper | 2012/03/01 10:05:15 | Falling back to the default file in the current working directory: %s  
> > > STATUS | wrapper | 2012/03/01 10:05:15 | --\> Wrapper Started as Daemon  
> > > STATUS | wrapper | 2012/03/01 10:05:15 | Java Service Wrapper Community Edition 64-bit 3.5.6  
> > > STATUS | wrapper | 2012/03/01 10:05:15 | Copyright (C) 1999-2010 Tanuki Software, Ltd. All Rights Reserved.  
> > > STATUS | wrapper | 2012/03/01 10:05:15 | [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> > > STATUS | wrapper | 2012/03/01 10:05:15 |  
> > > STATUS | wrapper | 2012/03/01 10:05:16 | Launching a JVM...  
> > > INFO | jvm 1 | 2012/03/01 10:05:16 | WrapperManager: Initializing...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:37am UTC](https://discuss.elastic.co/t/problem-in-wrapper/6856/6 "2017-07-06T03:37:15Z")

</div>


