# Problem java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

**URL:** <https://discuss.elastic.co/t/problem-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/223051>\
**Category:** Logstash\
**Created:** [March 11, 2020, 5:50am UTC](https://discuss.elastic.co/t/problem-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/223051 "2020-03-11T05:50:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tnahsoe](https://avatars.discourse-cdn.com/v4/letter/t/3da27b/32.png) [@Tnahsoe](https://discuss.elastic.co/u/Tnahsoe)\
**Post date:** [March 11, 2020, 5:50am UTC](https://discuss.elastic.co/t/problem-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/223051/1 "2020-03-11T05:50:59Z")

</div>

When I try to start logstash using  
/usr/share/logstash$ bin/logstash -e 'input{stdin{}}output{stdout{}}'

it gives

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.9.0.jar) to method sun.nio.ch.NativeThread.signal(long)  
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
[FATAL] 2020-03-11 11:20:13.488 [main] runner - An unexpected error occurred! {:error=\>#\<ArgumentError: Path "/usr/share/logstash/data" must be a writable directory. It is not writable.\>, :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:489:in `validate'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:271:in `validate\_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:182:in `block in validate_all'", "org/jruby/RubyHash.java:1428:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:181:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:284:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:242:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:73:in `'"]}  
[ERROR] 2020-03-11 11:20:13.516 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![ITIC](https://avatars.discourse-cdn.com/v4/letter/i/90ced4/32.png) [@ITIC](https://discuss.elastic.co/u/ITIC)\
**Post date:** [March 11, 2020, 6:42am UTC](https://discuss.elastic.co/t/problem-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/223051/2 "2020-03-11T06:42:55Z")

</div>

Hi

You seem to have several issues. The main one is probably this:

```auto
<ArgumentError: Path "/usr/share/logstash/data" must be a writable directory. It is not writable.>

```

Hope this helps

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 8, 2020, 6:42am UTC](https://discuss.elastic.co/t/problem-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/223051/3 "2020-04-08T06:42:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
