# Problem starting Elasticsearch process

**URL:** <https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078>\
**Category:** Elasticsearch\
**Created:** [March 2, 2017, 2:37am UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078 "2017-03-02T02:37:55Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![adityajain19](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adityajain19/32/23171_2.png) [@adityajain19](https://discuss.elastic.co/u/adityajain19)\
**Post date:** [March 2, 2017, 2:37am UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/1 "2017-03-02T02:37:55Z")

</div>

Hi,

we are trying to start out elasticsearch process

sudo service elasticsearch start  
sudo service elasticsearch status gives following

[root@efkkibapp31d x-pack]# sudo service elasticsearch status -l  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2017-03-01 21:34:47 EST; 15s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 29341 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 29339 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 29341 (code=exited, status=1/FAILURE)

Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.elasticsearch.cli.Command.main(Command.java:88)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: Exception in thread "main" java.lang.NullPointerException  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.apache.logging.log4j.core.config.composite.DefaultMergeStrategy.mergeRootProp...ava:72)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc elasticsearch[29341]: at org.apache.logging.log4j.core.config.composite.CompositeConfiguration.(Comp...ava:77)  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc systemd[1]: Unit elasticsearch.service entered failed state.  
Mar 01 21:34:47 efkkibapp31d.amtrak.ad.nrpc systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

Cant find anything in log.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 2, 2017, 3:16am UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/2 "2017-03-02T03:16:08Z")

</div>

> [@adityajain19](#):
>
> Cant find anything in log

Which log?

What version are you on? What OS? What JVM? What settings have you changed?

---

<div class="post-metadata">

**Author:** ![adityajain19](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adityajain19/32/23171_2.png) [@adityajain19](https://discuss.elastic.co/u/adityajain19)\
**Post date:** [March 2, 2017, 3:19am UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/3 "2017-03-02T03:19:28Z")

</div>

I am not getting anything in elasticsearch log.

Elastic version 5.1.1  
Unix I installed and un installed the xpack.

Regards  
Aditya

---

<div class="post-metadata">

**Author:** ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)\
**Post date:** [March 2, 2017, 8:44am UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/4 "2017-03-02T08:44:09Z")

</div>

Can you check log: /var/log/messages ?

---

<div class="post-metadata">

**Author:** ![adityajain19](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adityajain19/32/23171_2.png) [@adityajain19](https://discuss.elastic.co/u/adityajain19)\
**Post date:** [March 2, 2017, 9:38pm UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/5 "2017-03-02T21:38:34Z")

</div>

Thanks @xavierfacq I see the exception there and fixed it.

Regards  
Aditya

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 30, 2017, 9:38pm UTC](https://discuss.elastic.co/t/problem-starting-elasticsearch-process/77078/6 "2017-03-30T21:38:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
