# Problem to get xml response with http\_poller plugin

**URL:** <https://discuss.elastic.co/t/problem-to-get-xml-response-with-http-poller-plugin/263749>\
**Category:** Logstash\
**Created:** [February 9, 2021, 2:32pm UTC](https://discuss.elastic.co/t/problem-to-get-xml-response-with-http-poller-plugin/263749 "2021-02-09T14:32:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hiba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hiba/32/110919_2.png) [@hiba](https://discuss.elastic.co/u/hiba)\
**Post date:** [February 9, 2021, 2:32pm UTC](https://discuss.elastic.co/t/problem-to-get-xml-response-with-http-poller-plugin/263749/1 "2021-02-09T14:32:39Z")

</div>

Hi all,

I want to load data from an api rest (response xml) using logstash 7.9.0  
this is my config file:

input {  
http\_poller {

```
			urls => {
			 
				 method => get
				 url1 => "https:// ******* /rest/1.0/geography"
				 user =>" *********.com"
				 password =>" ******"
					}
			    schedule => { every => "70s" }
				request_timeout => 60
				codec => "plain"
			 }
	
     }

```

filter {  
xml {  
source =\> "message"  
force\_array =\> false  
target =\> "parsed"  
}  
}

output {

```
	elasticsearch {
			hosts => "localhost:9200"
			index => "cities"
			user => elastic
			password => *****
			action => "insert"
			doc_as_upsert => "true"
		
	}

stdout {codec => dots}

```

}

this is the error:

C:\ELK\ELK.7.9.0\logstash-7.9.0\logstash-7.9.0\bin\>logstash -f cities.conf  
Sending Logstash logs to C:/ELK/ELK.7.9.0/logstash-7.9.0/logstash-7.9.0/logs which is now configured via log4j2.properties  
[2021-02-09T15:29:58,961][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.9.0", "jruby.version"=\>"jruby 9.2.12.0 (2.5.7) 2020-07-01 db01a49ba6 Java HotSpot(TM) 64-Bit Server VM 25.211-b12 on 1.8.0\_211-b12 +indy +jit [mswin32-x86\_64]"}  
[2021-02-09T15:29:59,223][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2021-02-09T15:30:01,267][INFO][org.reflections.Reflections] Reflections took 37 ms to scan 1 urls, producing 22 keys and 45 values  
[2021-02-09T15:30:02,247][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://elastic:xxxxxx@localhost:9200/](http://elastic:xxxxxx@localhost:9200/)]}}  
[2021-02-09T15:30:02,457][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=\>"[http://elastic:xxxxxx@localhost:9200/](http://elastic:xxxxxx@localhost:9200/)"}  
[2021-02-09T15:30:02,499][INFO][logstash.outputs.elasticsearch][main] ES Output version determined {:es\_version=\>7}  
[2021-02-09T15:30:02,502][WARN][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2021-02-09T15:30:02,578][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2021-02-09T15:30:02,603][INFO][logstash.outputs.elasticsearch][main] Using a default mapping template {:es\_version=\>7, :ecs\_compatibility=\>:disabled}  
[2021-02-09T15:30:02,680][INFO][logstash.outputs.elasticsearch][main] Attempting to install template {:manage\_template=\>{"index\_patterns"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s", "number\_of\_shards"=\>1}, "mappings"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}  
[2021-02-09T15:30:02,903][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-02-09T15:30:07,808][INFO][logstash.runner] Logstash shut down.  
[2021-02-09T15:30:07,824][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Any help please !!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 9, 2021, 2:33pm UTC](https://discuss.elastic.co/t/problem-to-get-xml-response-with-http-poller-plugin/263749/2 "2021-03-09T14:33:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
