# Problem to run ElasticSearch on Azure

**URL:** <https://discuss.elastic.co/t/problem-to-run-elasticsearch-on-azure/1733>\
**Category:** Elasticsearch\
**Created:** [June 2, 2015, 2:20pm UTC](https://discuss.elastic.co/t/problem-to-run-elasticsearch-on-azure/1733 "2015-06-02T14:20:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mrcode](https://avatars.discourse-cdn.com/v4/letter/m/aeb1de/32.png) [@mrcode](https://discuss.elastic.co/u/mrcode)\
**Post date:** [June 2, 2015, 2:20pm UTC](https://discuss.elastic.co/t/problem-to-run-elasticsearch-on-azure/1733/1 "2015-06-02T14:20:06Z")

</div>

Hi,

i have follow this: [http://code972.com/blog/2014/07/74-the-definitive-guide-for-elasticsearch-on-windows-azure](http://code972.com/blog/2014/07/74-the-definitive-guide-for-elasticsearch-on-windows-azure)

And when i run: curl [http://localhost:9200](http://localhost:9200) i get: curl: (7) Failed to connect to localhost port 9200: Connection refused

And when i run: sudo /etc/init.d/elasticsearch status i get:

● elasticsearch.service - Starts and stops a single elasticsearch instance on this system  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Tue 2015-06-02 14:16:53 UTC; 9s ago  
Docs: [http://www.elasticsearch.org](http://www.elasticsearch.org)  
Process: 4328 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.default.config=$CONF\_FILE -Des.default.path.home=$ES\_HOME -Des.default.path.logs=$LOG\_DIR -Des.default.path.data=$DATA\_DIR -Des.default.path.work=$WORK\_DIR -Des.default.path.conf=$CONF\_DIR (code=exited, status=3)  
Main PID: 4328 (code=exited, status=3)

Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: log4j:WARN Please initialize the log4j system properly.  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: log4j:WARN See [http://logging.apache.org/log4j/1.2/faq.html#noconfig](http://logging.apache.org/log4j/1.2/faq.html#noconfig) for more info.  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: {1.5.2}: Initialization Failed ...  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: - ElasticsearchIllegalStateException[Failed to created node environment]  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: AccessDeniedException[/usr/share/elasticsearch/data]  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: org.elasticsearch.ElasticsearchIllegalStateException: Failed to created node environment  
Jun 02 14:16:53 MyDevSearch-01 elasticsearch[4328]: at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:162)  
Jun 02 14:16:53 MyDevSearch-01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=3/NOTIMPLEMENTED  
Jun 02 14:16:53 MyDevSearch-01 systemd[1]: Unit elasticsearch.service entered failed state.  
Jun 02 14:16:53 MyDevSearch-01 systemd[1]: elasticsearch.service failed.

Whats wrong with this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:10am UTC](https://discuss.elastic.co/t/problem-to-run-elasticsearch-on-azure/1733/2 "2017-07-06T00:10:11Z")

</div>


