# Problem to start logstash : java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

**URL:** <https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017>\
**Category:** Logstash\
**Created:** [October 4, 2018, 9:56am UTC](https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017 "2018-10-04T09:56:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![morihend](https://avatars.discourse-cdn.com/v4/letter/m/e9bcb4/32.png) [@morihend](https://discuss.elastic.co/u/morihend)\
**Post date:** [October 4, 2018, 9:56am UTC](https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017/1 "2018-10-04T09:56:12Z")

</div>

Hello,

I use windows logstash 6.4.0 version.  
My logstash service worked untill i install the input-jdbc plugin.  
Now, when i tape in my terminal window this : bin\logstash.bat to start logstash i obtained this mistack message :  
Sending Logstash logs to C:/UwAmp/www/logstash-6.4.0/logs which is now configured via log4j2.properties  
ERROR: Pipelines YAML file is empty. Location: C:/UwAmp/www/logstash-6.4.0/config/pipelines.yml  
usage:  
bin/logstash -f CONFIG\_PATH [-t] [-r] [] [-w COUNT] [-l LOG]  
bin/logstash --modules MODULE\_NAME [-M "MODULE\_NAME.var.PLUGIN\_TYPE.PLUGIN\_NAME.VARIABLE\_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]  
bin/logstash -e CONFIG\_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]  
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash --help  
[2018-10-04T11:50:40,871][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Thanks in avance to help me.

Rod.

---

<div class="post-metadata">

**Author:** ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)\
**Post date:** [October 4, 2018, 11:26am UTC](https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017/2 "2018-10-04T11:26:18Z")

</div>

> [@morihend](#):
>
> ERROR: Pipelines YAML file is empty

That' your problem. Does your pipelines.yml file exist? Are there any permissions on it? Is it empty?

---

<div class="post-metadata">

**Author:** ![morihend](https://avatars.discourse-cdn.com/v4/letter/m/e9bcb4/32.png) [@morihend](https://discuss.elastic.co/u/morihend)\
**Post date:** [October 4, 2018, 1:02pm UTC](https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017/3 "2018-10-04T13:02:37Z")

</div>

Thanks Andreas.  
I have solved my problem.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2018, 1:02pm UTC](https://discuss.elastic.co/t/problem-to-start-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/151017/4 "2018-11-01T13:02:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
