# Problem when installing elk 8.5.1

**URL:** <https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072>\
**Category:** Elasticsearch\
**Created:** [November 16, 2022, 12:14pm UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072 "2022-11-16T12:14:12Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Neelam\_Zanvar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/neelam_zanvar/32/103116_2.png) [@Neelam\_Zanvar](https://discuss.elastic.co/u/Neelam_Zanvar)\
**Post date:** [November 16, 2022, 12:14pm UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/1 "2022-11-16T12:14:12Z")

</div>

Hi i am trying to install elk stack 8.5.1 on amazon linux 2 redhat. When i try to start the service getting the following error

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/3/b3da74c74a33bd0d1c30e06b0e1f80fe02c42181.png)  
I have set xpack.security.enabled: true  
discovery-type: single-node  
xpack.security.transport.ssl.enabled: false  
.  
what are the expected configurations? i dont have ssl certificate for this machine

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 16, 2022, 12:18pm UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/2 "2022-11-16T12:18:31Z")

</div>

Hello,

Please do not share screenshots of error messages, they are pretty hard to read sometimes and some people may not be even able to read it.

Share the error log as plain text using the `</>` button in the editor.

---

<div class="post-metadata">

**Author:** ![Neelam\_Zanvar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/neelam_zanvar/32/103116_2.png) [@Neelam\_Zanvar](https://discuss.elastic.co/u/Neelam_Zanvar)\
**Post date:** [November 16, 2022, 12:26pm UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/3 "2022-11-16T12:26:10Z")

</div>

sorry for the inconvenience

```auto
 fatal exception while booting Elasticsearch
org.elasticsearch.ElasticsearchSecurityException: invalid configuration for xpack.security.transport.ssl - [xpack.security.transport.ssl.enabled] is not set, but the following settings have been configured in elasticsearch.yml : [xpack.security.transport.ssl.keystore.secure_password,xpack.security.transport.ssl.truststore.secure_password]

```

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 16, 2022, 1:18pm UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/4 "2022-11-16T13:18:48Z")

</div>

Can you share your entire `elasticsearch.yml`?

Also, share the entire Elasticsearch error log, what you shared now is completely different from the error in your image.

---

<div class="post-metadata">

**Author:** ![Neelam\_Zanvar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/neelam_zanvar/32/103116_2.png) [@Neelam\_Zanvar](https://discuss.elastic.co/u/Neelam_Zanvar)\
**Post date:** [November 17, 2022, 5:27am UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/5 "2022-11-17T05:27:45Z")

</div>

The problem was fixed. the old elasticsearch.yml file wasnt getting updated. I am installing elastic stack with authentication using ansible playbook. The same isnt working for 8.5.1. Can you please share how to setup authentication for elk 8.5.1?

---

<div class="post-metadata">

**Author:** ![Neelam\_Zanvar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/neelam_zanvar/32/103116_2.png) [@Neelam\_Zanvar](https://discuss.elastic.co/u/Neelam_Zanvar)\
**Post date:** [November 17, 2022, 7:32am UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/6 "2022-11-17T07:32:46Z")

</div>

For older version my playbook was running fine. But for 8.5.1 if i disable authentication i am prompted for token, which is don't see when i install elasticsearch using playbook

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 15, 2022, 7:33am UTC](https://discuss.elastic.co/t/problem-when-installing-elk-8-5-1/319072/7 "2022-12-15T07:33:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
