# Problem with centos 7 install

**URL:** <https://discuss.elastic.co/t/problem-with-centos-7-install/261941>\
**Category:** Elasticsearch\
**Created:** [January 22, 2021, 4:55pm UTC](https://discuss.elastic.co/t/problem-with-centos-7-install/261941 "2021-01-22T16:55:34Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cyrduf](https://avatars.discourse-cdn.com/v4/letter/c/bbe5ce/32.png) [@cyrduf](https://discuss.elastic.co/u/cyrduf)\
**Post date:** [January 22, 2021, 4:55pm UTC](https://discuss.elastic.co/t/problem-with-centos-7-install/261941/1 "2021-01-22T16:55:35Z")

</div>

Hello,

I have some problems after elasticsearch installation on centos 7 VM.

There is the log and if you can help me to solve.

Best Regards

[root@localhost log]# sudo yum install -y elasticsearch

Modules complémentaires chargés : fastestmirror, langpacks

Loading mirror speeds from cached hostfile

- base: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

- extras: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

- updates: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

[https://artifacts.elastic.co/packages/7.x/centos/repodata/repomd.xml:](https://artifacts.elastic.co/packages/7.x/centos/repodata/repomd.xml:) [Errno  
14] HTTPS Error 404 - Not Found

Essai d'un autre miroir.

To address this issue please refer to the below wiki article

> **[yum-errors - CentOS Wiki](https://wiki.centos.org/yum-errors)**

If above article doesn't help to resolve this issue please use  
[https://bugs.centos.org/](https://bugs.centos.org/).

Résolution des dépendances

--\> Lancement de la transaction de test

---\> Le paquet elasticsearch.x86\_64 0:7.10.2-1 sera installé

--\> Résolution des dépendances terminée

Dépendances résolues

# ============================================================================

Package Architecture Version  
Dépôt Taille

# ============================================================================

Installation :

elasticsearch x86\_64 7.10.2-1  
elasticsearch-7.x 304 M

Résumé de la transaction

# ============================================================================

Installation 1 Paquet

Taille totale des téléchargements : 304 M

Taille d'installation : 510 M

Downloading packages:

elasticsearch-7.10.2-x86\_64.rp FAILED

[https://artifacts.elastic.co/packages/7.x/centos/7.10.2/elasticsearch-7.10.2](https://artifacts.elastic.co/packages/7.x/centos/7.10.2/elasticsearch-7.10.2)  
-x86\_64.rpm: [Errno 14] HTTPS Error 404 - Not Found

Essai d'un autre miroir.

Error downloading packages:

elasticsearch-7.10.2-1.x86\_64: [Errno 256] No more mirrors to try.

[root@localhost log]# sudo kwrite /etc/yum.repos.d/elasticsearch.repo

[root@localhost log]# sudo yum install -y elasticsearch

Modules complémentaires chargés : fastestmirror, langpacks

Loading mirror speeds from cached hostfile

- base: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

- extras: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

- updates: [centos.mirrors.proxad.net](http://centos.mirrors.proxad.net)

elasticsearch-7.x  
| 1.3 kB 00:00:00

Résolution des dépendances

--\> Lancement de la transaction de test

---\> Le paquet elasticsearch.x86\_64 0:7.10.2-1 sera installé

--\> Résolution des dépendances terminée

Dépendances résolues

# ============================================================================

Package Architecture Version  
Dépôt Taille

# ============================================================================

Installation :

elasticsearch x86\_64 7.10.2-1  
elasticsearch-7.x 304 M

Résumé de la transaction

# ============================================================================

Installation 1 Paquet

Taille totale des téléchargements : 304 M

Taille d'installation : 510 M

Downloading packages:

elasticsearch-7.10.2-x86\_64.rpm  
| 304 MB 00:01:49

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

Creating elasticsearch group...groupadd: cannot open /etc/group

OK

Creating elasticsearch user...useradd: group 'elasticsearch' does not exist

OK

Installation : elasticsearch-7.10.2-1.x86\_64  
1/1

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: user elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

warning: user elasticsearch does not exist - using root

warning: group elasticsearch does not exist - using root

### NOT starting on installation, please execute the following statements to

configure elasticsearch service to start automatically using systemd

sudo systemctl daemon-reload

sudo systemctl enable elasticsearch.service

### You can start elasticsearch service by executing

sudo systemctl start elasticsearch.service

Created elasticsearch keystore in /etc/elasticsearch/elasticsearch.keystore

chown: groupe incorrect: « root:elasticsearch »

Vérification : elasticsearch-7.10.2-1.x86\_64  
1/1

Installé :

elasticsearch.x86\_64 0:7.10.2-1

Terminé !

[root@localhost log]# sudo kwrite /etc/elasticsearch/jvm.options

[root@localhost log]# sudo kwrite /etc/elasticsearch/elasticsearch.yml

[root@localhost log]# systemctl daemon-reload

[root@localhost log]# getenforce

Enforcing

[root@localhost log]# getsebool -a | grep httpd\_use\_nfs

httpd\_use\_nfs --\> off

[root@localhost log]# setsebool -P httpd\_use\_nfs on

[root@localhost log]# getsebool -a | grep httpd\_use\_nfs

httpd\_use\_nfs --\> on

[root@localhost log]# systemctl enable elasticsearch.service

Created symlink from  
/etc/systemd/system/multi-user.target.wants/elasticsearch.service to  
/usr/lib/systemd/system/elasticsearch.service.

[root@localhost log]# systemctl start elasticsearch.service

Job for elasticsearch.service failed because the control process exited with  
error code. See "systemctl status elasticsearch.service" and "journalctl  
-xe" for details.

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]#

[root@localhost log]# journalctl -xel

janv. 15 21:36:51 localhost.localdomain kernel: SELinux: 2048 avtab hash  
slots, 112730 rules.

janv. 15 21:36:51 localhost.localdomain kernel: SELinux: 8 users, 14 roles,  
5046 types, 316 bools, 1 sens, 1024 cats

janv. 15 21:36:51 localhost.localdomain kernel: SELinux: 130 classes,  
112730 rules

janv. 15 21:36:51 localhost.localdomain kernel: SELinux: Converting 2509  
SID table entries...

janv. 15 21:36:52 localhost.localdomain dbus[649]: [system] Reloaded  
configuration

janv. 15 21:36:53 localhost.localdomain dbus[2438]: avc: received  
policyload notice (seqno=7)

janv. 15 21:36:53 localhost.localdomain dbus[2009]: avc: received  
policyload notice (seqno=7)

janv. 15 21:36:53 localhost.localdomain dbus[649]: [system] Reloaded  
configuration

janv. 15 21:36:53 localhost.localdomain org.a11y.Bus[2009]: Reloaded  
configuration

janv. 15 21:36:53 localhost.localdomain setsebool[8433]: The httpd\_use\_nfs  
policy boolean was changed to on by root

janv. 15 21:37:15 localhost.localdomain polkitd[658]: Registered  
Authentication Agent for unix-process:8441:790577 (system bus n

janv. 15 21:37:15 localhost.localdomain systemd[1]: Reloading.

janv. 15 21:37:15 localhost.localdomain polkitd[658]: Unregistered  
Authentication Agent for unix-process:8441:790577 (system bus

janv. 15 21:37:22 localhost.localdomain polkitd[658]: Registered  
Authentication Agent for unix-process:8467:791279 (system bus n

janv. 15 21:37:22 localhost.localdomain systemd[1]: Starting  
Elasticsearch...

-- Subject: L'unité (unit) elasticsearch.service a commencé à démarrer

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

--

-- L'unité (unit) elasticsearch.service a commencé à démarrer.

janv. 15 21:37:22 localhost.localdomain systemd[8474]: Failed at step USER  
spawning /usr/share/elasticsearch/bin/systemd-entrypo

-- Subject: Le processus /usr/share/elasticsearch/bin/systemd-entrypoint n'a  
pas pu être exécuté

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

--

-- Le processus /usr/share/elasticsearch/bin/systemd-entrypoint n'a pas pu  
être exécuté, et a donc échoué.

--

-- Le code d'erreur renvoyé est 3.

janv. 15 21:37:22 localhost.localdomain systemd[1]: elasticsearch.service:  
main process exited, code=exited, status=217/USER

janv. 15 21:37:22 localhost.localdomain systemd[1]: Failed to start  
Elasticsearch.

-- Subject: L'unité (unit) elasticsearch.service a échoué

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

--

-- L'unité (unit) elasticsearch.service a échoué, avec le résultat failed.

janv. 15 21:37:22 localhost.localdomain systemd[1]: Unit  
elasticsearch.service entered failed state.

janv. 15 21:37:22 localhost.localdomain systemd[1]: elasticsearch.service  
failed.

janv. 15 21:37:22 localhost.localdomain polkitd[658]: Unregistered  
Authentication Agent for unix-process:8467:791279 (system bus

lines 2491-2528/2528 (END)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 24, 2021, 11:56pm UTC](https://discuss.elastic.co/t/problem-with-centos-7-install/261941/2 "2021-01-24T23:56:41Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 21, 2021, 11:56pm UTC](https://discuss.elastic.co/t/problem-with-centos-7-install/261941/3 "2021-02-21T23:56:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
