# Problem with EQL queries

**URL:** <https://discuss.elastic.co/t/problem-with-eql-queries/250266>\
**Category:** Elasticsearch\
**Created:** [September 28, 2020, 11:22pm UTC](https://discuss.elastic.co/t/problem-with-eql-queries/250266 "2020-09-28T23:22:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Yenii\_Ceri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yenii_ceri/32/76297_2.png) [@Yenii\_Ceri](https://discuss.elastic.co/u/Yenii_Ceri)\
**Post date:** [September 28, 2020, 11:22pm UTC](https://discuss.elastic.co/t/problem-with-eql-queries/250266/1 "2020-09-28T23:22:17Z")

</div>

Hey

I have an issue with EQL queries on Elasticsearch.  
I have a basic ES license with xpack enabled, in addition to some Winlogbeat indexes with ECS syntax.  
However, I don't get any hit when I execute some EQL queries such as:

```auto
GET /winlogbeat-*/_eql/search
{
  "query": """
    process where process.name == "cmd.exe"
  """
}

```

However, I do have in my winlogbeat indexes events of _process creation_ with _"cmd.exe."_  
This is just an example, and I tested many other EQL queries but with no results.  
I wonder if EQL requires some specific configuration in Elasticsearch or regarding the index template.

I really appreciate any help you can provide.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 26, 2020, 11:22pm UTC](https://discuss.elastic.co/t/problem-with-eql-queries/250266/2 "2020-10-26T23:22:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
