# Problem with index-pattern id when recreating index

**URL:** <https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087>\
**Category:** Kibana\
**Created:** [July 17, 2019, 8:44pm UTC](https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087 "2019-07-17T20:44:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jjfbcn](https://avatars.discourse-cdn.com/v4/letter/j/7cd45c/32.png) [@jjfbcn](https://discuss.elastic.co/u/jjfbcn)\
**Post date:** [July 17, 2019, 8:44pm UTC](https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087/1 "2019-07-17T20:44:58Z")

</div>

After recreating index stats-\* all the saved objects (visualizations, dashboards,...) are failing to load with error:  
Could not locate that index-pattern (id: 70ea4880-815b-11e9-a33a-156632c3253a), click here to re-create it

When I check with query:  
POST .kibana/\_search  
{  
"query": {  
"term": {  
"type": {  
"value": "index-pattern"  
}  
}  
}  
}

{  
"took" : 0,  
"timed\_out" : false,  
"\_shards" : {  
"total" : 1,  
"successful" : 1,  
"skipped" : 0,  
"failed" : 0  
},  
"hits" : {  
"total" : 1,  
"max\_score" : 2.9123507,  
"hits" : [  
{  
"\_index" : ".kibana\_1",  
"\_type" : "doc",  
"\_id" : "index-pattern:853edd20-a8b4-11e9-85c3-6d5ebd116eca",  
"\_score" : 2.9123507,  
...

looks like index-pattern has changed  
70ea4880-815b-11e9-a33a-156632c3253a  
for  
853edd20-a8b4-11e9-85c3-6d5ebd116eca

...but why? how can I fix it?

If I go to Saved Objects and change the pattern-id manually the visualization gets fixed, should I go manually to each saved object and change the pattern-id??

Thank you for your help,

Juanjo.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [July 18, 2019, 5:00pm UTC](https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087/2 "2019-07-18T17:00:27Z")

</div>

When creating an index pattern there is an option under the "Advanced" tab that allows you to specify the ID. There you could specify the ID that it had before: `70ea4880-815b-11e9-a33a-156632c3253a`

---

<div class="post-metadata">

**Author:** ![jjfbcn](https://avatars.discourse-cdn.com/v4/letter/j/7cd45c/32.png) [@jjfbcn](https://discuss.elastic.co/u/jjfbcn)\
**Post date:** [July 18, 2019, 5:14pm UTC](https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087/3 "2019-07-18T17:14:07Z")

</div>

Thank you Marius.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 15, 2019, 5:14pm UTC](https://discuss.elastic.co/t/problem-with-index-pattern-id-when-recreating-index/191087/4 "2019-08-15T17:14:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
