# Problem with Kibana unable to load Dashboards

**URL:** <https://discuss.elastic.co/t/problem-with-kibana-unable-to-load-dashboards/228325>\
**Category:** Kibana\
**Created:** [April 16, 2020, 1:23pm UTC](https://discuss.elastic.co/t/problem-with-kibana-unable-to-load-dashboards/228325 "2020-04-16T13:23:24Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chandrashekar467](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chandrashekar467/32/63539_2.png) [@Chandrashekar467](https://discuss.elastic.co/u/Chandrashekar467)\
**Post date:** [April 16, 2020, 1:23pm UTC](https://discuss.elastic.co/t/problem-with-kibana-unable-to-load-dashboards/228325/1 "2020-04-16T13:23:24Z")

</div>

Hi all,

I have installed metric-beat , but unable to load he kibana dashboard for mongodb.

i am getting below error,  
[10.0.1.1:9300][indices:data/read/search[phase/query]]  
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [service.address] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.  
at org.elasticsearch.index.mapper.TextFieldMapper$TextFieldType.fielddataBuilder(TextFieldMapper.java:759) ~[elasticsearch-7.5.0.jar:7.5.0]

---

<div class="post-metadata">

**Author:** ![Magnus\_Kessler](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnus_kessler/32/42001_2.png) [@Magnus\_Kessler](https://discuss.elastic.co/u/Magnus_Kessler)\
**Post date:** [April 16, 2020, 3:17pm UTC](https://discuss.elastic.co/t/problem-with-kibana-unable-to-load-dashboards/228325/2 "2020-04-16T15:17:07Z")

</div>

Please check that the metricbeat index template was installed before the first data was sent to the index. In the default configuration of metricbeat sending data directly to Elasticsearch this should happen automatically before the first index is created, but if you send data through e.g. Logstash, you'll have to take some additional manual steps first.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 14, 2020, 3:17pm UTC](https://discuss.elastic.co/t/problem-with-kibana-unable-to-load-dashboards/228325/3 "2020-05-14T15:17:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
