# Problem with logstash: java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

**URL:** <https://discuss.elastic.co/t/problem-with-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/238390>\
**Category:** Logstash\
**Created:** [June 24, 2020, 6:14am UTC](https://discuss.elastic.co/t/problem-with-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/238390 "2020-06-24T06:14:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![kase](https://avatars.discourse-cdn.com/v4/letter/k/a5b964/32.png) [@kase](https://discuss.elastic.co/u/kase)\
**Post date:** [June 24, 2020, 6:14am UTC](https://discuss.elastic.co/t/problem-with-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/238390/1 "2020-06-24T06:14:13Z")

</div>

Hi there,  
I'm using elastiflow with logstash, I've done these command in this url([https://www.catapultsystems.com/blogs/install-elastiflow-on-ubuntu-18-04-part-3/](https://www.catapultsystems.com/blogs/install-elastiflow-on-ubuntu-18-04-part-3/))  
And netflow data could came through logstash to elasticsearch successfully, after this I also wrote a config for elasticsearch to redis.  
logstash-plain.log told me there has some wrong in my comtumized config, but others is fine and logstash can work, also upgrade logstash 7.7 to 7.8.

```auto
apt update
apt upgrade logstash

```

so I stop logstash and fix my config and then restart it, but log outputs same error and fall into a cycle of restarting..., here is the log:

[2020-06-24T05:51:43,316][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.8.0", "jruby.version"=\>"jruby 9.2.11.1 (2.5.7) 2020-03-25 b1f55b1a40 OpenJDK 64-Bit Server VM 11.0.7+10-post-Ubuntu-2ubuntu218.04 on 11.0.7+10-post-Ubuntu-2ubuntu218.04 +indy +jit [linux-x86\_64]"}  
[2020-06-24T05:51:44,419][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=\>"/etc/logstash/conf.d/\*.conf"}  
[2020-06-24T05:51:54,528][INFO][org.reflections.Reflections] Reflections took 35 ms to scan 1 urls, producing 21 keys and 41 values  
[2020-06-24T05:51:59,128][ERROR][logstash.inputs.elasticsearch] Unknown setting 'port' for elasticsearch  
[2020-06-24T05:51:59,132][ERROR][logstash.inputs.elasticsearch] Unknown setting 'host' for elasticsearch  
[2020-06-24T05:51:59,141][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:elastiflow, :exception=\>"Java::JavaLang::IllegalStateException", :message=\>"Unable to configure plugins: (ConfigurationError) Something is wrong with your configuration.", :backtrace=\>["org.logstash.config.ir.CompiledPipeline.(CompiledPipeline.java:119)", "org.logstash.execution.JavaBasePipelineExt.initialize(JavaBasePipelineExt.java:80)", "org.logstash.execution.JavaBasePipelineExt$INVOKER$i$1$0$initialize.call(JavaBasePipelineExt$INVOKER$i$1$0$initialize.gen)", "org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:837)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuper(IRRuntimeHelpers.java:1169)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuperSplatArgs(IRRuntimeHelpers.java:1156)", "org.jruby.ir.targets.InstanceSuperInvokeSite.invoke(InstanceSuperInvokeSite.java:39)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.RUBY$method$initialize$0(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:43)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:82)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:332)", "org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:86)", "org.jruby.RubyClass.newInstance(RubyClass.java:939)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(RubyClass$INVOKER$i$newInstance.gen)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0(/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:52)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0$ **VARARGS** (/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:82)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.agent.RUBY$block$converge\_state$2(/usr/share/logstash/logstash-core/lib/logstash/agent.rb:342)", "org.jruby.runtime.CompiledIRBlockBody.callDirect(CompiledIRBlockBody.java:138)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:58)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:52)", "org.jruby.runtime.Block.call(Block.java:139)", "org.jruby.RubyProc.call(RubyProc.java:318)", "org.jruby.internal.runtime.RubyRunnable.run(RubyRunnable.java:105)", "java.base/java.lang.Thread.run(Thread.java:834)"]}  
[2020-06-24T05:51:59,162][ERROR][logstash.agent] An exception happened when converging configuration {:exception=\>LogStash::Error, :message=\>"Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<elastiflow>`", :backtrace=\>["org/logstash/execution/ConvergeResultExt.java:129:in `create'", "org/logstash/execution/ConvergeResultExt.java:57:in `add'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:355:in `block in converge_state'"]} [2020-06-24T05:51:59,199][FATAL][logstash.runner] An unexpected error occurred! {:error=>#<LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException`for`PipelineAction::Create`>, :backtrace=>["org/logstash/execution/ConvergeResultExt.java:129:in `create'", "org/logstash/execution/ConvergeResultExt.java:57:in `add'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:355:in `block in converge\_state'"]}  
[2020-06-24T05:51:59,218][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

I have tried

```auto
sudo /usr/share/logstash/bin/logstash-plugin update
sudo /usr/share/logstash/bin/logstash-plugin install logstash-filter-translate
sudo /usr/share/logstash/bin/logstash-plugin update logstash-filter-translate
systemctl daemon-reload
systemctl start logstash

```

and  
`reboot`

still don't work...does anyone how to solve this problem?  
Thanks  
Kase

---

<div class="post-metadata">

**Author:** ![kase](https://avatars.discourse-cdn.com/v4/letter/k/a5b964/32.png) [@kase](https://discuss.elastic.co/u/kase)\
**Post date:** [June 24, 2020, 6:29am UTC](https://discuss.elastic.co/t/problem-with-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/238390/2 "2020-06-24T06:29:53Z")

</div>

Okay, I found the answer...

my customized config looks like

```auto
input {
  # elasticsearch
  elasticsearch {
    id => "input_elasticsearch_netflow_redis"
    host => "10.250.31.42"
    port => "9200"
    index => "elastiflow-3.5.3-%{YYYY.MM.dd}"
.....
}

```

but elasticsearch input plugin don't has "port" "host" options, so I fixed it to

```auto
input {
  # elasticsearch
  elasticsearch {
    id => "input_elasticsearch_netflow_redis"
    hosts => "10.250.31.42:9200"
    index => "elastiflow-3.5.3-%{YYYY.MM.dd}"
......
}

```

and restart logstash, it works fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 22, 2020, 6:30am UTC](https://discuss.elastic.co/t/problem-with-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/238390/3 "2020-07-22T06:30:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
