# Problems configuring a custom analyzer plugin

**URL:** <https://discuss.elastic.co/t/problems-configuring-a-custom-analyzer-plugin/8358>\
**Category:** Elasticsearch\
**Created:** [July 9, 2012, 9:49am UTC](https://discuss.elastic.co/t/problems-configuring-a-custom-analyzer-plugin/8358 "2012-07-09T09:49:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![g3org](https://avatars.discourse-cdn.com/v4/letter/g/ee7513/32.png) [@g3org](https://discuss.elastic.co/u/g3org)\
**Post date:** [July 9, 2012, 9:49am UTC](https://discuss.elastic.co/t/problems-configuring-a-custom-analyzer-plugin/8358/1 "2012-07-09T09:49:58Z")

</div>

Hello everybody,

for migration of a legacy JSM-based analyzer to el (version 0.19.7) i would  
like to wrap the legacy code in a plugin. My plugin gets successfully  
loaded on startup but i fail to configure the analyzer correctly. I tried  
following configurations (based on default config witch distribution  
disabled):

1: index.analysis.analyzer.hda.type:  
org.mypackage.elasticsearch.HAnalyzerProvider  
2: index.analysis.analyzer.hda.type: "hda"

1: would startup without exception, but curl -XGET  
'localhost:9200/myIdx/\_analyze?analyzer=hda' -d 'some text' would return  
this result:{"error":"RemoteTransportException[[Namorita][inet[/192.168.x.y:9304]][indices/analyze/s]];  
nested: ElasticSearchIllegalArgumentException[failed to find analyzer  
[hda]]; ","status":400}, whereas the ip-adress does not equal my local  
machine's ip.

2: excepts on startup, tries to find a class named "hda" (see  
[http://pastebin.com/Ryk5x9Jz](http://pastebin.com/Ryk5x9Jz)). Note, that my implementation of  
AnalysisBinderProcessor binds "hda" to HAnalyzerProvider.class

I am not sure if my configuration is wrong or if there is a problem with  
the distribution. According to the documentation and other plugins (e.g. ik  
[https://github.com/medcl/elasticsearch-analysis-ik](https://github.com/medcl/elasticsearch-analysis-ik)) my configuration  
"should" work. Would somebody help me please?

Thanks in advance!

Cheers

Georg

---

<div class="post-metadata">

**Author:** ![g3org](https://avatars.discourse-cdn.com/v4/letter/g/ee7513/32.png) [@g3org](https://discuss.elastic.co/u/g3org)\
**Post date:** [July 9, 2012, 12:21pm UTC](https://discuss.elastic.co/t/problems-configuring-a-custom-analyzer-plugin/8358/2 "2012-07-09T12:21:17Z")

</div>

solved this: i did not properly invoke the binder processor.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:20am UTC](https://discuss.elastic.co/t/problems-configuring-a-custom-analyzer-plugin/8358/3 "2017-07-06T03:20:56Z")

</div>


