# Problems enabling security features

**URL:** <https://discuss.elastic.co/t/problems-enabling-security-features/290164>\
**Category:** Elastic Security\
**Created:** [November 25, 2021, 10:44am UTC](https://discuss.elastic.co/t/problems-enabling-security-features/290164 "2021-11-25T10:44:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![johnny1891](https://avatars.discourse-cdn.com/v4/letter/j/43a26b/32.png) [@johnny1891](https://discuss.elastic.co/u/johnny1891)\
**Post date:** [November 25, 2021, 10:44am UTC](https://discuss.elastic.co/t/problems-enabling-security-features/290164/1 "2021-11-25T10:44:05Z")

</div>

Hi,

I am trying to enable password so that I can create a super user to access some pages after enabling the EDR trial for 30 days in the license management page after setting up ELK stack.  
The reason is I got this error when going to Security-\>Endpoints

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/7/87539f0747eb5fa9c8e985dfb58e9e14a8e73b7d.png)

So then I ran this command: .\Elasticsearch-setup-passwords interactive  
and setup some passwords, but then once I start Kibana, I get this error:

```auto
[error][savedobjects-service] Unable to retrieve version information from Elasticsearch nodes. security_exception: [security_exception] Reason: missing authentication credentials for REST request [/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip]

```

Anyone have any ideas how I can fix this?

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [November 25, 2021, 3:26pm UTC](https://discuss.elastic.co/t/problems-enabling-security-features/290164/2 "2021-11-25T15:26:26Z")

</div>

Hi @johnny1891 welcome to the community.

Hopefully you are following the guide here it is really important if you just randomly try to setup security you will have issues

> **[Set up minimal security for Elasticsearch | Elasticsearch Guide \[7.15\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-minimal-setup.html#security-minimal-setup)**

Did you follow this step for setup the users in the kibana.yml so Kibana can connect with Elasticsearch

[Configure Kibana to connect to Elasticsearch with a password](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-minimal-setup.html#add-built-in-users)

---

<div class="post-metadata">

**Author:** ![johnny1891](https://avatars.discourse-cdn.com/v4/letter/j/43a26b/32.png) [@johnny1891](https://discuss.elastic.co/u/johnny1891)\
**Post date:** [November 25, 2021, 4:04pm UTC](https://discuss.elastic.co/t/problems-enabling-security-features/290164/3 "2021-11-25T16:04:05Z")

</div>

Hi,

That solved it. Thanks a lot!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 23, 2021, 4:04pm UTC](https://discuss.elastic.co/t/problems-enabling-security-features/290164/4 "2021-12-23T16:04:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
