# Problems upgrading an existing field to a multi-field

**URL:** <https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514>\
**Category:** Elasticsearch\
**Created:** [July 7, 2014, 11:15pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514 "2014-07-07T23:15:06Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ryan\_Tanner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_tanner/32/1059_2.png) [@Ryan\_Tanner](https://discuss.elastic.co/u/Ryan_Tanner)\
**Post date:** [July 7, 2014, 11:15pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/1 "2014-07-07T23:15:06Z")

</div>

I'm having trouble upgrading an existing field to a multi-field. I've done  
this before with no issues on other fields.

I think the issue here is that the original mapping specifically defines an  
analyzer:

"mappings" : {  
"person" : {  
"properties" : {  
"domain\_titles" : {  
"type" : "string",  
"analyzer" : "stop",  
"include\_in\_all" : true  
}  
}  
}  
}

The other fields that have been upgraded do not have an analyzer in the  
original mapping.

This is the upgrade I'm attempting:

{  
"settings" : {  
"index.analysis.filter.shingle\_filter.type" : "shingle",  
"index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
"index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
"index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
"index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
"index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
"shingle\_filter" ]  
},  
"mappings" : {  
"person" : {  
"properties" : {  
"domain\_titles" : {  
"type" : "string",  
"fields" : {  
"suggestions" : {  
"type" : "string",  
"index" : "analyzed",  
"include\_in\_all" : false,  
"analyzer" : "nicknameAnalyzer"  
}  
}  
}  
}  
}  
}  
}

Is there any reason why this sort of upgrade should fail? This is the  
error message I get:

{"error":"MergeMappingException[Merge failed with failures {[mapper  
[domain\_titles] has different index\_analyzer]}]","status":400}

Thanks for the help.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/e057498d-64ca-4f5f-a76c-0a4717b82b9b%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/e057498d-64ca-4f5f-a76c-0a4717b82b9b%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ryan\_Tanner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_tanner/32/1059_2.png) [@Ryan\_Tanner](https://discuss.elastic.co/u/Ryan_Tanner)\
**Post date:** [July 8, 2014, 6:31pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/2 "2014-07-08T18:31:32Z")

</div>

_bump_

Anyone?

On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:

> I'm having trouble upgrading an existing field to a multi-field. I've  
> done this before with no issues on other fields.
> 
> I think the issue here is that the original mapping specifically defines  
> an analyzer:
> 
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "analyzer" : "stop",  
> "include\_in\_all" : true  
> }  
> }  
> }  
> }
> 
> The other fields that have been upgraded do not have an analyzer in the  
> original mapping.
> 
> This is the upgrade I'm attempting:
> 
> {  
> "settings" : {  
> "index.analysis.filter.shingle\_filter.type" : "shingle",  
> "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> "index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
> "shingle\_filter" ]  
> },  
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "fields" : {  
> "suggestions" : {  
> "type" : "string",  
> "index" : "analyzed",  
> "include\_in\_all" : false,  
> "analyzer" : "nicknameAnalyzer"  
> }  
> }  
> }  
> }  
> }  
> }  
> }
> 
> Is there any reason why this sort of upgrade should fail? This is the  
> error message I get:
> 
> {"error":"MergeMappingException[Merge failed with failures {[mapper  
> [domain\_titles] has different index\_analyzer]}]","status":400}
> 
> Thanks for the help.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [July 8, 2014, 6:52pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/3 "2014-07-08T18:52:50Z")

</div>

Which version of ES are using? I believe we fixed a bug around this several versions ago.

On Jul 8, 2014, at 20:31, Ryan Tanner [ryan.tanner@gmail.com](mailto:ryan.tanner@gmail.com) wrote:

> _bump_
> 
> Anyone?
> 
> On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:  
> I'm having trouble upgrading an existing field to a multi-field. I've done this before with no issues on other fields.
> 
> I think the issue here is that the original mapping specifically defines an analyzer:
> 
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "analyzer" : "stop",  
> "include\_in\_all" : true  
> }  
> }  
> }  
> }
> 
> The other fields that have been upgraded do not have an analyzer in the original mapping.
> 
> This is the upgrade I'm attempting:
> 
> {  
> "settings" : {  
> "index.analysis.filter.shingle\_filter.type" : "shingle",  
> "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> "index.analysis.analyzer.shingle\_analyzer.filter" : ["lowercase","shingle\_filter"]  
> },  
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "fields" : {  
> "suggestions" : {  
> "type" : "string",  
> "index" : "analyzed",  
> "include\_in\_all" : false,  
> "analyzer" : "nicknameAnalyzer"  
> }  
> }  
> }  
> }  
> }  
> }  
> }
> 
> Is there any reason why this sort of upgrade should fail? This is the error message I get:
> 
> {"error":"MergeMappingException[Merge failed with failures {[mapper [domain\_titles] has different index\_analyzer]}]","status":400}
> 
> Thanks for the help.
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email [toelasticsearch+unsubscribe@googlegroups.com](mailto:toelasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/F39D649D-2C67-4B8A-B549-C10CBCCB3E51%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/F39D649D-2C67-4B8A-B549-C10CBCCB3E51%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ryan\_Tanner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_tanner/32/1059_2.png) [@Ryan\_Tanner](https://discuss.elastic.co/u/Ryan_Tanner)\
**Post date:** [July 8, 2014, 6:53pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/4 "2014-07-08T18:53:57Z")

</div>

1.1.1 in production but I tested this with 1.2.1 locally and had the same  
problem.

On Tuesday, July 8, 2014 12:53:14 PM UTC-6, kimchy wrote:

> Which version of ES are using? I believe we fixed a bug around this  
> several versions ago.
> 
> On Jul 8, 2014, at 20:31, Ryan Tanner \<[ryan....@gmail.com](mailto:ryan....@gmail.com) \<javascript:\>\>  
> wrote:
> 
> _bump_
> 
> Anyone?
> 
> On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:
> 
> > I'm having trouble upgrading an existing field to a multi-field. I've  
> > done this before with no issues on other fields.
> > 
> > I think the issue here is that the original mapping specifically defines  
> > an analyzer:
> > 
> > "mappings" : {  
> > "person" : {  
> > "properties" : {  
> > "domain\_titles" : {  
> > "type" : "string",  
> > "analyzer" : "stop",  
> > "include\_in\_all" : true  
> > }  
> > }  
> > }  
> > }
> > 
> > The other fields that have been upgraded do not have an analyzer in the  
> > original mapping.
> > 
> > This is the upgrade I'm attempting:
> > 
> > {  
> > "settings" : {  
> > "index.analysis.filter.shingle\_filter.type" : "shingle",  
> > "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> > "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> > "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> > "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> > "index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
> > "shingle\_filter" ]  
> > },  
> > "mappings" : {  
> > "person" : {  
> > "properties" : {  
> > "domain\_titles" : {  
> > "type" : "string",  
> > "fields" : {  
> > "suggestions" : {  
> > "type" : "string",  
> > "index" : "analyzed",  
> > "include\_in\_all" : false,  
> > "analyzer" : "nicknameAnalyzer"  
> > }  
> > }  
> > }  
> > }  
> > }  
> > }  
> > }
> > 
> > Is there any reason why this sort of upgrade should fail? This is the  
> > error message I get:
> > 
> > {"error":"MergeMappingException[Merge failed with failures {[mapper  
> > [domain\_titles] has different index\_analyzer]}]","status":400}
> > 
> > Thanks for the help.
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email [toelasticsearc...@googlegroups.com](mailto:toelasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/8c4afa1e-ab72-456f-aa3e-4848968613df%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/8c4afa1e-ab72-456f-aa3e-4848968613df%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ryan\_Tanner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_tanner/32/1059_2.png) [@Ryan\_Tanner](https://discuss.elastic.co/u/Ryan_Tanner)\
**Post date:** [July 8, 2014, 9:14pm UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/5 "2014-07-08T21:14:21Z")

</div>

Side question:

If I try to set lowercase\_terms to true, I get a 400 back saying  
"suggester[term] doesn't support [lowercase\_terms]" which seems to  
contradict the documentation.

```
  "suggest" : {
    "text" : "my query string",
    "person_name" : {
      "term" : {
        "field" : "name.suggestion",
        "size" : 1,
        "sort" : "score",
        "lowercase_terms" : true
      }
    }
  }

```

Fails against both 1.1.1 and 1.2.1.

On Tuesday, July 8, 2014 12:53:57 PM UTC-6, Ryan Tanner wrote:

> 1.1.1 in production but I tested this with 1.2.1 locally and had the same  
> problem.
> 
> On Tuesday, July 8, 2014 12:53:14 PM UTC-6, kimchy wrote:
> 
> > Which version of ES are using? I believe we fixed a bug around this  
> > several versions ago.
> > 
> > On Jul 8, 2014, at 20:31, Ryan Tanner [ryan....@gmail.com](mailto:ryan....@gmail.com) wrote:
> > 
> > _bump_
> > 
> > Anyone?
> > 
> > On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:
> > 
> > > I'm having trouble upgrading an existing field to a multi-field. I've  
> > > done this before with no issues on other fields.
> > > 
> > > I think the issue here is that the original mapping specifically defines  
> > > an analyzer:
> > > 
> > > "mappings" : {  
> > > "person" : {  
> > > "properties" : {  
> > > "domain\_titles" : {  
> > > "type" : "string",  
> > > "analyzer" : "stop",  
> > > "include\_in\_all" : true  
> > > }  
> > > }  
> > > }  
> > > }
> > > 
> > > The other fields that have been upgraded do not have an analyzer in the  
> > > original mapping.
> > > 
> > > This is the upgrade I'm attempting:
> > > 
> > > {  
> > > "settings" : {  
> > > "index.analysis.filter.shingle\_filter.type" : "shingle",  
> > > "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> > > "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> > > "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> > > "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> > > "index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
> > > "shingle\_filter" ]  
> > > },  
> > > "mappings" : {  
> > > "person" : {  
> > > "properties" : {  
> > > "domain\_titles" : {  
> > > "type" : "string",  
> > > "fields" : {  
> > > "suggestions" : {  
> > > "type" : "string",  
> > > "index" : "analyzed",  
> > > "include\_in\_all" : false,  
> > > "analyzer" : "nicknameAnalyzer"  
> > > }  
> > > }  
> > > }  
> > > }  
> > > }  
> > > }  
> > > }
> > > 
> > > Is there any reason why this sort of upgrade should fail? This is the  
> > > error message I get:
> > > 
> > > {"error":"MergeMappingException[Merge failed with failures {[mapper  
> > > [domain\_titles] has different index\_analyzer]}]","status":400}
> > > 
> > > Thanks for the help.
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email [toelasticsearc...@googlegroups.com](mailto:toelasticsearc...@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/f616d617-a443-4975-b8e0-92fc22cfba1f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f616d617-a443-4975-b8e0-92fc22cfba1f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Travis\_Bullock](https://avatars.discourse-cdn.com/v4/letter/t/35a633/32.png) [@Travis\_Bullock](https://discuss.elastic.co/u/Travis_Bullock)\
**Post date:** [September 20, 2014, 1:02am UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/6 "2014-09-20T01:02:28Z")

</div>

I have the same problem with lowercase\_terms. Is there a fix? The term  
suggester lowercases them by default (not desirable), and the completion  
suggester doesn't.

On Tuesday, July 8, 2014 4:14:22 PM UTC-5, Ryan Tanner wrote:

> Side question:
> 
> If I try to set lowercase\_terms to true, I get a 400 back saying  
> "suggester[term] doesn't support [lowercase\_terms]" which seems to  
> contradict the documentation.
> 
> ```
> "suggest" : {
> "text" : "my query string",
> "person_name" : {
> "term" : {
> "field" : "name.suggestion",
> "size" : 1,
> "sort" : "score",
> "lowercase_terms" : true
> }
> }
> }
> 
> ```
> 
> Fails against both 1.1.1 and 1.2.1.
> 
> On Tuesday, July 8, 2014 12:53:57 PM UTC-6, Ryan Tanner wrote:
> 
> > 1.1.1 in production but I tested this with 1.2.1 locally and had the same  
> > problem.
> > 
> > On Tuesday, July 8, 2014 12:53:14 PM UTC-6, kimchy wrote:
> > 
> > > Which version of ES are using? I believe we fixed a bug around this  
> > > several versions ago.
> > > 
> > > On Jul 8, 2014, at 20:31, Ryan Tanner [ryan....@gmail.com](mailto:ryan....@gmail.com) wrote:
> > > 
> > > _bump_
> > > 
> > > Anyone?
> > > 
> > > On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:
> > > 
> > > > I'm having trouble upgrading an existing field to a multi-field. I've  
> > > > done this before with no issues on other fields.
> > > > 
> > > > I think the issue here is that the original mapping specifically  
> > > > defines an analyzer:
> > > > 
> > > > "mappings" : {  
> > > > "person" : {  
> > > > "properties" : {  
> > > > "domain\_titles" : {  
> > > > "type" : "string",  
> > > > "analyzer" : "stop",  
> > > > "include\_in\_all" : true  
> > > > }  
> > > > }  
> > > > }  
> > > > }
> > > > 
> > > > The other fields that have been upgraded do not have an analyzer in the  
> > > > original mapping.
> > > > 
> > > > This is the upgrade I'm attempting:
> > > > 
> > > > {  
> > > > "settings" : {  
> > > > "index.analysis.filter.shingle\_filter.type" : "shingle",  
> > > > "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> > > > "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> > > > "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> > > > "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> > > > "index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
> > > > "shingle\_filter" ]  
> > > > },  
> > > > "mappings" : {  
> > > > "person" : {  
> > > > "properties" : {  
> > > > "domain\_titles" : {  
> > > > "type" : "string",  
> > > > "fields" : {  
> > > > "suggestions" : {  
> > > > "type" : "string",  
> > > > "index" : "analyzed",  
> > > > "include\_in\_all" : false,  
> > > > "analyzer" : "nicknameAnalyzer"  
> > > > }  
> > > > }  
> > > > }  
> > > > }  
> > > > }  
> > > > }  
> > > > }
> > > > 
> > > > Is there any reason why this sort of upgrade should fail? This is the  
> > > > error message I get:
> > > > 
> > > > {"error":"MergeMappingException[Merge failed with failures {[mapper  
> > > > [domain\_titles] has different index\_analyzer]}]","status":400}
> > > > 
> > > > Thanks for the help.
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google  
> > > Groups "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send  
> > > an email [toelasticsearc...@googlegroups.com](mailto:toelasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/3ffb1a0c-c1eb-4c2c-90f3-7d579aab7a41%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c1757b54-fb8c-4438-a4b4-70d500de1690%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c1757b54-fb8c-4438-a4b4-70d500de1690%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ryan\_Tanner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_tanner/32/1059_2.png) [@Ryan\_Tanner](https://discuss.elastic.co/u/Ryan_Tanner)\
**Post date:** [December 9, 2014, 1:03am UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/7 "2014-12-09T01:03:08Z")

</div>

_bump_

Does anyone know if upgrading an existing field with a specified analyzer  
to a multi-field has been fixed in the recent versions of Elasticsearch?

On Monday, July 7, 2014 5:15:06 PM UTC-6, Ryan Tanner wrote:

> I'm having trouble upgrading an existing field to a multi-field. I've  
> done this before with no issues on other fields.
> 
> I think the issue here is that the original mapping specifically defines  
> an analyzer:
> 
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "analyzer" : "stop",  
> "include\_in\_all" : true  
> }  
> }  
> }  
> }
> 
> The other fields that have been upgraded do not have an analyzer in the  
> original mapping.
> 
> This is the upgrade I'm attempting:
> 
> {  
> "settings" : {  
> "index.analysis.filter.shingle\_filter.type" : "shingle",  
> "index.analysis.filter.shingle\_filter.min\_shingle\_size" : 2,  
> "index.analysis.filter.shingle\_filter.max\_shingle\_size" : 5,  
> "index.analysis.analyzer.shingle\_analyzer.type" : "custom",  
> "index.analysis.analyzer.shingle\_analyzer.tokenizer" : "standard",  
> "index.analysis.analyzer.shingle\_analyzer.filter" : [ "lowercase",  
> "shingle\_filter" ]  
> },  
> "mappings" : {  
> "person" : {  
> "properties" : {  
> "domain\_titles" : {  
> "type" : "string",  
> "fields" : {  
> "suggestions" : {  
> "type" : "string",  
> "index" : "analyzed",  
> "include\_in\_all" : false,  
> "analyzer" : "nicknameAnalyzer"  
> }  
> }  
> }  
> }  
> }  
> }  
> }
> 
> Is there any reason why this sort of upgrade should fail? This is the  
> error message I get:
> 
> {"error":"MergeMappingException[Merge failed with failures {[mapper  
> [domain\_titles] has different index\_analyzer]}]","status":400}
> 
> Thanks for the help.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/f59655a2-1ffe-4d64-8e25-7113a264ecaa%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f59655a2-1ffe-4d64-8e25-7113a264ecaa%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:44am UTC](https://discuss.elastic.co/t/problems-upgrading-an-existing-field-to-a-multi-field/18514/8 "2017-07-06T00:44:47Z")

</div>


