# Problems upgrading elasticsearch from 5.6.1 to 6.3.2

**URL:** <https://discuss.elastic.co/t/problems-upgrading-elasticsearch-from-5-6-1-to-6-3-2/144625>\
**Category:** Elasticsearch\
**Created:** [August 16, 2018, 5:59am UTC](https://discuss.elastic.co/t/problems-upgrading-elasticsearch-from-5-6-1-to-6-3-2/144625 "2018-08-16T05:59:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![McElroy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mcelroy/32/24639_2.png) [@McElroy](https://discuss.elastic.co/u/McElroy)\
**Post date:** [August 16, 2018, 5:59am UTC](https://discuss.elastic.co/t/problems-upgrading-elasticsearch-from-5-6-1-to-6-3-2/144625/1 "2018-08-16T05:59:03Z")

</div>

Hi,

I tried to install Elasticsearch on my Debian machine but everytime I try, I get:

```auto
apt install elasticsearch-6.3.2.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package elasticsearch-6.3.2.deb
E: Couldn't find any package by regex 'elasticsearch-6.3.2.deb'

```

Edit:  
Doesn't work with dpkg either:

```auto
dpkg -i ./elasticsearch-6.3.2.deb 
(Reading database ... 102776 files and directories currently installed.)
Preparing to unpack ./elasticsearch-6.3.2.deb ...
dpkg: error processing archive ./elasticsearch-6.3.2.deb (--install):
 subprocess new pre-installation script returned error exit status 1
### NOT starting on installation, please execute the following statements to configure elasticsearch service to start automatically using systemd
 sudo systemctl daemon-reload
 sudo systemctl enable elasticsearch.service
### You can start elasticsearch service by executing
 sudo systemctl start elasticsearch.service
Errors were encountered while processing:
 ./elasticsearch-6.3.2.deb

```

---

<div class="post-metadata">

**Author:** ![McElroy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mcelroy/32/24639_2.png) [@McElroy](https://discuss.elastic.co/u/McElroy)\
**Post date:** [August 16, 2018, 7:27am UTC](https://discuss.elastic.co/t/problems-upgrading-elasticsearch-from-5-6-1-to-6-3-2/144625/2 "2018-08-16T07:27:41Z")

</div>

I could install an older Version of elasticsearch(6.3.0) but now I have the problem that it doesn't start either.

```auto
Aug 16 09:22:00 atlxweb30231 elasticsearch[9437]: 2018-08-16 09:22:00,130 main ERROR Could not create plugin of type class org.apache.logging.log4j.core.appender.RollingFileAppender for element RollingFile: java.lang.IllegalStateException: ManagerFactory [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$RollingFileManagerFactory@1a1ccaaf] unable to create manager for [/usr/share/elasticsearch/logs/elastic-test_index_indexing_slowlog.log] with data [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$FactoryData@171dc7c3[pattern=/usr/share/elasticsearch/logs/elastic-test_index_indexing_slowlog-%d{yyyy-MM-dd}.log, append=true, bufferedIO=true, bufferSize=8192, policy=CompositeTriggeringPolicy(policies=[TimeBasedTriggeringPolicy(nextRolloverMillis=0, interval=1, modulate=true)]), strategy=DefaultRolloverStrategy(min=1, max=7, useMax=true), advertiseURI=null, layout=[%d{ISO8601}][%-5p][%-25c] %marker%.-10000m%n, filePermissions=null, fileOwner=null]] java.lang.IllegalStateException: ManagerFactory [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$RollingFileManagerFactory@1a1ccaaf] unable to create manager for [/usr/share/elasticsearch/logs/elastic-test_index_indexing_slowlog.log] with data [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$FactoryData@171dc7c3[pattern=/usr/share/elasticsearch/logs/elastic-test_index_indexing_slowlog-%d{yyyy-MM-dd}.log, append=true, bufferedIO=true, bufferSize=8192, policy=CompositeTriggeringPolicy(policies=[TimeBasedTriggeringPolicy(nextRolloverMillis=0, interval=1, modulate=true)]), strategy=DefaultRolloverStrategy(min=1, max=7, useMax=true), advertiseURI=null, layout=[%d{ISO8601}][%-5p][%-25c] %marker%.-10000m%n, filePermissions=null, fileOwner=null]]

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 13, 2018, 7:27am UTC](https://discuss.elastic.co/t/problems-upgrading-elasticsearch-from-5-6-1-to-6-3-2/144625/3 "2018-09-13T07:27:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
