# Problems with NXLOG and Logstash

**URL:** <https://discuss.elastic.co/t/problems-with-nxlog-and-logstash/145586>\
**Category:** Logstash\
**Created:** [August 22, 2018, 4:07pm UTC](https://discuss.elastic.co/t/problems-with-nxlog-and-logstash/145586 "2018-08-22T16:07:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Irving\_Hernandez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/irving_hernandez/32/43340_2.png) [@Irving\_Hernandez](https://discuss.elastic.co/u/Irving_Hernandez)\
**Post date:** [August 22, 2018, 4:07pm UTC](https://discuss.elastic.co/t/problems-with-nxlog-and-logstash/145586/1 "2018-08-22T16:07:26Z")

</div>

I have 2 virtual Ubuntu machines:

```
        1. Realize that both could be seen.
        2. Ping to see if they are calling between them.

```

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/c/3c58e5df37cd35a0c03681bf95c217b4ea4a2718.png)

"the previous image is of a virtual machine called Ubuntu 180"

"the next image is of another virtual machine called server in which NXLOG is installed. In the previous one it has everything of ELK."

 ![Nxlog%20y%20Logstash%2002](https://us1.discourse-cdn.com/elastic/original/3X/1/4/1445dbaf734f95a95b799da05c577cd0ed43d84d.png)

My configuration in /etc/nxlog/nxlog.conf is as follows

 ![Nxlog%20y%20Logstash%2003](https://us1.discourse-cdn.com/elastic/original/3X/4/e/4e7553e388ac4328c83732add17361270da34944.png)  
 ![Nxlog%20y%20Logstash%2004](https://us1.discourse-cdn.com/elastic/original/3X/0/d/0dc92480300f547f90fb2b3da2040288c8b7ca4d.png)

My configuration in /etc/logstash/conf.d/tbus.conf is as follows.

 ![Nxlog%20y%20Logstash%2005](https://us1.discourse-cdn.com/elastic/original/3X/e/1/e16d08ba96876df46d04b3d6295b17d459f3a4f7.png)  
 ![Nxlog%20y%20Logstash%2006](https://us1.discourse-cdn.com/elastic/original/3X/d/5/d54bcefca5ed146b5efaff0921e148a65caef248.png)  
 ![Nxlog%20y%20Logstash%2007](https://us1.discourse-cdn.com/elastic/original/3X/8/6/8625eac577573ab4e94b1bb56b5900ad6cc69f68.png)  
 ![Nxlog%20y%20Logstash%2008](https://us1.discourse-cdn.com/elastic/original/3X/5/5/557227ad92bb3d54e063473aa3883dab048ea23a.png)

The logstash file is already in use and if you start the problem that I have serialized in the Logstash INPUT and in the NXLOG in your configuration.

```
   1. In NXLOG in its configuration in the host I put the ip 10.0.2.15 but not
       it worked, now I tried it with localhost and it did not work.

   2. In the Logstash you add many things but for some reason when you do not
       I put the mode => client shows java error and with the mode: client does not show
       A java error shows another error that acontinuacnion will show.

```

I'm going to run the logstash file that contains the mode =\> client

 ![Nxlog%20y%20Logstash%2009](https://us1.discourse-cdn.com/elastic/original/3X/9/c/9c880139eebd0aaa53ac1cde5b63c8216e26daf3.png)  
Do not mark any errors run normally

But then it marks this type of error and that it is not loading the file or it is blocked, I do not know what the problem is if both are pinging

 ![Nxlog%20y%20Logstash%2010](https://us1.discourse-cdn.com/elastic/original/3X/d/0/d00156989e3e223f069f3f6102b5662431c89809.png)

This is another type of error when I run logstash removing the mode =\> "client" this comment to execute it. Because I have no idea what's going on

 ![Nxlog%20y%20Logstash%2011](https://us1.discourse-cdn.com/elastic/original/3X/4/3/4322e9b6331ac8a425afd1459acbf39153bf1223.png)

NXLOG from the other virtual machine tells me that if it is connected but it appears that the file reopens

 ![Nxlog%20y%20Logstash%2012](https://us1.discourse-cdn.com/elastic/original/3X/e/5/e5c9b2a3c1eb2794d518c04a3c64e5ab119155d5.png)

Help.....

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 19, 2018, 4:07pm UTC](https://discuss.elastic.co/t/problems-with-nxlog-and-logstash/145586/2 "2018-09-19T16:07:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
