Progress on APM for Java 8 based ERP

Continuing the discussion from Is APM perfromance like this because of Java version 1.7 at the Application side:

Hi All,
A small update
I was able to setup APM for my Adempiere which is using Java 8, in the APM I am able to get results, but there is no information on the sections of transaction and error, I am getting information on the metrics side.
I am wondering why I am not able to get anything on the transaction side, may be there is no transactions on the Adempiere ERP side, the instance is only for testing so I think there was no transaction happening when I tested and so I did not get the detail on transaction and on the error

My JAVA_OPT options is

export JAVA_OPTS="${JAVA_OPTS} -Delastic.apm.application_packages=org.compiere,org.adempiere"

and my screen shot of the metric side I am attaching

Tomorrow I will try to do some transactions and check if I am getting results in transaction and error menus

This post is only an update on the progress, just sharing my progress
Thanks
Joseph John

Blockquote

Do you know if Adempiere is using any of our supported technologies if so, which ones and which version?

Hi Felix,
thanks this Adempiere version earlier it was on Java 6, and it did not work. I was not fulfilling the pre-requistive
Now we upgraded it to java 8, and we are getting the communication from the elastic search APM and the Adempiere ERP
our java version is

openjdk version "1.8.0_181"

Which is supported
About the application server, we are using JBoss, I am not sure of the version no, will check it up and update
thanks
Joseph John

The Jboss version it says is

Adempiere process says it is JBoss [Trinity] 4.2.3.GA

from the docs, it says it says supported ones are

6.4, 7.0, 7.1, 7.2

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.