# Property \[name\] is missing for plugin \[plugin-descriptor.properties\] while starting

**URL:** <https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525>\
**Category:** Elasticsearch\
**Created:** [November 14, 2024, 7:39am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525 "2024-11-14T07:39:28Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 7:39am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/1 "2024-11-14T07:39:29Z")

</div>

Hello.

Installed ES

```auto
ii elasticsearch 8.15.2 amd64 Distributed RESTful search engine built for the cloud

```

When configured as a first node for future cluster:

```auto
cluster.name: osir-cluster
node.name: node01
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: 10.10.7.41

xpack.security.enabled: true
xpack.security.enrollment.enabled: true
xpack.security.http.ssl:
  enabled: true
  keystore.path: certs/http.p12

xpack.security.transport.ssl:
  enabled: true
  verification_mode: certificate
  keystore.path: certs/transport.p12
  truststore.path: certs/transport.p12
cluster.initial_master_nodes: ["10.10.7.41"]

http.host: 0.0.0.0
transport.host: 0.0.0.0

```

During starting ES has got a issue:

```auto
[2024-11-14T10:33:47,879][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]

```

But not plugins are installed:

```auto
ls -la /usr/share/elasticsearch/plugins
total 8
drwxr-xr-x 2 root root 4096 Sep 19 13:13 .
drwxr-xr-x 7 root root 4096 Nov 14 10:22 ..

```

How to resolve this issue?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 8:59am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/2 "2024-11-14T08:59:41Z")

</div>

Welcome!

I'm surprised to see:

```auto
ii elasticsearch 8.15.2 amd64 Distributed RESTful search engine built for the cloud

```

And:

```auto
(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]

```

Could you explain? And check what exactly you are doing?  
It would help to reproduce the problem.

---

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 9:32am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/3 "2024-11-14T09:32:15Z")

</div>

I was trying to update from 8.15.2 to 8.16.0

```auto
ii elasticsearch 8.16.0 amd64 Distributed RESTful search engine built for the cloud

```

But it hasn't resolved the issue yet.

How to reproduce:

```auto
root@node01:~# systemctl start elasticsearch.service 
Job for elasticsearch.service failed because the control process exited with error code.
See "systemctl status elasticsearch.service" and "journalctl -xe" for details.
root@node01:~# systemctl status elasticsearch.service 
● elasticsearch.service - Elasticsearch
     Loaded: loaded (/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Thu 2024-11-14 12:31:20 MSK; 4s ago
       Docs: https://www.elastic.co
    Process: 1158 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
   Main PID: 1158 (code=exited, status=1/FAILURE)
        CPU: 7.357s

Nov 14 12:31:17 node01 systemd[1]: Starting Elasticsearch...
Nov 14 12:31:19 node01 systemd-entrypoint[1217]: CompileCommand: dontinline java/lang/invoke/MethodHandle.setAsTypeCache bool dontinline = true
Nov 14 12:31:19 node01 systemd-entrypoint[1217]: CompileCommand: dontinline java/lang/invoke/MethodHandle.asTypeUncached bool dontinline = true
Nov 14 12:31:20 node01 systemd-entrypoint[1158]: ERROR: Elasticsearch did not exit normally - check the logs at /var/log/elasticsearch/osir-cluster.log
Nov 14 12:31:20 node01 systemd-entrypoint[1158]: ERROR: Elasticsearch died while starting up, with exit code 1
Nov 14 12:31:20 node01 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Nov 14 12:31:20 node01 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Nov 14 12:31:20 node01 systemd[1]: Failed to start Elasticsearch.
Nov 14 12:31:20 node01 systemd[1]: elasticsearch.service: Consumed 7.357s CPU time.

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 10:07am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/4 "2024-11-14T10:07:21Z")

</div>

So I just tried a very basic thing (on MacOS):

```auto
mkdir es-distribution
cd es-distribution
wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-8.16.0-darwin-aarch64.tar.gz
tar xzf elasticsearch-8.16.0-darwin-aarch64.tar.gz
cd elasticsearch-8.16.0
bin/elasticsearch

```

And all worked well OOTB for me.

One of the difference I could see with your installation is that the plugins dir belongs to `root` whereas mine belongs to my current user.

Could you share the full logs from the start?

---

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 10:37am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/5 "2024-11-14T10:37:02Z")

</div>

You know, all the files inside /usr/share/elasticsearch have been owned by root:root and also tried to change owner like as "chown -R elasticsearch:elasticsearch /usr/share/elasticsearch/" but id didn't resolve the issue.

Logs in /var/log/elasticsearch/osir-cluster.log have the same content:

```auto
[2024-11-14T10:08:44,673][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:301) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:262) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:251) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:80) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:167) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:75) ~[elasticsearch-8.15.2.jar:?]
[2024-11-14T10:23:49,450][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 10:51am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/6 "2024-11-14T10:51:13Z")

</div>

But that's the very first line of the log file?

---

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 11:13am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/7 "2024-11-14T11:13:49Z")

</div>

There were the head of the log during starting ES first time after installation 8.15.2.  
Nothing else.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 11:29am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/8 "2024-11-14T11:29:43Z")

</div>

But when you started the 8.16 version? Is that the start of the log file?

---

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 11:55am UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/9 "2024-11-14T11:55:45Z")

</div>

Here is the full log:

```auto
root@node01:~# cat /var/log/elasticsearch/osir-cluster.log
[2024-11-14T10:08:44,673][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:301) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:262) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:251) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:80) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:167) ~[elasticsearch-8.15.2.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:75) ~[elasticsearch-8.15.2.jar:?]
[2024-11-14T10:23:49,450][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T10:24:04,135][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T10:30:51,302][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T10:33:47,879][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T12:31:20,400][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T13:32:51,255][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T13:39:33,556][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]
[2024-11-14T13:40:18,571][ERROR][o.e.b.Elasticsearch] [node01] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: property [name] is missing for plugin [plugin-descriptor.properties]
	at org.elasticsearch.plugins.PluginDescriptor.readNonEmptyString(PluginDescriptor.java:302) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readerInternalDescriptor(PluginDescriptor.java:263) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.plugins.PluginDescriptor.readFromProperties(PluginDescriptor.java:252) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:81) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:166) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]

```

Tried update to 8.16.0 and then changing owner for elasticsearch folders - without any success.  
Package has been installed from

```auto
 "deb [trusted=yes] https://mirror.yandex.ru/mirrors/elastic/8/ stable main"

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 12:50pm UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/10 "2024-11-14T12:50:41Z")

</div>

Just to make sure. Could you start in another directory with the exact commands I shared previously?

---

<div class="post-metadata">

**Author:** ![AlexeiKlimenko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexeiklimenko/32/139209_2.png) [@AlexeiKlimenko](https://discuss.elastic.co/u/AlexeiKlimenko)\
**Post date:** [November 14, 2024, 1:55pm UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/11 "2024-11-14T13:55:30Z")

</div>

Nope.

With root got:

```auto
java.lang.RuntimeException: can not run elasticsearch as root
	at org.elasticsearch.bootstrap.Elasticsearch.initializeNatives(Elasticsearch.java:287) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:169) ~[elasticsearch-8.16.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:74) ~[elasticsearch-8.16.0.jar:?]

```

With regular user

```auto
user@node01:/tmp/elasticsearch-8.16.0$ bin/elasticsearch
bin/elasticsearch-cli: line 14: /tmp/elasticsearch-8.16.0/jdk/bin/java: Permission denied

```

Notice.  
Procedures of installing and configuring ES Cluster have been deployed with root user.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 14, 2024, 2:36pm UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/12 "2024-11-14T14:36:09Z")

</div>

Don't run as root but as a standard user.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2024, 2:36pm UTC](https://discuss.elastic.co/t/property-name-is-missing-for-plugin-plugin-descriptor-properties-while-starting/370525/13 "2024-12-12T14:36:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
