# Prune plugin cannot be found by systems after being installed

**URL:** <https://discuss.elastic.co/t/prune-plugin-cannot-be-found-by-systems-after-being-installed/134453>\
**Category:** Logstash\
**Created:** [June 4, 2018, 3:37pm UTC](https://discuss.elastic.co/t/prune-plugin-cannot-be-found-by-systems-after-being-installed/134453 "2018-06-04T15:37:02Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mr\_BAU](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mr\_BAU](https://discuss.elastic.co/u/Mr_BAU)\
**Post date:** [June 4, 2018, 3:37pm UTC](https://discuss.elastic.co/t/prune-plugin-cannot-be-found-by-systems-after-being-installed/134453/1 "2018-06-04T15:37:02Z")

</div>

Hi,

maybe I'm looking at this all wrong, but I can't find what I"m doing wrong here.  
I installed the prune filter, with this command:  
`bin/logstash-plugin install logstash-filter-prune`  
which was successful and I can list the plugin:  
`bin/logstash-plugin list --verbose prune logstash-filter-prune (3.0.3)`  
However, I still get following error in the logs:

> [2018-06-04T16:09:57,478][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. {:exception=\>#\<LoadError: no such file to load -- logstash/filters/prune\>, :path=\>"logstash/filters/prune", :type=\>"filter", :name=\>"prune"}  
> [2018-06-04T16:09:57,479][ERROR][logstash.agent] Failed to execute action {:id=\>:"nginx-tca", :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Couldn't find any filter plugin named 'prune'. Are you sure this is correct? Trying to load the prune filter plugin resulted in this error: no such file to load -- logstash/filters/prune", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/plugins/registry.rb:192:in `lookup_pipeline_plugin'", "/usr/share/logstash/logstash-core/lib/logstash/plugin.rb:140:in `lookup'", "/usr/share/logstash/logstash-core/lib/logstash/plugins/plugin\_factory.rb:81:in `plugin'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:112:in `plugin'", "(eval):120:in `'", "org/jruby/RubyKernel.java:994:in `eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:84:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/reload.rb:34:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:315:in `block in converge_state'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:141:in `with\_pipelines'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:312:in `block in converge_state'", "org/jruby/RubyArray.java:1734:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:299:in `converge_state'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:166:in `block in converge\_state\_and\_update'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:141:in `with_pipelines'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:164:in `converge\_state\_and\_update'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:105:in `block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/interval.rb:18:in `interval'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:94:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:348:in `block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:24:in `block in initialize'"]}

Automatic reload is enabled, so it should pick it up.  
Any idea what I'm doing wrong??

Cheers

Jan

**Update**

Because I can no longer reply to this thread, this can be solved by simply restarting the logstash service, even if automatic reload of config is enabled.  
Would be handy if this is mentioned somewhere in the docs...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 2, 2018, 3:40pm UTC](https://discuss.elastic.co/t/prune-plugin-cannot-be-found-by-systems-after-being-installed/134453/2 "2018-07-02T15:40:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
