# Puppet-elasticsearch upgrading instance from 2.3.2 to 5.1.2

**URL:** https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941
**Category:** Elasticsearch
**Created:** [January 26, 2017, 7:06pm UTC](https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941 "2017-01-26T19:06:37Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Joseph.Flanigan](https://avatars.discourse-cdn.com/v4/letter/j/5f8ce5/32.png) [@Joseph.Flanigan](https://discuss.elastic.co/u/Joseph.Flanigan)
#### Post date: [January 26, 2017, 7:06pm UTC](https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941/1 "2017-01-26T19:06:37Z")

</div>

I have a large number of elasticsearch nodes with version 2.3.2 installed and puppetized on them. I was hoping this week to start the process of upgrading some of the clusters containing these nodes to some version of Elasticsearch 5.x. The puppet-elasticsearch readme says that 5.x is supported, but when I try to change the version value in the manifest to 5.1.2 I get the following error:

`Error: Could not update: Failed to update to version 5.1.2-1, got version 2.3.2-1 instead Error: /Stage[main]/Elasticsearch::Package/Package[elasticsearch]/ensure: change from 2.3.2-1 to 5.1.2-1 failed: Could not update: Failed to update to version 5.1.2-1, got version 2.3.2-1 instead`

The error is then following by a large number of `Skipping because of failed dependencies` errors. Which is to be expected since the upgrade of elasticsearch fails in a big way.

Has anyone else dealt with this issue? Elastic team, any advice on dealing with this issue?

---

<div class="post-metadata">

### Author: ![tylerjl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylerjl/32/44965_2.png) [@tylerjl](https://discuss.elastic.co/u/tylerjl)
#### Post date: [January 27, 2017, 6:08pm UTC](https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941/2 "2017-01-27T18:08:38Z")

</div>

Hi @Joseph.Flanigan, welcome to the forums!

That error just means that your package manager can't find version 5.x to install. This can be due to a number of reasons. By default, the module pins the package version to avoid accidentally upgrading when you indicate a package version. Could you post the relevant parts of your puppet config here so we can take a closer look?

---

<div class="post-metadata">

### Author: ![Joseph.Flanigan](https://avatars.discourse-cdn.com/v4/letter/j/5f8ce5/32.png) [@Joseph.Flanigan](https://discuss.elastic.co/u/Joseph.Flanigan)
#### Post date: [January 27, 2017, 7:07pm UTC](https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941/3 "2017-01-27T19:07:23Z")

</div>

Pointing this out actually solved the issue for me. We maintain our own yum servers and no package existed for 5.1.2, but there was one for 5.0.1. I tested the code out pointing to that version and everything works fine now. Thanks for the help!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 24, 2017, 7:07pm UTC](https://discuss.elastic.co/t/puppet-elasticsearch-upgrading-instance-from-2-3-2-to-5-1-2/72941/4 "2017-02-24T19:07:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
