# Pushing logs to ElasticSearch in another AWS account: Timeout errors

**URL:** <https://discuss.elastic.co/t/pushing-logs-to-elasticsearch-in-another-aws-account-timeout-errors/246718>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [August 28, 2020, 6:14am UTC](https://discuss.elastic.co/t/pushing-logs-to-elasticsearch-in-another-aws-account-timeout-errors/246718 "2020-08-28T06:14:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ltrod](https://avatars.discourse-cdn.com/v4/letter/l/db5fbb/32.png) [@ltrod](https://discuss.elastic.co/u/ltrod)\
**Post date:** [August 28, 2020, 6:14am UTC](https://discuss.elastic.co/t/pushing-logs-to-elasticsearch-in-another-aws-account-timeout-errors/246718/1 "2020-08-28T06:14:07Z")

</div>

I'm running Filebeat on Kubernetes in a EKS Cluster in AWS and send the logs to ElasticSearch in another AWS account. The logs reach the ElasticSearch and I can see the logs in Kibana. But I get these errors sometimes:

```auto
ERROR [publisher_pipeline_output] pipeline/output.go:155 Failed to connect to backoff(elasticsearch(https://<elasticsearch>.es.amazonaws.com:443)): Get https://<elasticsearch>.es.amazonaws.com:443: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

```

For testing, I setup a ElasticSearch in the same AWS Account and send the logs to this ElasticSearch. So I did't get these errors. I only get the errors if I'm sending the logs to a ElasticSearch in another AWS account.

Anyone else had this problem and can help me?  
Thank you in advance.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 25, 2020, 8:14am UTC](https://discuss.elastic.co/t/pushing-logs-to-elasticsearch-in-another-aws-account-timeout-errors/246718/2 "2020-09-25T08:14:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
