# Query using Kibana URL

**URL:** <https://discuss.elastic.co/t/query-using-kibana-url/145007>\
**Category:** Kibana\
**Created:** [August 18, 2018, 1:34pm UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007 "2018-08-18T13:34:13Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![shiveshabhishek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiveshabhishek/32/34533_2.png) [@shiveshabhishek](https://discuss.elastic.co/u/shiveshabhishek)\
**Post date:** [August 18, 2018, 1:34pm UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/1 "2018-08-18T13:34:13Z")

</div>

Hey , I am using kibana v6.3.0 . I want to show the **discover** tab with pre-existing filter to users which I want to show them(basically, filtered logs) . The problem here is, if I open the link in incognito tab, it shows error like:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/d/dda122b1bc516085152f19e70b271617592fcfd0.png)  
The URL is like this:  
localhost:5601/app/kibana#/discover?\_g=()&\_a=(columns:!(\_source),filters:!(('$state':(store:appState),meta:(alias:!n,disabled:!f,index:'215dd610-a155-11e8-8b91-cb4b4edefe7f',key:xyz,negate:!f,params:(query:'1',type:phrase),type:phrase,value:'1'),query:(match:(xyz:(query:'1',type:phrase))))),index:'215dd610-a155-11e8-8b91-cb4b4edefe7f',interval:auto,query:(language:lucene,query:''),sort:!('@timestamp',desc))

How can I resolve this ?

Also I want to change the filters without using the UI, I want to give URL to the users of the filtered logs in kibana, for now I am doing this by changing the values in the URL. Is there any better way to do this either by API or something?

Any help would be appreciated.

---

<div class="post-metadata">

**Author:** ![tamara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tamara/32/47095_2.png) [@tamara](https://discuss.elastic.co/u/tamara)\
**Post date:** [August 20, 2018, 1:27pm UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/2 "2018-08-20T13:27:15Z")

</div>

Hi,

If you want to share the Kibana search/filters with other users, you can actually create an url link clicking at "Share". Share will create an url that you can share with others (I have tested in incognito mode and still works).

 ![53](https://us1.discourse-cdn.com/elastic/original/3X/7/c/7c434a228bf8b751561e02273a0ea0f026180636.png)

---

<div class="post-metadata">

**Author:** ![shiveshabhishek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiveshabhishek/32/34533_2.png) [@shiveshabhishek](https://discuss.elastic.co/u/shiveshabhishek)\
**Post date:** [August 21, 2018, 2:20pm UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/3 "2018-08-21T14:20:29Z")

</div>

Thanks for replying. 🙂  
I got your answer. But still, that didn't help me. It is showing that error again.  
I think, the problem is somewhere else because if I try to access logs in Kibana, it sometimes giving me another error also like :

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/9/9/99f4a776161fbea4385e29550979a09056e80b44.png)

If I set the **auto-refresh** interval to **10secs** and **time range** to **last 1hr** , sometimes, Kibana displays the logs correctly and sometimes it shows error as above. Can you help me with this ?  
FYI, I am getting this error while running kibana and elasticsearch on cloud.

---

<div class="post-metadata">

**Author:** ![tamara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tamara/32/47095_2.png) [@tamara](https://discuss.elastic.co/u/tamara)\
**Post date:** [August 22, 2018, 3:52pm UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/4 "2018-08-22T15:52:45Z")

</div>

I think you should post a new question with this error explaining the problem a bit more.

---

<div class="post-metadata">

**Author:** ![shiveshabhishek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiveshabhishek/32/34533_2.png) [@shiveshabhishek](https://discuss.elastic.co/u/shiveshabhishek)\
**Post date:** [August 23, 2018, 8:55am UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/5 "2018-08-23T08:55:43Z")

</div>

Okay, thanks.. btw currently as a temporary solution, I reduced the replicas of elasticsearch to 1 . And it is working fine!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 20, 2018, 8:55am UTC](https://discuss.elastic.co/t/query-using-kibana-url/145007/6 "2018-09-20T08:55:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
