# QueryShardException No mapping found for \[failed\]

**URL:** https://discuss.elastic.co/t/queryshardexception-no-mapping-found-for-failed/269111
**Category:** Elasticsearch
**Created:** [April 2, 2021, 2:19pm UTC](https://discuss.elastic.co/t/queryshardexception-no-mapping-found-for-failed/269111 "2021-04-02T14:19:51Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![MdRashid](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@MdRashid](https://discuss.elastic.co/u/MdRashid)
#### Post date: [April 2, 2021, 2:19pm UTC](https://discuss.elastic.co/t/queryshardexception-no-mapping-found-for-failed/269111/1 "2021-04-02T14:19:51Z")

</div>

Hi All,

I have deploy my ES on Azure Kubernetes Services AKS after deploying i got error

all shards failed

```auto
Caused by: org.elasticsearch.index.query.QueryShardException: No mapping found for [failed] in order to sort on

```

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [April 2, 2021, 8:47pm UTC](https://discuss.elastic.co/t/queryshardexception-no-mapping-found-for-failed/269111/2 "2021-04-02T20:47:56Z")

</div>

That does not look like a deployment error but a usage error. What are you doing?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 30, 2021, 8:48pm UTC](https://discuss.elastic.co/t/queryshardexception-no-mapping-found-for-failed/269111/3 "2021-04-30T20:48:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
