# Read from ES index fails without write permission with HEAD \[405|Method Not Allowed:\]

**URL:** https://discuss.elastic.co/t/read-from-es-index-fails-without-write-permission-with-head-405-method-not-allowed/328176
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [March 21, 2023, 3:24pm UTC](https://discuss.elastic.co/t/read-from-es-index-fails-without-write-permission-with-head-405-method-not-allowed/328176 "2023-03-21T15:24:24Z")
**Posts on this page:** 1
**Showing post:** 8

<div class="post-metadata">

### Author: ![Keith\_Massey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/keith_massey/32/83666_2.png) [@Keith\_Massey](https://discuss.elastic.co/u/Keith_Massey)
#### Post date: [March 23, 2023, 8:18pm UTC](https://discuss.elastic.co/t/read-from-es-index-fails-without-write-permission-with-head-405-method-not-allowed/328176/8 "2023-03-23T20:18:49Z")

</div>

I'm not very familiar with `es.nodes.path.prefix`, but it sounds like there might be two problems, right?  
(1) Somehow es-hadoop is swapping the prefix and port as you describe in [Prefix and port appear flipped in es-hadoop implementation - #3 by petersedivec](https://discuss.elastic.co/t/prefix-and-port-appear-flipped-in-es-hadoop-implementation/328072/3). It would be good to get a ticket for that (with steps to reproduce)  
(2) It looks like maybe your elasticsearch is not configured right, since it is failing on `curl -u "username:password" --head https://server/es/indexname`. I would assume that `es/` would have been stripped out of the path before Elasticsearch got to it.

---

_[View the full topic](https://discuss.elastic.co/t/read-from-es-index-fails-without-write-permission-with-head-405-method-not-allowed/328176)._
