# Readiness probe failed: Waiting for elasticsearch cluster to become ready

**URL:** <https://discuss.elastic.co/t/readiness-probe-failed-waiting-for-elasticsearch-cluster-to-become-ready/272273>\
**Category:** Elasticsearch\
**Created:** [May 6, 2021, 10:10am UTC](https://discuss.elastic.co/t/readiness-probe-failed-waiting-for-elasticsearch-cluster-to-become-ready/272273 "2021-05-06T10:10:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vbharath2007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vbharath2007/32/88312_2.png) [@vbharath2007](https://discuss.elastic.co/u/vbharath2007)\
**Post date:** [May 6, 2021, 10:10am UTC](https://discuss.elastic.co/t/readiness-probe-failed-waiting-for-elasticsearch-cluster-to-become-ready/272273/1 "2021-05-06T10:10:00Z")

</div>

Hi, I'm running ELK stack using helm charts through the elastic community operator git repo.

My ES is a single node cluster, today morning suddenly the pod failed and unable to bring up and receiving the below from the event.

**Readiness probe failed: Waiting for elasticsearch cluster to become ready (request params: "wait\_for\_status=yellow&timeout=1s" ) Cluster is not yet ready (request params: "wait\_for\_status=yellow&timeout=1s" )**

I have already added in elasticsearch.yml config the below parameter  
clusterHealthCheckParams: "wait\_for\_status=yellow&timeout=1s"

But still getting the below error. and this from the ES log...

`Preformatted text` "timestamp": "2021-05-06T09:09:47,490Z", "level": "WARN", "component": "o.e.l.LicenseService", "cluster.name": "elasticsearch", "node.name": "elasticsearch-master-0", "message": "LICENSE [EXPIRED] ON [WEDNESDAY, APRIL 28, 2021].\n# IF YOU HAVE A NEW LICENSE, PLEASE UPDATE IT. OTHERWISE, PLEASE REACH OUT TO\n# YOUR SUPPORT CONTACT.\n# \n# COMMERCIAL PLUGINS OPERATING WITH REDUCED FUNCTIONALITY\n# - security\n# - Cluster health, cluster stats and indices stats operations are blocked\n# - All data operations (read and write) continue to work\n# - watcher\n# - PUT / GET watch APIs are disabled, DELETE watch API continues to work\n# - Watches execute and write to the history\n# - The actions of the watches don't execute\n# - monitoring\n# - The agent will stop collecting cluster and indices metrics\n# - The agent will stop automatically cleaning indices older than [xpack.monitoring.history.duration]\n# - graph\n# - Graph explore APIs are disabled\n# - ml\n# - Machine learning APIs are disabled\n# - logstash\n# - Logstash will continue to poll centrally-managed pipelines\n# - beats\n# - Beats will continue to poll centrally-managed configuration\n# - deprecation\n# - Deprecation APIs are disabled\n# - upgrade\n# - Upgrade API is disabled\n# - sql\n# - SQL support is disabled\n# - rollup\n# - Creating and Starting rollup jobs will no longer be allowed.\n# - Stopping/Deleting existing jobs, RollupCaps API and RollupSearch continue to function.\n# - transform\n# - Creating, starting, updating transforms will no longer be allowed.\n# - Stopping/Deleting existing transforms continue to function.\n# - analytics\n# - Aggregations provided by Analytics plugin are no longer usable.\n# - ccr\n# - Creating new follower indices will be blocked\n# - Configuring auto-follow patterns will be blocked\n# - Auto-follow patterns will no longer discover new leader indices\n# - The CCR monitoring endpoint will be blocked\n# - Existing follower indices will continue to replicate data", "cluster.uuid":`Preformatted text`

` indent preformatted text by 4 spaces {"type": "server", "timestamp": "2021-05-06T10:05:49,075Z", "level": "WARN", "component": "o.e.x.w.e.ExecutionService", "cluster.name": "elasticsearch", "node.name": "elasticsearch-master-0", "message": "failed to execute watch [85e301d2-f79e-4414-81c2-20c84e2bc2d6]", "cluster.uuid"`

---

<div class="post-metadata">

**Author:** ![legoguy1000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/legoguy1000/32/54301_2.png) [@legoguy1000](https://discuss.elastic.co/u/legoguy1000)\
**Post date:** [May 7, 2021, 9:42am UTC](https://discuss.elastic.co/t/readiness-probe-failed-waiting-for-elasticsearch-cluster-to-become-ready/272273/2 "2021-05-07T09:42:59Z")

</div>

> [@vbharath2007](#):
>
> LICENSE [EXPIRED] ON [WEDNESDAY, APRIL 28, 2021]

Looks like your license expired. You'll need to update it or convert to the basic license.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 4, 2021, 11:43am UTC](https://discuss.elastic.co/t/readiness-probe-failed-waiting-for-elasticsearch-cluster-to-become-ready/272273/3 "2021-06-04T11:43:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
