# Receive this error

**URL:** <https://discuss.elastic.co/t/receive-this-error/114817>\
**Category:** Logstash\
**Created:** [January 10, 2018, 8:59am UTC](https://discuss.elastic.co/t/receive-this-error/114817 "2018-01-10T08:59:40Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [January 10, 2018, 8:59am UTC](https://discuss.elastic.co/t/receive-this-error/114817/1 "2018-01-10T08:59:41Z")

</div>

Hi all,  
i'm receiving the following errors every 2-5 mins:

```auto
[2018-01-10T09:55:35,117][WARN][logstash.outputs.elasticsearch] Marking url as dead. Last error: [LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError] Elasticsearch Unreachable: [http://elastic:xxxxxx@127.0.0.1:9200/][Manticore::SocketTimeout] Read timed out {:url=>http://elastic:xxxxxx@127.0.0.1:9200/, :error_message=>"Elasticsearch Unreachable: [http://elastic:xxxxxx@127.0.0.1:9200/][Manticore::SocketTimeout] Read timed out", :error_class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError"}
[2018-01-10T09:55:35,117][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch' but Elasticsearch appears to be unreachable or down! {:error_message=>"Elasticsearch Unreachable: [http://elastic:xxxxxx@127.0.0.1:9200/][Manticore::SocketTimeout] Read timed out", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,160][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,161][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,192][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,192][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,204][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,204][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,204][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,204][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,253][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,254][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,261][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,261][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:35,268][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:35,269][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:36,031][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2018-01-10T09:55:36,031][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>2}
[2018-01-10T09:55:36,700][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck_url=>http://elastic:xxxxxx@127.0.0.1:9200/, :path=>"/"}
[2018-01-10T09:55:36,701][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=>"http://elastic:xxxxxx@127.0.0.1:9200/"}
[2018-01-10T09:55:37,573][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck_url=>http://elastic:xxxxxx@127.0.0.1:9200/, :path=>"/"}
[2018-01-10T09:55:37,574][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=>"http://elastic:xxxxxx@127.0.0.1:9200/"}

```

What is the problem? Can you help me?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 10, 2018, 10:43am UTC](https://discuss.elastic.co/t/receive-this-error/114817/2 "2018-01-10T10:43:55Z")

</div>

Please format your code. I edited your post.

> `Perhaps Elasticsearch is unreachable or down?`

Anything in elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [January 10, 2018, 10:46am UTC](https://discuss.elastic.co/t/receive-this-error/114817/3 "2018-01-10T10:46:06Z")

</div>

Nothing....elastic process is up and running without error,  
and other ls node are correctly connected and are ingesting data!

Also after a restart i receive the error...

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 10, 2018, 11:00am UTC](https://discuss.elastic.co/t/receive-this-error/114817/4 "2018-01-10T11:00:10Z")

</div>

So elasticsearch seems ok. I'm moving your question to #logstash but a first guess is that you have troubles to access elasticsearch from the host where your LS instance is running.

---

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [January 10, 2018, 11:01am UTC](https://discuss.elastic.co/t/receive-this-error/114817/5 "2018-01-10T11:01:08Z")

</div>

I add, as you can see, LS and ES are running in the same host.

---

<div class="post-metadata">

**Author:** ![Krunal\_kalaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krunal_kalaria/32/23862_2.png) [@Krunal\_kalaria](https://discuss.elastic.co/u/Krunal_kalaria)\
**Post date:** [January 10, 2018, 11:26am UTC](https://discuss.elastic.co/t/receive-this-error/114817/6 "2018-01-10T11:26:26Z")

</div>

hi @sbampa ,  
can you show me your conf file first.

---

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [January 10, 2018, 11:32am UTC](https://discuss.elastic.co/t/receive-this-error/114817/7 "2018-01-10T11:32:35Z")

</div>

input {  
beats {  
port =\> "5043"  
}  
file {  
path =\> [ "/opt/logs/sito02/wildfly-auth-sito2/server.log", "/opt/logs/sito02/wildfly-intserv-sito2/server.log", "/opt/logs/sito02/wildfly-wallet-sito2/server.log", "/opt/logs/sito03/wildfly  
-intserv-sito3/server.log", "/opt/logs/sito03/wildfly-wallet-sito3/server.log", "/opt/logs/sito03/wildfly-auth-sito3/server.log", "/opt/logs/sito04/wildfly-info-sito4/server.log", "/opt/logs/sito04/  
wildfly-sport-sito4/server.log", "/opt/logs/sito04/wildfly-auth-sito4/server.log", "/opt/logs/sito05/wildfly-auth-sito5/server.log", "/opt/logs/sito05/wildfly-sport-sito5/server.log", "/opt/logs/sit  
o05/wildfly-gaming-sito5/server.log", "/opt/logs/sito06/wildfly-info-sito6/server.log", "/opt/logs/sito06/wildfly-sport-sito6/server.log", "/opt/logs/sito06/wildfly-sportschedule-sito6/server.log",  
"/opt/logs/sito07/wildfly-gaming-sito7/server.log", "/opt/logs/sito07/wildfly-sport-sito7/server.log", "/opt/logs/sito08/wildfly-sport-sito8/server.log", "/opt/logs/sito08/wildfly-intserv-sito8/serv  
er.log", "/opt/logs/sito09/wildfly-sport-sito9/server.log", "/opt/logs/sito09/wildfly-intserv-sito9/server.log", "/opt/logs/sito10/wildfly-sportschedule-sito10/server.log", "/opt/logs/sito11/wildfly  
-info-sito11/server.log", "/opt/logs/sito11/wildfly-sale-sito11/server.log", "/opt/logs/sito12/wildfly-info-sito12/server.log", "/opt/logs/sito12/wildfly-sale-sito12/server.log", "/opt/logs/sito13/w  
ildfly-info-sito13/server.log", "/opt/logs/sito13/wildfly-sale-sito13/server.log", "/opt/logs/sito14/wildfly-info-sito14/server.log", "/opt/logs/sito14/wildfly-sale-sito14/server.log", "/opt/logs/si  
to15/wildfly-intserv-sito15/server.log", "/opt/logs/sito15/wildfly-sport-sito15/server.log" ]  
codec =\> multiline {  
pattern =\> "^%{TIMESTAMP\_ISO8601} "  
negate =\> true  
what =\> "previous"  
}  
exclude =\> "_.gz"  
add\_field =\> { "log\_type" =\> "sitonew" }  
start\_position =\> "end"  
sincedb\_path =\> "/vol1/since.db"  
}  
file {  
path =\> ["/opt/logs/betradar-live/betradar\_live\_odds\_psqf3/echo/_.echo"]  
codec =\> multiline {  
pattern =\> "^%{HTTPDERROR\_DATE} "  
negate =\> true  
what =\> "previous"  
}  
exclude =\> "_.gz"  
add\_field =\> { "log\_type" =\> "betradar\_live" }  
start\_position =\> "end"  
sincedb\_path =\> "/dev/null"  
}  
file {  
path =\> ["/opt/logs/wildfly-betgen01/wildfly/server.log"]  
codec =\> multiline {  
pattern =\> "^%{TIMESTAMP\_ISO8601} "  
negate =\> true  
what =\> "previous"  
max\_lines =\> 4000  
}  
exclude =\> "_.gz"  
add\_field =\> { "log\_type" =\> "betgenius" }  
start\_position =\> "end"  
sincedb\_path =\> "/vol1/since2.db"  
}  
}  
filter {  
grok {  
match =\> ["message", "%{TIMESTAMP\_ISO8601:timestamp} %{LOGLEVEL:level} "]  
match =\> ["message", "%{HTTPDERROR\_DATE:timestamp} (%{NUMBER:bytes}) "]  
match =\> ["message", "%{TIME:timestamp} %{LOGLEVEL:level}"]  
match =\> ["message", "%{BIND9\_TIMESTAMP:timestamp}"]  
}  
date {  
match =\> ["timestamp", "YYYY-MM-dd HH:mm:ss,SSS", "HH:mm:ss,SSS", "EEE MMM dd HH:mm:ss YYYY", "dd-MMM-yyyy HH:mm:ss.SSS"]  
timezone =\> "Europe/Rome"  
target =\> "@timestamp"  
}  
mutate {  
remove\_field =\> ["timestamp","offset","level","@version","input\_type","beat","type","tags","sort"]  
}

}  
output {  
if [fields][log\_type] == "totem"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "totem-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}  
else if [fields][log\_type] == "backoffice-agenzie"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "backoffice-agenzie-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
} }else if [fields][log\_type] == "backoffice-interno"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "backoffice-interno-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
} else if [log\_type] == "betgenius"{  
elasticsearch {  
hosts =\> ["127.0.0.1:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "betgenius-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}else if [fields][log\_type] == "worldmatch"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "worldmatch-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
} }  
else if [fields][log\_type] == "sito-gioco"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "sito-gioco-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}  
else if [fields][log\_type] == "prodven1\_sport\_psqf"{  
elasticsearch {  
hosts =\> ["127.0.0.1:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "prodven1\_sport\_psqf%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}else if [fields][log\_type] == "prodven1\_sport\_web"{  
elasticsearch {  
hosts =\> ["127.0.0.1:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "prodven1\_sport\_web-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
} else if [fields][log\_type] == "mob-prodpal"{  
elasticsearch {  
hosts =\> ["172.16.0.4:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "mob-prodpal-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
} else {  
elasticsearch {  
hosts =\> ["127.0.0.1:9200", "172.16.0.5:9200", "172.16.0.6:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "others-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}  
}

---

<div class="post-metadata">

**Author:** ![Krunal\_kalaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krunal_kalaria/32/23862_2.png) [@Krunal\_kalaria](https://discuss.elastic.co/u/Krunal_kalaria)\
**Post date:** [January 10, 2018, 11:42am UTC](https://discuss.elastic.co/t/receive-this-error/114817/8 "2018-01-10T11:42:07Z")

</div>

else if [log\_type] == "betgenius"{  
elasticsearch {  
hosts =\> ["127.0.0.1:9200"]  
user =\> elastic  
password =\> "changeme"  
manage\_template =\> false  
index =\> "betgenius-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}

in else if [log\_type] == "betgenius" line you write only [log\_type] and other else if condition you write [fields][log\_type] is that correct ?

if i am not wrong in output so many ip of elasticsearch is their i dont know i think issue with this coz once i was same error is throwing but in mine its solved problem is in my elastic ip so you see that above line is correct or not.

Thanks & Regards,  
Krunal.

---

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [January 10, 2018, 11:48am UTC](https://discuss.elastic.co/t/receive-this-error/114817/9 "2018-01-10T11:48:53Z")

</div>

Problem in only with logtype backoffice-\*.  
and appear in both case: [fields][log\_type] and only [log\_type]...  
☹

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 7, 2018, 11:49am UTC](https://discuss.elastic.co/t/receive-this-error/114817/10 "2018-02-07T11:49:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
