# Receiving ERR\_CONNECTION\_REFUSED after installing and starting kibana on AWS EC2 instance

**URL:** <https://discuss.elastic.co/t/receiving-err-connection-refused-after-installing-and-starting-kibana-on-aws-ec2-instance/101583>\
**Category:** Kibana\
**Created:** [September 23, 2017, 10:55pm UTC](https://discuss.elastic.co/t/receiving-err-connection-refused-after-installing-and-starting-kibana-on-aws-ec2-instance/101583 "2017-09-23T22:55:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![manoj\_faria](https://avatars.discourse-cdn.com/v4/letter/m/278dde/32.png) [@manoj\_faria](https://discuss.elastic.co/u/manoj_faria)\
**Post date:** [September 23, 2017, 10:55pm UTC](https://discuss.elastic.co/t/receiving-err-connection-refused-after-installing-and-starting-kibana-on-aws-ec2-instance/101583/1 "2017-09-23T22:55:48Z")

</div>

When connecting to kibana hosted on aws ec2 ami instance via chrome browser i run into the below stated error:

* * *

This site can’t be reached

## ec2-.us-west-1.compute.amazonaws.com refused to connect. Search Google for ec2 205 west compute amazonaws 5601 status ERR\_CONNECTION\_REFUSED

Listed below are some of the troubleshooting steps that I have performed so far.

1. yum list installed reports that kibana is installed.  
yum list installed | grep kibana  
kibana.x86\_64 6.0.0\_beta2-1 installed

2. kibana is reported as running.  
sudo service kibana status  
kibana is running

3. /var/log/kibana/kibana.stderr file is emplty i.e. no errors are reported when kibana was started using "sudo service kibana start".

4. On the AWS Security Groups port 5601 has been opened to be accessible from my IP.

5. i have not setup any firewalls etc which may prevent access to port 5601.

6. netstat reports that i have a process running on 5601  
sudo netstat -tulpn | grep 5601  
tcp 0 0 127.0.0.1:5601 0.0.0.0:\* LISTEN 7104/node

Any idea what else can i try to troubleshoot and fix this issue - to get Kibana up and running on AWS EC2 AMI instance and have it accessible from my chrome browser?

Thanks!  
-Manoj

---

<div class="post-metadata">

**Author:** ![manoj\_faria](https://avatars.discourse-cdn.com/v4/letter/m/278dde/32.png) [@manoj\_faria](https://discuss.elastic.co/u/manoj_faria)\
**Post date:** [September 25, 2017, 12:57am UTC](https://discuss.elastic.co/t/receiving-err-connection-refused-after-installing-and-starting-kibana-on-aws-ec2-instance/101583/2 "2017-09-25T00:57:49Z")

</div>

This issue was addressed by setting network.host value to the private/public ip. By default it binds to localhost.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 23, 2017, 12:58am UTC](https://discuss.elastic.co/t/receiving-err-connection-refused-after-installing-and-starting-kibana-on-aws-ec2-instance/101583/3 "2017-10-23T00:58:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
