# Recovery failure on shard

**URL:** <https://discuss.elastic.co/t/recovery-failure-on-shard/227453>\
**Category:** Elasticsearch\
**Created:** [April 10, 2020, 8:04am UTC](https://discuss.elastic.co/t/recovery-failure-on-shard/227453 "2020-04-10T08:04:52Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pugdummy](https://avatars.discourse-cdn.com/v4/letter/p/439d5e/32.png) [@pugdummy](https://discuss.elastic.co/u/pugdummy)\
**Post date:** [April 10, 2020, 8:04am UTC](https://discuss.elastic.co/t/recovery-failure-on-shard/227453/1 "2020-04-10T08:04:52Z")

</div>

Hello,

I am new with elastic and coding in general. I just want to ask how to fix this issue we have on Elastic. We are using elastic and kibana with UiPath Orchestrator. We are using old version for elastic 6.2.3.

> [2020-04-09T03:39:00,202][INFO][o.e.g.GatewayService] [Sample\_Node] recovered [46] indices into cluster\_state  
> [2020-04-09T03:39:01,968][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:01,984][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:01,984][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:01,984][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:01,984][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:02,578][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [can\_match]  
> [2020-04-09T03:39:02,953][DEBUG][o.e.a.s.TransportSearchAction] [Sample\_Node] All shards failed for phase: [query]  
> [2020-04-09T03:39:22,281][WARN][o.e.i.c.IndicesClusterStateService] [Sample\_Node] [[default-2018.02][3]] marking and sending shard failed due to [failed recovery]  
> org.elasticsearch.indices.recovery.RecoveryFailedException: [default-2018.02][3]: Recovery failed on {Sample\_Node}{nymqVlasQlCUJRwTOBfBfA}{Zcxi-VYFSQG6bHvucfSJZQ}{127.0.0.1}{127.0.0.1:9300}  
> at org.elasticsearch.index.shard.IndexShard.lambda$startRecovery$6(IndexShard.java:2043) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:573) [elasticsearch-6.2.3.jar:6.2.3]  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0\_161]  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0\_161]  
> at java.lang.Thread.run(Unknown Source) [?:1.8.0\_161]  
> Caused by: org.elasticsearch.index.shard.IndexShardRecoveryException: failed recovery  
> at org.elasticsearch.index.shard.StoreRecovery.executeRecovery(StoreRecovery.java:342) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.StoreRecovery.recoverFromStore(StoreRecovery.java:92) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.recoverFromStore(IndexShard.java:1607) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.lambda$startRecovery$6(IndexShard.java:2039) ~[elasticsearch-6.2.3.jar:6.2.3]  
> ... 4 more  
> Caused by: java.lang.IllegalStateException: Checkpoint file translog-17.ckp already exists but has corrupted content expected: Checkpoint{offset=43, numOps=0, generation=17, minSeqNo=-1, maxSeqNo=-1, globalCheckpoint=165, minTranslogGeneration=16} but got: Checkpoint{offset=43, numOps=0, generation=17, minSeqNo=-1, maxSeqNo=-1, globalCheckpoint=-1, minTranslogGeneration=16}  
> at org.elasticsearch.index.translog.Translog.recoverFromFiles(Translog.java:260) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.translog.Translog.(Translog.java:176) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.engine.InternalEngine.openTranslog(InternalEngine.java:524) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.engine.InternalEngine.(InternalEngine.java:185) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.engine.InternalEngine.(InternalEngine.java:152) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.engine.InternalEngineFactory.newReadWriteEngine(InternalEngineFactory.java:25) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.newEngine(IndexShard.java:2164) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.createNewEngine(IndexShard.java:2146) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.innerOpenEngineAndTranslog(IndexShard.java:1377) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.openIndexAndRecoveryFromTranslog(IndexShard.java:1331) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.StoreRecovery.internalRecoverFromStore(StoreRecovery.java:404) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.StoreRecovery.lambda$recoverFromStore$0(StoreRecovery.java:94) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.StoreRecovery.executeRecovery(StoreRecovery.java:300) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.StoreRecovery.recoverFromStore(StoreRecovery.java:92) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.recoverFromStore(IndexShard.java:1607) ~[elasticsearch-6.2.3.jar:6.2.3]  
> at org.elasticsearch.index.shard.IndexShard.lambda$startRecovery$6(IndexShard.java:2039) ~[elasticsearch-6.2.3.jar:6.2.3]  
> ... 4 more

I found a similar thread [Corrupted elastic index - #2 by thiago](https://discuss.elastic.co/t/corrupted-elastic-index/135932/2) but I do not know how to set the index settings.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2020, 8:05am UTC](https://discuss.elastic.co/t/recovery-failure-on-shard/227453/2 "2020-05-08T08:05:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
