# RecoveryFailedException after a node restart

**URL:** https://discuss.elastic.co/t/recoveryfailedexception-after-a-node-restart/24923
**Category:** Elasticsearch
**Created:** [July 6, 2015, 6:18am UTC](https://discuss.elastic.co/t/recoveryfailedexception-after-a-node-restart/24923 "2015-07-06T06:18:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Amol\_Sonawane](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@Amol\_Sonawane](https://discuss.elastic.co/u/Amol_Sonawane)
#### Post date: [July 6, 2015, 6:18am UTC](https://discuss.elastic.co/t/recoveryfailedexception-after-a-node-restart/24923/1 "2015-07-06T06:18:39Z")

</div>

Hi, I have been testing a 5 node elastic search cluster. When I restarted one of the nodes, I started getting RecoveryFailedException, I also tried cleaning up its data directory as well as set replication factor to zero. Still restarted node is crashing due to following error..  
org.elasticsearch.indices.recovery.RecoveryFailedException: : Recovery failed from [node-3][Rq2FL3-dRq-Oc0MkSlNd9Q][inet[/10.113.196.53:9300]]{max\_local\_storage\_nodes=1, master=false} into [node-4][rRJfI1TyQaKVZkPtMFairQ][aes05][inet[aes05/10.113.196.71:9300]]{max\_local\_storage\_nodes=1, master=false}  
at org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:280)  
at org.elasticsearch.indices.recovery.RecoveryTarget.access$700(RecoveryTarget.java:70)  
at org.elasticsearch.indices.recovery.RecoveryTarget$RecoveryRunner.doRun(RecoveryTarget.java:561)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:36)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.transport.TransportException: transport stopped, action: internal:index/shard/recovery/start\_recovery  
at org.elasticsearch.transport.TransportService$2.run(TransportService.java:178)  
... 3 more  
Can you please give me some pointers how to resolve this error?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 6, 2015, 8:10am UTC](https://discuss.elastic.co/t/recoveryfailedexception-after-a-node-restart/24923/2 "2015-07-06T08:10:11Z")

</div>

What version, what does your config look like?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:04pm UTC](https://discuss.elastic.co/t/recoveryfailedexception-after-a-node-restart/24923/4 "2017-07-05T22:04:51Z")

</div>


