# Red health status

**URL:** <https://discuss.elastic.co/t/red-health-status/103989>\
**Category:** Elasticsearch\
**Created:** [October 14, 2017, 12:28pm UTC](https://discuss.elastic.co/t/red-health-status/103989 "2017-10-14T12:28:55Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joozty](https://avatars.discourse-cdn.com/v4/letter/j/3e96dc/32.png) [@Joozty](https://discuss.elastic.co/u/Joozty)\
**Post date:** [October 14, 2017, 12:28pm UTC](https://discuss.elastic.co/t/red-health-status/103989/1 "2017-10-14T12:28:55Z")

</div>

My index has red health status and I don't know why. It cannot be becouse of disk space. I have more than 20TB avalaible.

My index settings:

```auto
    {
        "my_index": {
            "settings": {
                "index": {
                    "routing": {
                        "allocation": {
                            "disable_allocation": "false"
                        }
                    },
                    "number_of_shards": "12",
                    "creation_date": "1507474046012",
                    "analysis": {
                        "analyzer": {
                            "analyzer_keyword": {
                                "filter": "lowercase",
                                "tokenizer": "keyword"
                            }
                        }
                    },
                    "uuid": "MnMLSXIkQ8aTwKI_pFpE-A",
                    "version": {
                        "created": "1070599"
                    },
                    "number_of_replicas": "0"
                }
            }
        }
    }

```

When I run health check command:

```auto
localhost:9200/_cat/shards?h=index,shard,prirep,state,unassigned.reason

```

I got:

```
my_index 3 p UNASSIGNED CLUSTER_RECOVERED 
my_index 10 p UNASSIGNED CLUSTER_RECOVERED 
my_index 6 p UNASSIGNED CLUSTER_RECOVERED 
my_index 2 p UNASSIGNED CLUSTER_RECOVERED 
my_index 1 p UNASSIGNED CLUSTER_RECOVERED 
my_index 0 p UNASSIGNED CLUSTER_RECOVERED 
my_index 7 p UNASSIGNED CLUSTER_RECOVERED 
my_index 11 p UNASSIGNED CLUSTER_RECOVERED 
my_index 9 p UNASSIGNED CLUSTER_RECOVERED 
my_index 5 p UNASSIGNED CLUSTER_RECOVERED 
my_index 4 p UNASSIGNED CLUSTER_RECOVERED 
my_index 8 p UNASSIGNED CLUSTER_RECOVERED 

```

What should I do? Where can be a problem?

ElastisSearch version - 1.7.5

Thanks a lot

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 14, 2017, 1:25pm UTC](https://discuss.elastic.co/t/red-health-status/103989/2 "2017-10-14T13:25:57Z")

</div>

Please format your code using `</>` icon as explained in [this guide](https://discuss.elastic.co/t/about-the-elasticsearch-category/21). It will make your post more readable.

Or use markdown style like:

````
```
CODE
```

````

This version is too old and not supported anymore.  
What do you have in logs?

---

<div class="post-metadata">

**Author:** ![Joozty](https://avatars.discourse-cdn.com/v4/letter/j/3e96dc/32.png) [@Joozty](https://discuss.elastic.co/u/Joozty)\
**Post date:** [October 14, 2017, 1:39pm UTC](https://discuss.elastic.co/t/red-health-status/103989/3 "2017-10-14T13:39:24Z")

</div>

I tried to use code icon but it doesnt work for first code sample. 😕

In logsI can see:

```
[2017-10-14 15:38:21,506][WARN][cluster.action.shard] [Lionheart] [size_test_siren][8] received shard failed for [size_test_siren][8], node[gZlTCarDRjazHPFU8al15A], [P], s[INITIALIZING], unassigned_info[[reason=ALLOCATION_FAILED], at[2017-10-14T13:38:21.437Z], details[shard failure [failed recovery][IndexShardGatewayRecoveryException[[size_test_siren][8] failed recovery]; nested: IllegalArgumentException[An SPI class of type org.apache.lucene.codecs.PostingsFormat with name 'Siren10AFor' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [es090, completion090, XBloomFilter, IDVersion, Lucene40, Lucene41]]; ]]], indexUUID [p1ZhMCPSR-GIzLr16KeW5g], reason [shard failure [failed recovery][IndexShardGatewayRecoveryException[[size_test_siren][8] failed recovery]; nested: IllegalArgumentException[An SPI class of type org.apache.lucene.codecs.PostingsFormat with name 'Siren10AFor' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [es090, completion090, XBloomFilter, IDVersion, Lucene40, Lucene41]]; ]]
[2017-10-14 15:38:21,512][WARN][indices.cluster] [Lionheart] [[size_test_siren][0]] marking and sending shard failed due to [failed recovery]
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [size_test_siren][0] failed recovery
	at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:162)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.PostingsFormat with name 'Siren10AFor' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [es090, completion090, XBloomFilter, IDVersion, Lucene40, Lucene41]
	at org.apache.lucene.util.NamedSPILoader.lookup(NamedSPILoader.java:109)
	at org.apache.lucene.codecs.PostingsFormat.forName(PostingsFormat.java:100)
	at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsReader.<init>(PerFieldPostingsFormat.java:194)
	at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat.fieldsProducer(PerFieldPostingsFormat.java:254)
	at org.apache.lucene.index.SegmentCoreReaders.<init>(SegmentCoreReaders.java:120)
	at org.apache.lucene.index.SegmentReader.<init>(SegmentReader.java:108)
	at org.apache.lucene.index.ReadersAndUpdates.getReader(ReadersAndUpdates.java:145)
	at org.apache.lucene.index.ReadersAndUpdates.getReadOnlyClone(ReadersAndUpdates.java:239)
	at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:109)
	at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:421)
	at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:112)
	at org.apache.lucene.search.SearcherManager.<init>(SearcherManager.java:89)
	at org.elasticsearch.index.engine.InternalEngine.createSearcherManager(InternalEngine.java:186)
	at org.elasticsearch.index.engine.InternalEngine.<init>(InternalEngine.java:146)
	at org.elasticsearch.index.engine.InternalEngineFactory.newReadWriteEngine(InternalEngineFactory.java:32)
	at org.elasticsearch.index.shard.IndexShard.newEngine(IndexShard.java:1354)
	at org.elasticsearch.index.shard.IndexShard.createNewEngine(IndexShard.java:1349)
	at org.elasticsearch.index.shard.IndexShard.prepareForTranslogRecovery(IndexShard.java:869)
	at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:233)
	at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:112)
	... 3 more
```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 14, 2017, 5:04pm UTC](https://discuss.elastic.co/t/red-health-status/103989/4 "2017-10-14T17:04:52Z")

</div>

May be @jpountz have some ideas?

BTW are you using any plugin?

---

<div class="post-metadata">

**Author:** ![Joozty](https://avatars.discourse-cdn.com/v4/letter/j/3e96dc/32.png) [@Joozty](https://discuss.elastic.co/u/Joozty)\
**Post date:** [October 14, 2017, 5:22pm UTC](https://discuss.elastic.co/t/red-health-status/103989/5 "2017-10-14T17:22:21Z")

</div>

No, I don't use any plugins.

---

<div class="post-metadata">

**Author:** ![thiago](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thiago/32/32096_2.png) [@thiago](https://discuss.elastic.co/u/thiago)\
**Post date:** [October 14, 2017, 7:08pm UTC](https://discuss.elastic.co/t/red-health-status/103989/6 "2017-10-14T19:08:40Z")

</div>

This seems to be an index created with this plugin [https://github.com/sirensolutions/siren/tree/master/siren-elasticsearch](https://github.com/sirensolutions/siren/tree/master/siren-elasticsearch) and now the plugin is not installed anymore.

I can tell this because of the postings format used named `Siren10AFor` and I could only find a plugin that provides that format in that project.

You need to install that plugin to be able to recover this index.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 11, 2017, 7:08pm UTC](https://discuss.elastic.co/t/red-health-status/103989/7 "2017-11-11T19:08:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
