# REDIS Module : harvester/registry.go:83 Error running input: error receiving slowlog data: dial tcp 127.0.0.1:6379

**URL:** <https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [July 27, 2018, 7:28pm UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987 "2018-07-27T19:28:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![eric.franckx](https://avatars.discourse-cdn.com/v4/letter/e/a4c791/32.png) [@eric.franckx](https://discuss.elastic.co/u/eric.franckx)\
**Post date:** [July 27, 2018, 7:28pm UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/1 "2018-07-27T19:28:54Z")

</div>

Hi,

just try the Redis module on a Redis server but receives error message when start:  
_filebeat -e --modules system,redis_

The message in the console is the following:  
ERROR harvester/registry.go:83 Error running input: error receiving slowlog data: dial tcp **127.0.0.1:6379** : getsockopt: connection refused

Also in the config file of the Redis module: _modules.d/redis.yml_  
we have set the follwoing config:

- module: redis

--\> multiple Redis that don't list to localhost as access remotely. So why the message localhost:6379 ?  
Why does it try to access the localhost and not the IP or hostname set ?

Also with Redis you can you Sentinel that provide load balacing and automatic switch over of the Mastet/Slave. Shoudl Sentinel not be also supported ?

Regards,

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [July 27, 2018, 8:11pm UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/2 "2018-07-27T20:11:13Z")

</div>

What version of Filebeat are you using?

---

<div class="post-metadata">

**Author:** ![eric.franckx](https://avatars.discourse-cdn.com/v4/letter/e/a4c791/32.png) [@eric.franckx](https://discuss.elastic.co/u/eric.franckx)\
**Post date:** [July 29, 2018, 8:36am UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/3 "2018-07-29T08:36:00Z")

</div>

filebeat version 6.3.2

---

<div class="post-metadata">

**Author:** ![eric.franckx](https://avatars.discourse-cdn.com/v4/letter/e/a4c791/32.png) [@eric.franckx](https://discuss.elastic.co/u/eric.franckx)\
**Post date:** [July 29, 2018, 8:44am UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/4 "2018-07-29T08:44:05Z")

</div>

2 Redis instances running on the same server:  
redis\_01 on port 6379  
redis\_02 on port 26379

1 is the Master and the second is the slave (replication).

The connection to the instance works from the redis server and from any remote server that require to access the Redis instances.

**redis-cli -h poc-pex-redis-02 -p 26379 -a xxxxxx INFO | grep -i master**  
role:master  
master\_repl\_offset:19099124

**redis-cli -h poc-pex-redis-02 -p 26379 -a xxxxxx INFO | grep -i slave**  
connected\_slaves:1  
slave0:ip=10.0.193.56,port=6379,state=online,offset=19097814,lag=1

It is also protected by a password. If not set during access, connection is rejected and no data is send as response.

Also for HA we have set Sentinel that monitor Redis instance and response to any request the IP of the master.

In the Redis module config file:

- module: redis

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [August 3, 2018, 2:39pm UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/5 "2018-08-03T14:39:11Z")

</div>

The `redis` module should only use `var.hosts` for the `slowlog` fileset. It should not use it for the `log` fileset. So that fact that it's even trying to connect to `127.0.0.1:6379` is odd.

Could you post the _entire_ log from the moment you start running `filebeat`, please (not just the error line)?

Also, could you post your _complete_ `filebeat.yml` and re-post your _complete_ `modules.d/redis.yml`. For each of these files, when you post them here, please wrap the contents in ``` and ``` so the formatting of the files is preserved exactly as it is on your machine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 31, 2018, 2:39pm UTC](https://discuss.elastic.co/t/redis-module-harvester-registry-go-83-error-running-input-error-receiving-slowlog-data-dial-tcp-127-0-0-1-6379/141987/6 "2018-08-31T14:39:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
