# Reindex Api "didn't store \_source" error

**URL:** <https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043>\
**Category:** Elasticsearch\
**Tags:** reindex\
**Created:** [November 13, 2023, 5:15pm UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043 "2023-11-13T17:15:37Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hakan\_Kara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hakan_kara/32/127510_2.png) [@Hakan\_Kara](https://discuss.elastic.co/u/Hakan_Kara)\
**Post date:** [November 13, 2023, 5:15pm UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/1 "2023-11-13T17:15:37Z")

</div>

Hello, we are getting following error while using reindex api. Could we ignore these kind of errors with reindex api ?

Or could we destroy the following doc with given id ?

```auto
{
    "type" : "illegal_argument_exception",
    "reason" : "[listing__20220510_2001][_doc][1c0d897e5a0cc93f4ba4dc665be0ca88] didn't store _source"
}

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 13, 2023, 7:21pm UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/2 "2023-11-13T19:21:17Z")

</div>

It means that this document does not have a `_source` field. This looks weird if the other documents of the same index do have this field IMO.

---

<div class="post-metadata">

**Author:** ![Hakan\_Kara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hakan_kara/32/127510_2.png) [@Hakan\_Kara](https://discuss.elastic.co/u/Hakan_Kara)\
**Post date:** [November 13, 2023, 8:04pm UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/3 "2023-11-13T20:04:38Z")

</div>

Yes same index, it can reindex 424M documents until reached this weird document.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 13, 2023, 8:20pm UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/4 "2023-11-13T20:20:58Z")

</div>

Which version of Elasticsearch are you using?

---

<div class="post-metadata">

**Author:** ![Hakan\_Kara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hakan_kara/32/127510_2.png) [@Hakan\_Kara](https://discuss.elastic.co/u/Hakan_Kara)\
**Post date:** [November 14, 2023, 5:48am UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/5 "2023-11-14T05:48:46Z")

</div>

ES version is 7.10.2 @Christian_Dahlqvist

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2023, 5:49am UTC](https://discuss.elastic.co/t/reindex-api-didnt-store-source-error/347043/6 "2023-12-12T05:49:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
