# Reindex fails on array formatted geo\_point

**URL:** https://discuss.elastic.co/t/reindex-fails-on-array-formatted-geo-point/107054
**Category:** Elasticsearch
**Created:** [November 9, 2017, 2:26pm UTC](https://discuss.elastic.co/t/reindex-fails-on-array-formatted-geo-point/107054 "2017-11-09T14:26:11Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![andrewgstreet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewgstreet/32/24029_2.png) [@andrewgstreet](https://discuss.elastic.co/u/andrewgstreet)
#### Post date: [November 9, 2017, 2:26pm UTC](https://discuss.elastic.co/t/reindex-fails-on-array-formatted-geo-point/107054/1 "2017-11-09T14:26:11Z")

</div>

I'm trying to perform a reindex with only subtle mapping changes. One those changes doesn't apply to a field with the type of geo\_point.

In the existing index, the mapping is

`{MapCoordinate : {"type":"geo_point"}}`

In the destination index, the mapping is

`{MapCoordinate : {"type":"geo_point"}}`

The form of the data in the existing index is:

`"MapCoordinate": [-90.874886, 37.917992]`

However, when performing the reindex operation, all elements fail with

```
`{
	"index": "xyz",
	"type": "thetype",
	"id": "theid",
	"cause": {
		"type": "mapper_parsing_exception",
		"reason": "failed to parse",
		"caused_by": {
			"type": "parse_exception",
			"reason": "geo_point expected"
		}
	},
	"status": 400
}`

```

The documentation @ [https://www.elastic.co/guide/en/elasticsearch/reference/current/geo-point.html#CO185-4](https://www.elastic.co/guide/en/elasticsearch/reference/current/geo-point.html#CO185-4)  
states that [lon,lat] is totally valid format for geo\_points.

Any thoughts on a work around? This seems like a bug to me. I have no way to tell, but a suspect if my property were in the form of

`"MapCoordinate": {lon: -90.874886, lat:37.917992}`

I wouldn't be having this problem.

Thanks!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 7, 2017, 2:26pm UTC](https://discuss.elastic.co/t/reindex-fails-on-array-formatted-geo-point/107054/2 "2017-12-07T14:26:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
