# Reindexing Timeout

**URL:** https://discuss.elastic.co/t/reindexing-timeout/93467
**Category:** Elasticsearch
**Created:** [July 17, 2017, 10:38pm UTC](https://discuss.elastic.co/t/reindexing-timeout/93467 "2017-07-17T22:38:17Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![seanziee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/seanziee/32/45151_2.png) [@seanziee](https://discuss.elastic.co/u/seanziee)
#### Post date: [July 17, 2017, 10:38pm UTC](https://discuss.elastic.co/t/reindexing-timeout/93467/1 "2017-07-17T22:38:17Z")

</div>

Hi there,

I'm reindexing a data set from one cluster to another and I keep getting a timeout which stops the reindex from completing. It stops after about 15 seconds and after about 500mb has been transferred. I'm importing about 9gb of data from one cluster of ES to another. Any idea what this error code is caused by?

```
{
"statusCode": 504,
"error": "Gateway Timeout",
"message": "Client request timeout"
}
```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 14, 2017, 10:38pm UTC](https://discuss.elastic.co/t/reindexing-timeout/93467/2 "2017-08-14T22:38:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
