_remote/info?pretty cannot get the accurate/latest information

After I set up the cross-cluster search and restarted the ES node, this API doesn't return empty seeds node until I make a cross-cluster search request.

Is it a bug? And how to address it?

Here is the empty feedback.

{
    "seeds" : [ ],
    "http_addresses" : [ ],
    "connected" : false,
    "num_nodes_connected" : 0,
    "max_connections_per_cluster" : 3,
    "initial_connect_timeout" : "30s",
    "skip_unavailable" : true
  }

which versions of Elasticsearch are involved in this?

I am using 6.2. And I've head there is some fix on 6.6 by introducing a new setting: https://github.com/elastic/elasticsearch/pull/34753

Right?

Hi,
do you configure CCS in elasticsearch.yml or via cluster update settings API?

REST API

Restarting nodes should not be necessary. As long as you wait for the response of the cluster update settings API to come back, the connection to the remote clusters should initiated. What do you get back from the cluster update settings API?

The cluster setting update is sccessful because I get {ackownledged: true} response.

Ok, and can you reproduce this all the time? Meaning every time you register a new cluster, you call remote info API after cluster update settings API has returned, and you get no nodes connected, yet you run search, you get results and the nodes appear in the output of remote info?

I am asking because it may happen depending on your setup, I guess, but it's not the expected behaviour.

Yes. I can reproduce it.

Could you say something more about your network layout?

Two clusters are in the same local network. I have two physical servers running docker on containers over calico network.