# Removing one of the s3 snapshot repository causing connection pool shutdown

**URL:** <https://discuss.elastic.co/t/removing-one-of-the-s3-snapshot-repository-causing-connection-pool-shutdown/329857>\
**Category:** Elasticsearch\
**Tags:** slm-snapshot-lifecycle-management, snapshot-and-restore\
**Created:** [April 12, 2023, 4:13pm UTC](https://discuss.elastic.co/t/removing-one-of-the-s3-snapshot-repository-causing-connection-pool-shutdown/329857 "2023-04-12T16:13:44Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Vivek\_Shinde](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vivek_shinde/32/117294_2.png) [@Vivek\_Shinde](https://discuss.elastic.co/u/Vivek_Shinde)\
**Post date:** [April 12, 2023, 4:13pm UTC](https://discuss.elastic.co/t/removing-one-of-the-s3-snapshot-repository-causing-connection-pool-shutdown/329857/1 "2023-04-12T16:13:44Z")

</div>

Hello - When we configure single S3 bucket for backup, snapshot functionality is working as expected. But when we create a additional repository and remove it afterwards, elasticsearch snapshot functionality is failing to work. Sometimes, pointing to "Snapshot could not be read" error and sometime causing "Connection pool shut down" error.

At this time, if we restart elastic, snapshot functionality starts working as normal.  
Any suggestions ?

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [April 13, 2023, 2:31am UTC](https://discuss.elastic.co/t/removing-one-of-the-s3-snapshot-repository-causing-connection-pool-shutdown/329857/2 "2023-04-13T02:31:02Z")

</div>

> [@Vivek\_Shinde](#):
>
> But when we create a additional repository and remove it afterwards, elasticsearch snapshot functionality is failing to work. Sometimes, pointing to "Snapshot could not be read" error and sometime causing "Connection pool shut down" error.

You need to share logs with evidences of your issue, without logs is not possible to help further or to know what may be happening.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2023, 2:32am UTC](https://discuss.elastic.co/t/removing-one-of-the-s3-snapshot-repository-causing-connection-pool-shutdown/329857/3 "2023-05-11T02:32:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
