# Reporting not sending me the reports

**URL:** <https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341>\
**Category:** Kibana\
**Tags:** elastic-stack-reporting\
**Created:** [September 23, 2016, 6:41am UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341 "2016-09-23T06:41:09Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![vk126y](https://avatars.discourse-cdn.com/v4/letter/v/aeb1de/32.png) [@vk126y](https://discuss.elastic.co/u/vk126y)\
**Post date:** [September 23, 2016, 6:41am UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/1 "2016-09-23T06:41:09Z")

</div>

I have successfully configured the reports plugin but not able to generate the reports and getting the below errors

> There was an error generating your report for the "Login-Dashboard" dashboard: Error: URL open failed. Is the server running?

My ELK stack is up and running successfully.

PFA the error screen shots.

Let me know if there are any configurations need to be added in my Kibana as I am running this behind a proxy.

 ![](https://us1.discourse-cdn.com/elastic/original/2X/1/13be871511613ac2d9d136d92efa7535840f5325.png) ![](https://us1.discourse-cdn.com/elastic/original/2X/0/06a34b50a580d05ce47ca04b6d7a80e92def663d.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 25, 2016, 6:12am UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/2 "2016-09-25T06:12:07Z")

</div>

What version of things are you running?

---

<div class="post-metadata">

**Author:** ![pksingh](https://avatars.discourse-cdn.com/v4/letter/p/bbce88/32.png) [@pksingh](https://discuss.elastic.co/u/pksingh)\
**Post date:** [September 27, 2016, 4:33am UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/3 "2016-09-27T04:33:58Z")

</div>

Hi Mark,

I am writing on behalf of vinay.

The version which we are using are as below:  
Elasticsearch --2.4.0  
Logstash --2.4.0  
Kibana --4.6.1  
Marvel/Marvel Agent --2.4.0  
Sense --2.0.0  
Watcher --2.4.0

Thanks,  
Pradip K Singh

---

<div class="post-metadata">

**Author:** ![vk126y](https://avatars.discourse-cdn.com/v4/letter/v/aeb1de/32.png) [@vk126y](https://discuss.elastic.co/u/vk126y)\
**Post date:** [September 27, 2016, 3:54pm UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/4 "2016-09-27T15:54:03Z")

</div>

anyone can please update why reporting is not workable in my environments.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [October 10, 2016, 11:16pm UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/5 "2016-10-10T23:16:52Z")

</div>

What's the IP you are connecting to in your screenshots?

Is your Kibana/Reporting setup running on another machine?

Did you set a custom `server.host` value in your `kibana.yml` file?

The error comes up when the background process can't connect to the running Kibana instance. Usually this happens because you're using a proxy or something to connect to Kibana, but it may also be caused by changing the hostname you are binding Kibana to.

---

<div class="post-metadata">

**Author:** ![vk126y](https://avatars.discourse-cdn.com/v4/letter/v/aeb1de/32.png) [@vk126y](https://discuss.elastic.co/u/vk126y)\
**Post date:** [October 13, 2016, 7:26pm UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/6 "2016-10-13T19:26:02Z")

</div>

> [@Joe\_Fleming](#):
>
> hostname

Yes Joe ,

It was because of wrong hostname binding , by default its server.host: "0.0.0.0" and I updated it to server.host: "127.0.0.1" or my actual IP address and it worked as expected.

Thanks a ton !!

Cheers  
Vinay Kumar

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [October 13, 2016, 10:36pm UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/7 "2016-10-13T22:36:43Z")

</div>

Great, thanks for closing the loop here.

Out of curiosity, were you running Kibana on a Windows server? This was a known issue that's [been fixed](https://github.com/elastic/kibana/pull/8013).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:43pm UTC](https://discuss.elastic.co/t/reporting-not-sending-me-the-reports/61341/8 "2017-07-06T13:43:02Z")

</div>


