# Repositories for YUM Error generated

**URL:** <https://discuss.elastic.co/t/repositories-for-yum-error-generated/735>\
**Category:** Elasticsearch\
**Created:** [May 15, 2015, 7:15am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735 "2015-05-15T07:15:07Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![ydbank](https://avatars.discourse-cdn.com/v4/letter/y/ea666f/32.png) [@ydbank](https://discuss.elastic.co/u/ydbank)\
**Post date:** [May 15, 2015, 7:15am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/1 "2015-05-15T07:15:07Z")

</div>

[root@localhost software]# cat /etc/yum.repos.d/elasticsearch.repo  
[elasticsearch]  
name=Elasticsearch  
baseurl=http://packages.elastic.co/elasticsearch/1.5/centos  
gpgcheck=1  
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch  
enabled=1  
[root@localhost software]# rpm --import [https://packages.elastic.co/GPG-KEY-elasticsearch](https://packages.elastic.co/GPG-KEY-elasticsearch)  
error: [https://packages.elastic.co/GPG-KEY-elasticsearch:](https://packages.elastic.co/GPG-KEY-elasticsearch:) import read failed(-1).  
[root@localhost software]# rpm --import [http://packages.elastic.co/GPG-KEY-elasticsearch](http://packages.elastic.co/GPG-KEY-elasticsearch)  
[root@localhost software]# yum install elasticsearch  
Loaded plugins: fastestmirror, security  
Loading mirror speeds from cached hostfile

- base: [mirrors.btte.net](http://mirrors.btte.net)
- extras: [mirrors.sina.cn](http://mirrors.sina.cn)
- updates: [mirrors.sina.cn](http://mirrors.sina.cn)  
elasticsearch | 2.9 kB 00:00  
elasticsearch/primary\_db | 2.9 kB 00:00  
[http://packages.elastic.co/elasticsearch/1.5/centos/repodata/53affd1b65c791b1a24b0921d6592fea88fc1391d5cf8659a668234b66c52399-primary.sqlite.bz2:](http://packages.elastic.co/elasticsearch/1.5/centos/repodata/53affd1b65c791b1a24b0921d6592fea88fc1391d5cf8659a668234b66c52399-primary.sqlite.bz2:) [Errno -3] Error performing checksum  
Trying other mirror.  
elasticsearch/primary\_db | 2.9 kB 00:01  
[http://packages.elastic.co/elasticsearch/1.5/centos/repodata/53affd1b65c791b1a24b0921d6592fea88fc1391d5cf8659a668234b66c52399-primary.sqlite.bz2:](http://packages.elastic.co/elasticsearch/1.5/centos/repodata/53affd1b65c791b1a24b0921d6592fea88fc1391d5cf8659a668234b66c52399-primary.sqlite.bz2:) [Errno -3] Error performing checksum  
Trying other mirror.  
Error: failure: repodata/53affd1b65c791b1a24b0921d6592fea88fc1391d5cf8659a668234b66c52399-primary.sqlite.bz2 from elasticsearch: [Errno 256] No more mirrors to try.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 15, 2015, 11:30pm UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/2 "2015-05-15T23:30:11Z")

</div>

I think this is a problem with older versions of RPM, what version of CentOS are you on?

---

<div class="post-metadata">

**Author:** ![ydbank](https://avatars.discourse-cdn.com/v4/letter/y/ea666f/32.png) [@ydbank](https://discuss.elastic.co/u/ydbank)\
**Post date:** [May 20, 2015, 8:10am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/3 "2015-05-20T08:10:59Z")

</div>

centos5.8 32bit

[root@localhost kibana-4.0.2-linux-x86]# cat /etc/redhat-release  
CentOS release 5.8 (Final)  
[root@localhost kibana-4.0.2-linux-x86]# uname -a  
Linux localhost 2.6.18-308.el5 #1 SMP Tue Feb 21 20:05:41 EST 2012 i686 i686 i386 GNU/Linux  
[root@localhost kibana-4.0.2-linux-x86]# file /bin/ls  
/bin/ls: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), stripped  
[root@localhost kibana-4.0.2-linux-x86]# rpm --version  
RPM version 4.4.2.3

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 20, 2015, 8:20am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/4 "2015-05-20T08:20:34Z")

</div>

Try telling RPM to ignore the signing, there is a flag for it but I dunno what it is sorry!

---

<div class="post-metadata">

**Author:** ![ydbank](https://avatars.discourse-cdn.com/v4/letter/y/ea666f/32.png) [@ydbank](https://discuss.elastic.co/u/ydbank)\
**Post date:** [May 20, 2015, 8:37am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/5 "2015-05-20T08:37:39Z")

</div>

May be：  
gpgcheck=0

AS：  
[root@localhost ~]# cat /etc/yum.repos.d/elasticsearch.repo  
[elasticsearch]  
name=Elasticsearch  
baseurl=http://packages.elastic.co/elasticsearch/1.5/centos  
gpgcheck=0  
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch  
enabled=1

I have done so.

---

<div class="post-metadata">

**Author:** ![ydbank](https://avatars.discourse-cdn.com/v4/letter/y/ea666f/32.png) [@ydbank](https://discuss.elastic.co/u/ydbank)\
**Post date:** [May 20, 2015, 8:42am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/6 "2015-05-20T08:42:46Z")

</div>

直接打开http://packages.elastic.co/elasticsearch/1.5/centos/  
却什么都没有。  
但打开http://vault.centos.org/6.6/os/Source/SPackages/至少能看到列表。

Directly open [http://packages.elastic.co/elasticsearch/1.5/centos/](http://packages.elastic.co/elasticsearch/1.5/centos/)  
But nothing.  
But at least be able to see a list of open [http://vault.centos.org/6.6/os/Source/SPackages/](http://vault.centos.org/6.6/os/Source/SPackages/).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:13am UTC](https://discuss.elastic.co/t/repositories-for-yum-error-generated/735/7 "2017-07-06T00:13:08Z")

</div>


