# Repository

**URL:** https://discuss.elastic.co/t/repository/37948
**Category:** Elasticsearch
**Created:** [December 24, 2015, 3:38pm UTC](https://discuss.elastic.co/t/repository/37948 "2015-12-24T15:38:26Z")
**Posts on this page:** 15
**Page:** 1

<div class="post-metadata">

### Author: ![Hilal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilal/32/7684_2.png) [@Hilal](https://discuss.elastic.co/u/Hilal)
#### Post date: [December 24, 2015, 3:38pm UTC](https://discuss.elastic.co/t/repository/37948/1 "2015-12-24T15:38:26Z")

</div>

Hi,

I am trying to snapshot and restore module in elasticsearch but ı have a problem.  
I am using marvel plugin. My repository codes:

PUT /\_snapshot/my\_backup/  
{  
"type": "fs",  
"settings": {  
"location": "/root/backup/",  
"compress": true  
}  
}

RESULT ERROR:  
{  
"error": {  
"root\_cause": [  
{  
"type": "repository\_exception",  
"reason": "[my\_backup] failed to create repository"  
}  
],  
"type": "repository\_exception",  
"reason": "[my\_backup] failed to create repository",  
"caused\_by": {  
"type": "creation\_exception",  
"reason": "Guice creation errors:\n\n1) Error injecting constructor, RepositoryException[[my\_backup] location [/root/backup/] doesn't match any of the locations specified by path.repo because this setting is empty]\n at org.elasticsearch.repositories.fs.FsRepository.(Unknown Source)\n while locating org.elasticsearch.repositories.fs.FsRepository\n while locating org.elasticsearch.repositories.Repository\n\n1 error",  
"caused\_by": {  
"type": "repository\_exception",  
"reason": "[my\_backup] location [/root/backup/] doesn't match any of the locations specified by path.repo because this setting is empty"  
}  
}  
},  
"status": 500  
}

What is the problem?

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 24, 2015, 5:12pm UTC](https://discuss.elastic.co/t/repository/37948/2 "2015-12-24T17:12:42Z")

</div>

You did not set path.repo in settings.

---

<div class="post-metadata">

### Author: ![Hilal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilal/32/7684_2.png) [@Hilal](https://discuss.elastic.co/u/Hilal)
#### Post date: [December 25, 2015, 7:42am UTC](https://discuss.elastic.co/t/repository/37948/3 "2015-12-25T07:42:04Z")

</div>

Thank you. So how can I do?I am using Centos 6.7 , Elasticsearch 2.1 and Marvel 1.3.1I did path.repo:["/mount/backups","/mount/longterm\_backups"] in elasticsearch.yml but ıt had same error. 24.12.2015, 19:23, "David Pilato" \<noreply@discuss.elastic.co\>:

> ![](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/45/12_1.png "dadoonet")[dadoonet](http://discuss.elastic.co/users/dadoonet)[David Pilato](http://discuss.elastic.co/users/dadoonet)Developer | Evangelist
> 
> December 24
> 
> You did not set path.repo in settings.
> 
> To respond, reply to this email or [visit the topic](http://discuss.elastic.co/t/repository/37948/2).
> 
> * * *
> 
> #### Previous Replies
> ![](upload://AmD9Iw4N2uQixdqSwbOoiMR7r16.png "Hilal")[Hilal](http://discuss.elastic.co/users/hilal)
> 
> December 24
> 
> Hi,
> 
> I am trying to snapshot and restore module in elasticsearch but ı have a problem.
> 
> I am using marvel plugin. My repository codes:
> 
> PUT /\_snapshot/my\_backup/
> 
> {
> 
> "type": "fs",
> 
> "settings": {
> 
> "location": "/root/backup/",
> 
> "compress": true
> 
> }
> 
> }
> 
> RESULT ERROR:
> 
> {
> 
> "error": {
> 
> "root\_cause": [
> 
> {
> 
> "type": "repository\_exception",
> 
> "reason": "[my\_backup] failed to create repository"
> 
> }
> 
> ],
> 
> "type": "repository\_exception",
> 
> "reason": "[my\_backup] failed to create repository",
> 
> "caused\_by": {
> 
> "type": "creation\_exception",
> 
> "reason": "Guice creation errors:\n\n1) Error injecting constructor, RepositoryException[[my\_backup] location [/root/backup/] doesn't match any of the locations specified by path.repo because this setting is empty]\n at org.elasticsearch.repositories.fs.FsRepository.(Unknown Source)\n while locating org.elasticsearch.repositories.fs.FsRepository\n while locating org.elasticsearch.repositories.Repository\n\n1 error",
> 
> "caused\_by": {
> 
> "type": "repository\_exception",
> 
> "reason": "[my\_backup] location [/root/backup/] doesn't match any of the locations specified by path.repo because this setting is empty"
> 
> }
> 
> }
> 
> },
> 
> "status": 500
> 
> }
> 
> What is the problem?
> 
> * * *
> 
> To respond, reply to this email or [visit the topic](http://discuss.elastic.co/t/repository/37948/2).
> 
> To stop receiving notifications for this particular topic, [click here](http://discuss.elastic.co/t/repository/37948/unsubscribe). To unsubscribe from these emails, change your [user preferences](http://discuss.elastic.co/my/preferences).

**--**  **Hilal GÜR**** İhale Yazılım Yayıncılık Reklamcılık Ltd.Şti. **Eskişehir Yolu No:266 Tepe Prime İş Merkezi C Blok D:44 Çankaya / Ankara** Tel: **0312 287 6556** Faks: **0312 911 3527** E-Posta:** [hilal.gur@ihale.com.tr](http://mailto:hilal.gur@ihale.com.tr)

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 25, 2015, 5:55pm UTC](https://discuss.elastic.co/t/repository/37948/4 "2015-12-25T17:55:54Z")

</div>

> [@Hilal](#):
>
> Elasticsearch 2.1 and Marvel 1.3.1

That does not look possible to me.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [December 25, 2015, 6:36pm UTC](https://discuss.elastic.co/t/repository/37948/5 "2015-12-25T18:36:35Z")

</div>

> [@Hilal](#):
>
> "reason": "[my\_backup] location [/root/backup/] doesn't match any of the locations specified by path.repo because this setting is empty"

It looks like the problem is that '/root/backup/' does not match any of the configured paths;["/mount/backups","/mount/longterm\_backups"]

---

<div class="post-metadata">

### Author: ![Hilal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilal/32/7684_2.png) [@Hilal](https://discuss.elastic.co/u/Hilal)
#### Post date: [December 28, 2015, 2:09pm UTC](https://discuss.elastic.co/t/repository/37948/6 "2015-12-28T14:09:08Z")

</div>

Hi,

I am tyring again:

**My elasticsearch.yml codes:**

```auto
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
# path.data: /path/to/data
#
# Path to log files:
#
# path.logs: /path/to/logs
# path.repo: ["/root/backup"]

```

**My Codes:**

```auto
 PUT /_snapshot/my_backup
{
    "type": "fs",
    "settings": {
        "location": "/root/backup",
        "compress": true
    }
}

```

My Result Error:

```auto
{
   "error": {
      "root_cause": [
         {
            "type": "repository_exception",
            "reason": "[my_backup] failed to create repository"
         }
      ],
      "type": "repository_exception",
      "reason": "[my_backup] failed to create repository",
      "caused_by": {
         "type": "creation_exception",
         "reason": "Guice creation errors:\n\n1) Error injecting constructor, RepositoryException[[my_backup] location [/root/backup] doesn't match any of the locations specified by path.repo because this setting is empty]\n at org.elasticsearch.repositories.fs.FsRepository.<init>(Unknown Source)\n while locating org.elasticsearch.repositories.fs.FsRepository\n while locating org.elasticsearch.repositories.Repository\n\n1 error",
         "caused_by": {
            "type": "repository_exception",
            "reason": "[my_backup] location [/root/backup] doesn't match any of the locations specified by path.repo because this setting is empty"
         }
      }
   },
   "status": 500
}

```

What can I do?

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 28, 2015, 4:55pm UTC](https://discuss.elastic.co/t/repository/37948/7 "2015-12-28T16:55:58Z")

</div>

uncomment `path.repo: ["/root/backup"]`

---

<div class="post-metadata">

### Author: ![sukesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukesh/32/10890_2.png) [@sukesh](https://discuss.elastic.co/u/sukesh)
#### Post date: [July 13, 2016, 6:26am UTC](https://discuss.elastic.co/t/repository/37948/8 "2016-07-13T06:26:01Z")

</div>

Hi David,

even though after uncomment also its not working  
same exception is throwing there

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 13, 2016, 6:45am UTC](https://discuss.elastic.co/t/repository/37948/9 "2016-07-13T06:45:21Z")

</div>

Can you paste the logs and your full config file?

---

<div class="post-metadata">

### Author: ![sukesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukesh/32/10890_2.png) [@sukesh](https://discuss.elastic.co/u/sukesh)
#### Post date: [July 13, 2016, 6:54am UTC](https://discuss.elastic.co/t/repository/37948/10 "2016-07-13T06:54:18Z")

</div>

elasticsearch.yml:

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

# path.data: /path/to/data

# 

# Path to log files:

# 

# path.logs: /path/to/logs

# 

path.repo: [D:/elasticsearch-2.3.1/repo/my\_backup]

# 

logs:

[2016-07-12 14:56:07,436][WARN][repositories] [Temugin] failed to create repository [my\_backup]  
RepositoryException[[my\_backup] failed to create repository]; nested: IllegalArgumentException[Unknown [repository] type [VerticalDetails]];  
at org.elasticsearch.repositories.RepositoriesService.createRepositoryHolder(RepositoriesService.java:411)  
at org.elasticsearch.repositories.RepositoriesService.registerRepository(RepositoriesService.java:368)  
at org.elasticsearch.repositories.RepositoriesService.access$100(RepositoriesService.java:55)  
at org.elasticsearch.repositories.RepositoriesService$1.execute(RepositoriesService.java:110)  
at org.elasticsearch.cluster.ClusterStateUpdateTask.execute(ClusterStateUpdateTask.java:45)  
at org.elasticsearch.cluster.service.InternalClusterService.runTasksForExecutor(InternalClusterService.java:468)  
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:772)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:231)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:194)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.lang.IllegalArgumentException: Unknown [repository] type [VerticalDetails]  
at org.elasticsearch.common.util.ExtensionPoint$SelectedType.bindType(ExtensionPoint.java:146)  
at org.elasticsearch.repositories.RepositoryTypesRegistry.bindType(RepositoryTypesRegistry.java:49)  
at org.elasticsearch.repositories.RepositoryModule.configure(RepositoryModule.java:58)  
at org.elasticsearch.common.inject.AbstractModule.configure(AbstractModule.java:60)  
at org.elasticsearch.common.inject.spi.Elements$RecordingBinder.install(Elements.java:233)  
at org.elasticsearch.common.inject.spi.Elements.getElements(Elements.java:105)  
at org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:143)  
at org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:99)  
at org.elasticsearch.common.inject.InjectorImpl.createChildInjector(InjectorImpl.java:162)  
at org.elasticsearch.common.inject.ModulesBuilder.createChildInjector(ModulesBuilder.java:55)  
at org.elasticsearch.repositories.RepositoriesService.createRepositoryHolder(RepositoriesService.java:404)  
... 11 more

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 13, 2016, 10:49am UTC](https://discuss.elastic.co/t/repository/37948/12 "2016-07-13T10:49:39Z")

</div>

Please format your code using `</>`.

`D:/elasticsearch-2.3.1/repo/my_backup` is not `D:\elasticsearch-2.3.1\repo\my_backup`

---

<div class="post-metadata">

### Author: ![sukesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukesh/32/10890_2.png) [@sukesh](https://discuss.elastic.co/u/sukesh)
#### Post date: [July 13, 2016, 10:54am UTC](https://discuss.elastic.co/t/repository/37948/13 "2016-07-13T10:54:32Z")

</div>

i tried to change in config file as you suggested in path.repo: [D:/elasticsearch-2.3.1/repo/my\_backup]  
, after changing that i tried to restart the ES but its failing to start the service.

If i give with # tag then ES service is starting successfully , like # path.repo: [D:/elasticsearch-2.3.1/repo/my\_backup]

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 13, 2016, 11:03am UTC](https://discuss.elastic.co/t/repository/37948/14 "2016-07-13T11:03:09Z")

</div>

```auto
path.repo: ["D:/elasticsearch-2.3.1/repo/my_backup"]

```

---

<div class="post-metadata">

### Author: ![sukesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukesh/32/10890_2.png) [@sukesh](https://discuss.elastic.co/u/sukesh)
#### Post date: [July 13, 2016, 11:09am UTC](https://discuss.elastic.co/t/repository/37948/15 "2016-07-13T11:09:28Z")

</div>

thank You David, Its created ,acknowledge is true

I am using the

PUT /\_snapshot/my\_backup  
{

```
  "type": "fs",

  "settings":
  {
  "location": "D:\\elasticsearch-2.3.1\\repo\\my_backup"
  }

```

}

command in kibana.

in elasticsearch.yml i wrote like path.repo: ["D:/elasticsearch-2.3.1/repo/my\_backup"] without # tag

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:36pm UTC](https://discuss.elastic.co/t/repository/37948/16 "2017-07-05T22:36:06Z")

</div>


