# RepositoryMissingException when restoring into a new cluster

**URL:** <https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518>\
**Category:** Elasticsearch\
**Created:** [January 7, 2015, 7:19am UTC](https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518 "2015-01-07T07:19:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Thomas\_Ardal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomas_ardal/32/7956_2.png) [@Thomas\_Ardal](https://discuss.elastic.co/u/Thomas_Ardal)\
**Post date:** [January 7, 2015, 7:19am UTC](https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518/1 "2015-01-07T07:19:33Z")

</div>

I'm using the snapshot/restore feature of Elasticsearch, together with the  
Azure plugin to backup snapshots to Azure blob storage. Everything works  
when doing snapshots from a cluster and restoring to the same cluster. Now  
I'm in a situation where I want to restore an entirely new cluster (let's  
call that cluster b) from a snapshot generated from cluster a. When I run a  
restore request on cluster b, I get a 404. Doing a \_status call on the  
snapshot, I get the same error:

{"error":"RepositoryMissingException[[elasticsearch\_logs] missing]","status":404}

The new cluster is configured with the Azure plugin and the same settings for Azure. I guess the error is caused by the fact, that Elasticsearch generates some metadata about the snapshots and store them locally in a the \_snapshot index and this index is not on the new cluster. The same error is happening if I delete the data dir on cluster a and try to restore cluster a from a snapshot.

How would I deal with a situation like this?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 7, 2015, 7:30am UTC](https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518/2 "2015-01-07T07:30:59Z")

</div>

Did you create the repository on cluster B?  
How?

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

> Le 7 janv. 2015 à 08:19, Thomas Ardal [thomasardal@gmail.com](mailto:thomasardal@gmail.com) a écrit :
> 
> I'm using the snapshot/restore feature of Elasticsearch, together with the Azure plugin to backup snapshots to Azure blob storage. Everything works when doing snapshots from a cluster and restoring to the same cluster. Now I'm in a situation where I want to restore an entirely new cluster (let's call that cluster b) from a snapshot generated from cluster a. When I run a restore request on cluster b, I get a 404. Doing a \_status call on the snapshot, I get the same error:
> 
> {"error":"RepositoryMissingException[[elasticsearch\_logs] missing]","status":404}
> 
> The new cluster is configured with the Azure plugin and the same settings for Azure. I guess the error is caused by the fact, that Elasticsearch generates some metadata about the snapshots and store them locally in a the \_snapshot index and this index is not on the new cluster. The same error is happening if I delete the data dir on cluster a and try to restore cluster a from a snapshot.
> 
> ## How would I deal with a situation like this?
> 
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/B4B355CC-BC3C-4A14-B7CF-B18919B0F3B8%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/B4B355CC-BC3C-4A14-B7CF-B18919B0F3B8%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Thomas\_Ardal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomas_ardal/32/7956_2.png) [@Thomas\_Ardal](https://discuss.elastic.co/u/Thomas_Ardal)\
**Post date:** [January 7, 2015, 7:44am UTC](https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518/3 "2015-01-07T07:44:26Z")

</div>

That was exactly what I was missing. I didn't create the repository named  
"elasticsearch\_logs" on cluster B. After I created it, the backup runs  
smoothly.

Thanks, David!

On Wednesday, January 7, 2015 8:31:08 AM UTC+1, David Pilato wrote:

> Did you create the repository on cluster B?  
> How?
> 
> --  
> David 😉  
> Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs
> 
> Le 7 janv. 2015 à 08:19, Thomas Ardal \<[thoma...@gmail.com](mailto:thoma...@gmail.com) \<javascript:\>\>  
> a écrit :
> 
> I'm using the snapshot/restore feature of Elasticsearch, together with the  
> Azure plugin to backup snapshots to Azure blob storage. Everything works  
> when doing snapshots from a cluster and restoring to the same cluster. Now  
> I'm in a situation where I want to restore an entirely new cluster (let's  
> call that cluster b) from a snapshot generated from cluster a. When I run a  
> restore request on cluster b, I get a 404. Doing a \_status call on the  
> snapshot, I get the same error:
> 
> {"error":"RepositoryMissingException[[elasticsearch\_logs] missing]","status":404}
> 
> The new cluster is configured with the Azure plugin and the same settings for Azure. I guess the error is caused by the fact, that Elasticsearch generates some metadata about the snapshots and store them locally in a the \_snapshot index and this index is not on the new cluster. The same error is happening if I delete the data dir on cluster a and try to restore cluster a from a snapshot.
> 
> How would I deal with a situation like this?
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/b5a0147c-cc38-4947-8530-0c66eb00fc2a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/2b1da7ff-9dd5-49ab-bd1f-34b38b1e0645%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/2b1da7ff-9dd5-49ab-bd1f-34b38b1e0645%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:40am UTC](https://discuss.elastic.co/t/repositorymissingexception-when-restoring-into-a-new-cluster/21518/4 "2017-07-06T00:40:22Z")

</div>


