# Reset password api is not working

**URL:** <https://discuss.elastic.co/t/reset-password-api-is-not-working/296028>\
**Category:** Elasticsearch\
**Created:** [February 2, 2022, 6:05am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028 "2022-02-02T06:05:14Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sunil\_Bhakar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunil_bhakar/32/99794_2.png) [@Sunil\_Bhakar](https://discuss.elastic.co/u/Sunil_Bhakar)\
**Post date:** [February 2, 2022, 6:05am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028/1 "2022-02-02T06:05:14Z")

</div>

{  
"error" : {  
"root\_cause" : [  
{  
"type" : "status\_exception",  
"reason" : "Cluster state has not been recovered yet, cannot write to the [null] index"  
}  
],  
"type" : "status\_exception",  
"reason" : "Cluster state has not been recovered yet, cannot write to the [null] index"  
},  
"status" : 503  
}

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 2, 2022, 6:17am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028/2 "2022-02-02T06:17:41Z")

</div>

Welcome.

I believe it means that your Elasticsearch cluster has not started yet.  
Try again.

If it doesn't work, share your Elasticsearch logs.

Please format your code, logs or configuration files using `</>` icon as explained in [this guide](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and not the citation button. It will make your post more readable.

Or use markdown style like:

````
```
CODE
```

````

This is the icon to use if you are not using markdown format:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/e/7e6e239431ec2d71cbf1beef741f2e93e7cc762c.jpg)

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.  
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.

---

<div class="post-metadata">

**Author:** ![Sunil\_Bhakar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunil_bhakar/32/99794_2.png) [@Sunil\_Bhakar](https://discuss.elastic.co/u/Sunil_Bhakar)\
**Post date:** [February 2, 2022, 7:17am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028/3 "2022-02-02T07:17:25Z")

</div>

Thanks for your reply,  
I have 3 nodes in my cluster  
node 1 master  
node 2 master and data  
node 3 data  
the node 2 and node 3 working fine  
I stopped the node 1 and start again the following error I am getting

 ![elasticerror](https://us1.discourse-cdn.com/elastic/original/3X/a/6/a647c365d8e079c3508875988360f90ada0a4142.png)

[2022-02-01T23:01:51,590][WARN][o.e.d.SeedHostsResolver] [node1] failed to resolve host [node2]  
java.net.UnknownHostException: node2  
at java.net.InetAddress$CachedAddresses.get(InetAddress.java:800) ~[?:?]  
at java.net.InetAddress.getAllByName0(InetAddress.java:1495) ~[?:?]  
at java.net.InetAddress.getAllByName(InetAddress.java:1354) ~[?:?]  
at java.net.InetAddress.getAllByName(InetAddress.java:1288) ~[?:?]  
at org.Elasticsearch.transport.TcpTransport.parse(TcpTransport.java:532) ~[Elasticsearch-7.7.0.jar:7.7.0]  
at org.Elasticsearch.transport.TcpTransport.addressesFromString(TcpTransport.java:474) ~[Elasticsearch-7.7.0.jar:7.7.0]  
at org.Elasticsearch.transport.TransportService.addressesFromString(TransportService.java:822) ~[Elasticsearch-7.7.0.jar:7.7.0]  
at org.Elasticsearch.discovery.SeedHostsResolver.lambda$resolveHostsLists$0(SeedHostsResolver.java:144) ~[Elasticsearch-7.7.0.jar:7.7.0]  
at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]  
at org.Elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:633) ~[Elasticsearch-7.7.0.jar:7.7.0]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130) [?:?]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630) [?:?]  
at java.lang.Thread.run(Thread.java:832) [?:?]  
[2022-02-01T23:01:51,687][INFO][o.e.x.s.a.AuthenticationService] [node1] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]  
[2022-02-01T23:01:51,796][INFO][o.e.x.s.a.AuthenticationService] [node1] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 2, 2022, 9:12am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028/4 "2022-02-02T09:12:27Z")

</div>

Please [read this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) about how to format.

Here your machine does not know how to resolve `node2`.  
You might need to use an IP address instead or add the `node2` in your `/etc/hosts`...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 2, 2022, 9:12am UTC](https://discuss.elastic.co/t/reset-password-api-is-not-working/296028/5 "2022-03-02T09:12:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
