# \[Resolved\]\[Kibana7.0.1\] Error occurs " Request Timeout after 30000ms" when starting kibana

**URL:** <https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968>\
**Category:** Logstash\
**Created:** [September 25, 2019, 6:56am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968 "2019-09-25T06:56:09Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![cheriemilk](https://avatars.discourse-cdn.com/v4/letter/c/c37758/32.png) [@cheriemilk](https://discuss.elastic.co/u/cheriemilk)\
**Post date:** [September 25, 2019, 6:56am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968/1 "2019-09-25T06:56:09Z")

</div>

Hi Team,

I was running into below error when starting kibana, and ES side has no error and exception.

> ```
> log [06:49:29.171] [info][status][plugin:spaces@7.0.1] Status changed from yellow to green - Ready
> error [06:49:57.442] [warning][process] UnhandledPromiseRejectionWarning: Error: Request Timeout after 30000ms
> at C:\elkstack\kibana-7.0.1-windows-x86_64\kibana-7.0.1-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:355:15
> at Timeout.<anonymous> (C:\elkstack\kibana-7.0.1-windows-x86_64\kibana-7.0.1-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:384:7)
> at ontimeout (timers.js:436:11)
> at tryOnTimeout (timers.js:300:5)
> at listOnTimeout (timers.js:263:5)
> at Timer.processTimers (timers.js:223:10)
> at emitWarning (internal/process/promises.js:81:15)
> at emitPromiseRejectionWarnings (internal/process/promises.js:120:9)
> at process._tickCallback (internal/process/next_tick.js:69:34)
> error [06:49:57.460] [warning][process] Error: Request Timeout after 30000ms
> at C:\elkstack\kibana-7.0.1-windows-x86_64\kibana-7.0.1-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:355:15
> at Timeout.<anonymous> (C:\elkstack\kibana-7.0.1-windows-x86_64\kibana-7.0.1-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:384:7)
> at ontimeout (timers.js:436:11)
> at tryOnTimeout (timers.js:300:5)
> at listOnTimeout (timers.js:263:5)
> at Timer.processTimers (timers.js:223:10)
> 
> ```

How to resolve it? Any other information needed, please let me know.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 25, 2019, 7:16am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968/2 "2019-09-25T07:16:26Z")

</div>

What is the output of the ‘\_cluster/health’ api in Elasticsearch?

---

<div class="post-metadata">

**Author:** ![cheriemilk](https://avatars.discourse-cdn.com/v4/letter/c/c37758/32.png) [@cheriemilk](https://discuss.elastic.co/u/cheriemilk)\
**Post date:** [September 25, 2019, 8:44am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968/3 "2019-09-25T08:44:03Z")

</div>

> [@Christian\_Dahlqvist](#):
>
> \_cluster/health

@Christian_Dahlqvist, here's the response. I found the same error occurs when deleting the index from Kibana -\> Management-\> Index Management

> ```
> {
> "cluster_name" : "elasticsearch",
> "status" : "yellow",
> "timed_out" : false,
> "number_of_nodes" : 1,
> "number_of_data_nodes" : 1,
> "active_primary_shards" : 21,
> "active_shards" : 21,
> "relocating_shards" : 0,
> "initializing_shards" : 0,
> "unassigned_shards" : 13,
> "delayed_unassigned_shards" : 0,
> "number_of_pending_tasks" : 1,
> "number_of_in_flight_fetch" : 0,
> "task_max_waiting_in_queue_millis" : 0,
> "active_shards_percent_as_number" : 61.76470588235294
> }
> 
> ```

And I found below warrning: does it matter?  
`

> log [08:44:58.841] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml

`

---

<div class="post-metadata">

**Author:** ![chandu5565](https://avatars.discourse-cdn.com/v4/letter/c/c57346/32.png) [@chandu5565](https://discuss.elastic.co/u/chandu5565)\
**Post date:** [September 25, 2019, 10:38am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968/4 "2019-09-25T10:38:29Z")

</div>

Add elasticsearch.requestTimeout : 90000 to your kibana.yml.  
Refer below link to configure kibana

[https://www.elastic.co/guide/en/kibana/current/settings.html](https://www.elastic.co/guide/en/kibana/current/settings.html)

When using reporting you have to set xpack.reporting.encryptionKey in kibana.yml if not kibana will generate it randomly.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 23, 2019, 10:38am UTC](https://discuss.elastic.co/t/resolved-kibana7-0-1-error-occurs-request-timeout-after-30000ms-when-starting-kibana/200968/5 "2019-10-23T10:38:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
