# ResposeError: illegal\_argument\_exception when create SLO

**URL:** <https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135>\
**Category:** SLO\
**Created:** [February 13, 2024, 7:55am UTC](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135 "2024-02-13T07:55:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![01052346103a](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/01052346103a/32/131680_2.png) [@01052346103a](https://discuss.elastic.co/u/01052346103a)\
**Post date:** [February 13, 2024, 7:55am UTC](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135/1 "2024-02-13T07:55:55Z")

</div>

Hi i got error when i create SLO with Kibana UI

I have no idea what to do solve this problem

ES v8.11.4  
Kibana v8.11.4

```auto
[2024-02-13T16:08:55.366+09:00][ERROR][plugins.observability] Cannot preview SLO transform [slo-bf57a7c0-ca3e-11ee-993e-57e17f10a2e4-1]
[2024-02-13T16:08:55.962+09:00][ERROR][plugins.observability] ResponseError: illegal_argument_exception
        Root causes:
                illegal_argument_exception: must specify at least one document in [docs]
    at KibanaTransport.request (/home/qwer/kibana/kibana-8.11.4/node_modules/@elastic/transport/lib/Transport.js:479:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at KibanaTransport.request (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/core-elasticsearch-client-server-internal/src/create_transport.js:51:16)
    at Transform.previewTransform (/home/qwer/kibana/kibana-8.11.4/node_modules/@elastic/elasticsearch/lib/api/api/transform.js:129:16)
    at retryTransientEsErrors (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/observability-plugin/server/utils/retry.js:35:12)
    at DefaultTransformManager.preview (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/observability-plugin/server/services/slo/transform_manager.js:45:7)
    at CreateSLO.execute (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/observability-plugin/server/services/slo/create_slo.js:40:7)
    at handler (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/observability-plugin/server/routes/slo/route.js:61:22)
    at /home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/observability-plugin/server/routes/register_routes.js:54:22
    at Router.handle (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/core-http-router-server-internal/src/router.js:154:30)
    at handler (/home/qwer/kibana/kibana-8.11.4/node_modules/@kbn/core-http-router-server-internal/src/router.js:113:50)
    at exports.Manager.execute (/home/qwer/kibana/kibana-8.11.4/node_modules/@hapi/hapi/lib/toolkit.js:60:28)
    at Object.internals.handler (/home/qwer/kibana/kibana-8.11.4/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/home/qwer/kibana/kibana-8.11.4/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/home/qwer/kibana/kibana-8.11.4/node_modules/@hapi/hapi/lib/request.js:371:32)
    at Request._execute (/home/qwer/kibana/kibana-8.11.4/node_modules/@hapi/hapi/lib/request.js:281:9)

```

---

<div class="post-metadata">

**Author:** ![framsouza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/framsouza/32/95958_2.png) [@framsouza](https://discuss.elastic.co/u/framsouza)\
**Post date:** [February 13, 2024, 2:18pm UTC](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135/2 "2024-02-13T14:18:47Z")

</div>

Hey,

Could you kindly share the query we're using? Were you able to execute the same query in the Dev Console to verify if it returns the expected results?

Just a reminder that SLO is generally available in version 8.12.0, so I would recommend using this version.

---

<div class="post-metadata">

**Author:** ![01052346103a](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/01052346103a/32/131680_2.png) [@01052346103a](https://discuss.elastic.co/u/01052346103a)\
**Post date:** [February 15, 2024, 10:16am UTC](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135/3 "2024-02-15T10:16:01Z")

</div>

> [@01052346103a](#):
>
> idea

OH thanks a lot  
After i version up to 8.12 , it works well  
Really thank you
