# Restoration of data from Primary to Backup cluster

**URL:** <https://discuss.elastic.co/t/restoration-of-data-from-primary-to-backup-cluster/370322>\
**Category:** Elastic Search\
**Created:** [November 11, 2024, 2:28pm UTC](https://discuss.elastic.co/t/restoration-of-data-from-primary-to-backup-cluster/370322 "2024-11-11T14:28:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sowr0704](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sowr0704/32/139446_2.png) [@sowr0704](https://discuss.elastic.co/u/sowr0704)\
**Post date:** [November 11, 2024, 2:28pm UTC](https://discuss.elastic.co/t/restoration-of-data-from-primary-to-backup-cluster/370322/1 "2024-11-11T14:28:17Z")

</div>

Hi All,

Scenario:  
I have 2 GKE cluster [1. Primary cluster & 2. Backup Cluster].  
The ESK is running in both primary & backup cluster.  
The snapshots are taken at regular intervals in primary cluster.  
When I try to restore the data from Primary to back up cluster, 10-15 indices are going into red status. rest of the indices are in green

When I try to list the latest snapshot, it throws the below error  
"error": {  
"root\_cause": [  
{  
"type": "snapshot\_missing\_exception.

Manually I found the latest snapshot name and tried to restore it.  
Few indices are going into red.

It was successful only once, after that same issue happens

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 9, 2024, 2:28pm UTC](https://discuss.elastic.co/t/restoration-of-data-from-primary-to-backup-cluster/370322/2 "2024-12-09T14:28:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
