# Restore elastic search from backup

**URL:** https://discuss.elastic.co/t/restore-elastic-search-from-backup/124885
**Category:** Elasticsearch
**Created:** [March 21, 2018, 1:28am UTC](https://discuss.elastic.co/t/restore-elastic-search-from-backup/124885 "2018-03-21T01:28:17Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![ak\_bharath](https://avatars.discourse-cdn.com/v4/letter/a/a6a055/32.png) [@ak\_bharath](https://discuss.elastic.co/u/ak_bharath)
#### Post date: [March 21, 2018, 1:28am UTC](https://discuss.elastic.co/t/restore-elastic-search-from-backup/124885/1 "2018-03-21T01:28:17Z")

</div>

Hi There,

I want to restore indexes from elasticsearch backup on a windows machine.

copied the zip file(es\_20170911) to a folder es\_backup and extracted it  
so the path is c:\backup\es\_backup\es\_20170911  
Step I had done are

register the repository in elastic search

for that

I had done curl -XPUT '[http://localhost:9200/\_snapshot/es\_snap?verify=false&pretty](http://localhost:9200/_snapshot/es_snap?verify=false&pretty)' -d '{"type":"fs", "settings":{"location":"\\PC-ASSET-2\backup\es-backup\es\_backup\_20170911","compress":true}}'

I am getting the following error

Invoke-WebRequest : Parameter cannot be processed because the parameter name 'd' is ambiguous. Possible matches  
include: -DisableKeepAlive -Debug.  
At line:1 char:67

- curl -XPUT 'localhost:9200/\_snapshot/es\_snap?verify=false&pretty' -d '{"type":"f ...
- 

```
                                                              ~~

```

  - CategoryInfo : InvalidArgument: (🙂 [Invoke-WebRequest], ParameterBindingException
  - FullyQualifiedErrorId : AmbiguousParameter,Microsoft.PowerShell.Commands.InvokeWebRequestCommand

Please help me this issue to be resolved.

I had tried with 127.0.0.1 instead of localhost and tried removing d option and several combinations but the error is not get resolved.

The above steps I had tried in windows administrator powershell

I had tried the same above steps on postman with put and url with raw plain text option. it is throwing 406 not acceptable erro

Step:2

#curl -XPOST "localhost:9200/\_snapshot/my\_backup/snapshot\_1/\_restore?wait\_for\_completion=true"

Is this the above command I have use after registering the repository? Please confirm.

Please help me in resolving this issue.

With Many Thanks,

Bharath AK

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 18, 2018, 1:28am UTC](https://discuss.elastic.co/t/restore-elastic-search-from-backup/124885/2 "2018-04-18T01:28:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
