# Restore from snapshot fails with no recovery information

**URL:** <https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355>\
**Category:** Elasticsearch\
**Tags:** snapshot-and-restore\
**Created:** [August 3, 2021, 5:45pm UTC](https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355 "2021-08-03T17:45:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bill\_d](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bill_d/32/90623_2.png) [@bill\_d](https://discuss.elastic.co/u/bill_d)\
**Post date:** [August 3, 2021, 5:45pm UTC](https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355/1 "2021-08-03T17:45:53Z")

</div>

I have 2 similarly configured 3 node elasticsearch clusters. Both run 7.10.2, but one is bigger than the other.

I'm trying to restore an index from a snapshot. In the small cluster, the restore takes about 3 minutes, during which the cluster is yellow. In the big cluster, starting the restore causes the cluster to go red. I waited some time, but had to delete the restored index while it was red so the cluster would be up.

Both clusters have a repository with scheduled backups.  
`GET /_cat/snapshots/gcs_repository?v`  
Shows 4 snapshots, all have status = "SUCCESS".  
To give an idea of the size, the small cluster has duration between 1-2 minutes. The large cluster has 4-12 minutes.

`POST /_snapshot/gcs_repository/_verify`  
Shows 3 nodes.

`GET /_snapshot/gcs_repository/`  
Shows the repository, the only difference here is that the large cluster has `"max_snapshot_bytes_per_sec" : "320mb"`.

When I start the restore, I issue a command like:

```auto
POST /_snapshot/gcs_repository/daily-backup-0/_restore
{
  "indices": "foo-000001",
  "rename_pattern": "foo-000001",
  "rename_replacement": "foo-test0"
}

```

Both clusters respond with "accepted".  
The small cluster's health goes to yellow, because there is a new index foo-test0 that is yellow. The large cluster goes red, as is the new index.

Then I check the status with  
`GET /foo-test0/_recovery`  
And the small cluster responds with a bunch of details about the recovery process, including the percent done. Awesome.

But the large cluster responds with  
`{ }`

Since the large cluster is being used, I can't leave it red for long, so i delete the new index and it goes back to green.

- Any ideas what is going on?
- Is there any command to check the status of my snapshots for damage?
- Is there a way to restore the snapshot without affecting the cluster's health?

Thanks for any help, Bill

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [August 3, 2021, 6:42pm UTC](https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355/2 "2021-08-03T18:42:56Z")

</div>

> [@bill\_d](#):
>
> The large cluster goes red, as is the new index.... But the large cluster responds with  
> `{ }`

So that indicates there's no recoveries going on, presumably because they've failed quickly. I would expect there to be helpful details in the logs, but the [cluster allocation explain API](https://www.elastic.co/guide/en/elasticsearch/reference/current/cluster-allocation-explain.html) is always the best way to diagnose non-`green` health.

---

<div class="post-metadata">

**Author:** ![bill\_d](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bill_d/32/90623_2.png) [@bill\_d](https://discuss.elastic.co/u/bill_d)\
**Post date:** [August 3, 2021, 7:43pm UTC](https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355/3 "2021-08-03T19:43:25Z")

</div>

Thanks very much David. I totally forgot to check the logs!

There were 4 lines of output each time I tried to restore. The first three end with:  
`node [o3XmuKUVRwi_nL9WIy0LSA] would have less than the required threshold of 0b free (currently 46.4gb free, estimated shard size is 131.4gb), preventing allocation`

So it's pretty clear what's wrong.  
Thank you!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 31, 2021, 7:43pm UTC](https://discuss.elastic.co/t/restore-from-snapshot-fails-with-no-recovery-information/280355/4 "2021-08-31T19:43:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
